Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 296423 - sys-apps/hal: pkg_postinst elog info should be summarized a bit
Summary: sys-apps/hal: pkg_postinst elog info should be summarized a bit
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
Depends on: 313389
Blocks:
  Show dependency tree
 
Reported: 2009-12-10 17:02 UTC by Pacho Ramos
Modified: 2011-09-18 09:28 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2009-12-10 17:02:08 UTC
I think that current elog information is too much for most of the cases:
        elog "Access to hal is not protected by either policykit or the plugdev group."

I am not sure what this really means and if it's really needed having the following message also:

        elog "If you have problems discovering/configuring hardware, try adding"
        elog "yourself to plugdev."
        echo

Why not show the following message only  "if ! has_version sys-power/acpid"
        elog "IF you have additional applications which consume ACPI events, you"
        elog "should consider installing acpid to allow applications to share ACPI"
        elog "events."

Related with the following, I would replace it by pointing people to http://www.gentoo.org/doc/en/xorg-config.xml#doc_chap4 :

        if use X ; then
                echo
                elog "If you wish to use a non US layout, you may do so by executing:"
                elog "setxkbmap <layout> or by utilizing your Desktop Environment's"
                elog "Keyboard Layout Settings mechanism."
                elog "Under GNOME, this is gnome-keyboard-properties, and under KDE"
                elog "it is kxkb."
        fi
        echo

Why not show the following when laptop USE flag is not set?
        elog "In order have suspend/hibernate function with HAL or apps that use HAL"
        elog "(such as gnome-power-manager), you should build HAL with the laptop"
        elog "useflag which will install pm-utils."

Thanks a lot :-)

Reproducible: Always
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-12-10 21:52:11 UTC
most of this sound sane, although I do not agree with the acpid bit since acpid is not the only way to consume acpi avents and you'd also need to make sure it is actually running.
Comment 2 Horst Prote 2010-07-13 13:32:41 UTC
(In reply to comment #0)
> I think that current elog information is too much for most of the cases:
>         elog "Access to hal is not protected by either policykit or the plugdev
> group."
> 
> I am not sure what this really means ...
I think there's a small typo and it should be "... is now(!) protected by ...".
Comment 3 Daniel Gryniewicz (RETIRED) gentoo-dev 2010-07-14 12:35:38 UTC
Good catch on the s/not/now/.  I've updated that.  As for the rest, I'm not sure how much work to put into overhauling the info on hal, as it's deprecated, and (hopefully) going away.
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2011-09-18 09:28:06 UTC
sys-apps/hal was removed from tree wrt #313389, closing as OBSOLETE