Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 29634 - Rebuild modules after installing new kernel
Summary: Rebuild modules after installing new kernel
Status: RESOLVED DUPLICATE of bug 34921
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Conceptual/Abstract Ideas (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 94953 (view as bug list)
Depends on: 1991
Blocks:
  Show dependency tree
 
Reported: 2003-09-25 22:15 UTC by Bill Cavalieri
Modified: 2007-01-11 12:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Cavalieri 2003-09-25 22:15:14 UTC
Would be easier for me to change kernels if ebuilds that build modules had a
flag that could be queried on, ie iptables, alsa.

I know there aren't that many, but I forgot sometimes to rebuild packages, and
when offering binaries on my binhost, I have to remember to delete the packages
those packages so they won't be downloaded (if client has different kernel than
build server).

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 SpanKY gentoo-dev 2003-09-26 03:38:25 UTC
`qpkg -f /lib/modules`
Comment 2 Bill Cavalieri 2003-09-27 09:43:49 UTC
qpkg -f /lib/modules doesn't return any results for me.  Do I need to type
anything else along with it?

I have alsa, iptables, & vmare that I know should show up.
Comment 3 SpanKY gentoo-dev 2003-09-27 10:55:49 UTC
iptables and vmware should not show up, they dont install kernel modules

alsa-drivers should show up ... try `qpkg -l alsa-drivers`
Comment 4 Paul Varner (RETIRED) gentoo-dev 2003-12-02 13:44:57 UTC
Since I have seen several questions like this on the gentoo-user mailing list, and the fact that I have been bitten a couple of times by forgetting to recompile packages after recompiling a kernel.  I created kernelmod-rebuild.  See bug 34921 where I submitted the ebuild for where to get the ebuild.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-06-04 00:39:19 UTC
*** Bug 94953 has been marked as a duplicate of this bug. ***
Comment 6 Pierre Poissinger 2005-06-23 09:59:48 UTC
My 2 cents:
Actually the emerge of vmware don't directly install kernel modules, but the
next step to make it work after emerge is actually to run the vmware-config and
it will compile at least 1 module: The vmware monitor... And if you need
networking in the guest OS, you need additional modules... (cf
/opt/vmware/bin/vmware-config.pl)
Comment 7 Jason Stubbs (RETIRED) gentoo-dev 2005-07-28 07:24:59 UTC
Putting a hold on feature requests for portage as they are drowning out the 
bugs. Most of these features should be available in the next major version of 
portage. But for the time being, they are just drowning out the major bugs and 
delaying the next version's progress. 
 
Any bugs that contain patches and any bugs for etc-update or dispatch-conf can 
be reopened. Sorry, I'm just not good enough with bugzilla. ;) 
Comment 8 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2006-01-02 21:30:16 UTC
should probably wait on dep-level tracking to get done, then it's usually no longer a special case ( module providing ebuilds should already dep on kernel-soruces ).
Comment 9 Marius Mauch (RETIRED) gentoo-dev 2007-01-11 12:22:47 UTC
Reopening for duping
Comment 10 Marius Mauch (RETIRED) gentoo-dev 2007-01-11 12:24:28 UTC

*** This bug has been marked as a duplicate of bug 34921 ***