Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 295777 - gentoo-sources-2.6.32: intel_bufmgr_gem.c:825: Error setting to CPU domain 626: Input/output error
Summary: gentoo-sources-2.6.32: intel_bufmgr_gem.c:825: Error setting to CPU domain 62...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo X packagers
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-04 22:37 UTC by Tassilo Horn
Modified: 2009-12-18 21:35 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
My Xorg.0.log when starting X with 2.6.32 kernel (Xorg.0.log,18.57 KB, text/plain)
2009-12-15 16:51 UTC, Tassilo Horn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tassilo Horn 2009-12-04 22:37:40 UTC
Since I updated to gentoo-sources-2.6.32, X11 doesn't work anymore.  It starts
up, but I only get a screen with artifacts.

The error occurs with various domain numbers.

I tried rebuilding libdrm, xf86-video-intel, mesa, and xorg-server, but the
problem persits.  So currently, there's no X11 for me at all.  (One of those
moments when it cashes out to know how to use a text browser.)

Here are the versions of the relevant packages I have installed:

*  x11-libs/libdrm
      Latest version available: 2.4.15
      Latest version installed: 2.4.15
      Size of files: 408 kB
      Homepage:      http://dri.freedesktop.org/
      Description:   X.Org libdrm library
      License:       MIT

*  x11-base/xorg-server
      Latest version available: 1.7.3
      Latest version installed: 1.7.3
      Size of files: 4,799 kB
      Homepage:      http://xorg.freedesktop.org/
      Description:   X.Org X servers
      License:       MIT

*  x11-drivers/xf86-video-intel
      Latest version available: 2.9.1
      Latest version installed: 2.9.1
      Size of files: 770 kB
      Homepage:      http://xorg.freedesktop.org/
      Description:   X.Org driver for Intel cards
      License:       MIT

*  media-libs/mesa
      Latest version available: 7.5.2
      Latest version installed: 7.5.2
      Size of files: 4,284 kB
      Homepage:      http://mesa3d.sourceforge.net/
      Description:   OpenGL-like graphic library for Linux
      License:       LGPL-2



Reproducible: Always




emerge --info
Portage 2.1.7.10 (default/linux/amd64/10.0/desktop, gcc-4.4.2, glibc-2.11-r1, 2.6.32-gentoo x86_64)
=================================================================
System uname: Linux-2.6.32-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 04 Dec 2009 21:30:01 +0000
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r2
dev-lang/python:     2.6.4, 3.1.1-r1
dev-python/pycrypto: 2.1.0_beta1
dev-util/cmake:      2.8.0
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.3
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.64
sys-devel/automake:  1.10.2, 1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://de-mirror.org/distro/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://mirror.netcologne.de/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://mirror.netcologne.de/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-z,now"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/emacs /usr/local/overlays/private"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa amd64 aspell avahi berkdb branding bzip2 cairo caps cdr cleartype cli consolekit cracklib crypt cups cxx dbus djvu dri dts dvd dvdr dvi eds emacs emboss encode evo exif ffmpeg firefox flac fortran gdbm gif gmp gnutls gpg gpm gstreamer gtk hal iconv idn imagemagick ioctl ipv6 jpeg libnotify mad mikmod mmap mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin ntp ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd qt3 qt3support qt4 quicktime raw readline reflection samba schroedinger sdl session slp smp spl sqlite sse sse2 ssl ssse3 startup-notification svg sysfs syslog t1lib taglib tcpd theora thunar tiff truetype udev unicode usb vorbis webkit x264 xcb xcomposite xft xinerama xml xorg xpm xrandr xulrunner xv xvid zeroconf zlib zsh-completion" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Sergei Danilov 2009-12-06 21:55:49 UTC
I can confirm the same behavior with xf86-video-intel and gentoo-sources-2.6.32.
I see only screen artifacts when kdm is loaded.I can only move the mouse.
all works ok with gentoo-sources-2.6.31-r6
Comment 2 Jeff Mitchell 2009-12-07 13:57:11 UTC
I also have this problem, with both latest versions of xorg 1.6 and 1.7.
Comment 3 Andrew Evans 2009-12-09 21:20:53 UTC
I too have this problem, however, it only occurs on one of two identical machines. Both boxes are HP dc5700 desktops w/Intel Core 2 6600 CPUs w/965Q graphics chipset. X was working fine with gentoo-sources-2.6.32 on machine A. Machine A's hard drive was then swapped into machine B, and machine B suffered this problem.

I'm playing around with BIOS settings to see if that makes any difference.

Also, I *think* machine A had 2GB of RAM. Machine B has 4GB of RAM. I might try removing 2GB to see if that makes any difference.

BTW my arch is amd64 too.
Comment 4 Andrew Evans 2009-12-09 21:30:46 UTC
Removing 2GB RAM from machine B "fixes" the problem with gentoo-sources-2.6.32.
Comment 5 Tassilo Horn 2009-12-09 21:49:43 UTC
Very interesting, I also have 4 GB of RAM (which I need at work, so removing is not a fix for me).
Comment 6 I am 2009-12-14 18:59:15 UTC
I am using 2.6.32 with xf86-video-intel , and CAN´T confirm this behavior.

Im also using 4GB DDR3 RAM in my Lenovo x301.

All working perfect together
Comment 7 Tassilo Horn 2009-12-15 16:51:37 UTC
Created attachment 213104 [details]
My Xorg.0.log when starting X with 2.6.32 kernel

Even ofter updating to

  x11-base/xorg-server-1.7.3.901 USE="hal ipv6 nptl sdl xorg -debug -dmx -kdrive -minimal -tslib"
  x11-libs/libdrm-2.4.16 USE="-debug"
  media-libs/mesa-7.7_rc2  USE="nptl xcb -debug -gallium -motif -pic" VIDEO_CARDS="intel"
  x11-drivers/xf86-video-intel-2.9.1 USE="dri -debug"

I have the problem with a 2.6.32 kernel. Now, I first get those artifacts, then the screen turns blank and I have an "underline cursor" in the top left corner of the screen. After that, the whole computer is not responsible anymore (I didn't test sshing to it, though), and I have to shut down using Magic SysRQ keys.

My Xorg.0.log (this attachment) contains the error:

  (EE) intel(0): failed to set mode: Operation not permitted(II) intel(0): EDID vendor "LEN", prod id 16464
Comment 8 R Bar-On 2009-12-17 18:33:45 UTC
same issue here, all packages latest unstable plus x11 overlay (but not live).  Works fine with 2.6.31-r6, but not with 2.6.32
Comment 9 R Bar-On 2009-12-17 18:40:13 UTC
anyone tried disabling PAT? (either on the kernel command line or in kernel config)
Comment 10 R Bar-On 2009-12-17 19:37:56 UTC
never mind, PAT makes no difference.
Comment 11 R Bar-On 2009-12-17 19:58:34 UTC
this might be useful: http://groups.google.com/group/linux.debian.bugs.dist/browse_thread/thread/543d6ac539cb0efa/3b9d5efa93764516?#3b9d5efa93764516

The commit mentioned at the end of that is pretty old and tricky to revert, but if anyone wants to try....
Comment 12 R Bar-On 2009-12-18 18:29:26 UTC
this bug is still present with 2.6.33-rc1, from git.

cc'ing kernel.  Any chance someone can look at this?
Comment 13 Mike Pagano gentoo-dev 2009-12-18 21:04:25 UTC
Seems like this was already reported upstream
Comment 14 Rémi Cardona gentoo-dev 2009-12-18 21:35:26 UTC
Let's track the bug upstream directly.

Thanks