Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 295277 - sys-apps/openrc net script can't connected to a ap name like 'abc-ed' use iwconfig
Summary: sys-apps/openrc net script can't connected to a ap name like 'abc-ed' use iwc...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2009-12-01 05:33 UTC by wd
Modified: 2009-12-02 01:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description wd 2009-12-01 05:33:26 UTC
I try to use iwconfig to connect a wep ap named like 'abc-ed'.

I'v set in /etc/conf.d/net like this:
modules_eth1=( "iwconfig" )

When I start net.eth1, will got this error:
/etc/init.d/../conf.d/net: line 5: key_abc-ed=123456: command not found

It seemes like a bash script varible name limit.

Reproducible: Always

Steps to Reproduce:
1. rename wifi essid to a name not contain '-' and other char that bash varible not permit.
Comment 1 Harald van Dijk (RETIRED) gentoo-dev 2009-12-01 21:47:00 UTC
That's not supposed to work, you should use key_abc_ed=... (using an underscore). See the installed net.example file's section "WIRELESS SSID IN VARIABLES". If it still doesn't work with that change, please re-open this bug.
Comment 2 wd 2009-12-02 01:16:46 UTC
Oh, yes, it's worked. Thks.