Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 294313 - dev-perl/IO-AIO fails tests
Summary: dev-perl/IO-AIO fails tests
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: perl-testfailure
  Show dependency tree
 
Reported: 2009-11-23 21:58 UTC by Patrick Lauer
Modified: 2014-06-28 17:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
TEST_VERBOSE=1 emerge -av =dev-perl/IO-AIO-3.3.1 (IO-AIO.txt,7.54 KB, text/plain)
2009-12-02 12:04 UTC, Torsten Veller (RETIRED)
Details
Build log (IO-AIO-3.6:20100331-233829.log,6.70 KB, text/plain)
2010-04-01 09:42 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Lauer gentoo-dev 2009-11-23 21:58:06 UTC
>>> Source compiled.
make -j5 test TEST_VERBOSE=0
PERL_DL_NONLAZY=1 /usr/bin/perl5.8.8 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00_load.......^M                                                                             ^Mt/00_load.......ok 1/3^M                                                                             ^Mt/00_load.......ok
t/01_stat.......^M                                                                             ^Mt/01_stat.......dubious
        Test returned status 0 (wstat 11, 0xb)
DIED. FAILED tests 1-10
        Failed 10/10 tests, 0.00% okay
t/02_read.......^M                                                                             ^Mt/02_read.......dubious
        Test returned status 0 (wstat 11, 0xb)
DIED. FAILED tests 1-2
        Failed 2/2 tests, 0.00% okay
t/03_errors.....^M                                                                             ^Mt/03_errors.....dubious
        Test returned status 0 (wstat 11, 0xb)
DIED. FAILED tests 1-12
        Failed 12/12 tests, 0.00% okay
t/04_fork.......^M                                                                             ^Mt/04_fork.......ok 1/9^M                                                                             ^Mt/04_fork.......ok
t/05_readdir....^M                                                                             ^Mt/05_readdir....ok 1/12^M                                                                             ^Mt/05_readdir....dubious
        Test returned status 0 (wstat 11, 0xb)
DIED. FAILED tests 2-12
        Failed 11/12 tests, 8.33% okay
t/06_group......^M                                                                             ^Mt/06_group......ok 1/12^M                                                                             ^Mt/06_group......ok
t/07_feeder.....^M                                                                             ^Mt/07_feeder.....ok 1/6^M                                                                             ^Mt/07_feeder.....ok
Failed Test    Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/01_stat.t       0    11    10   20 200.00%  1-10
t/02_read.t       0    11     2    4 200.00%  1-2
t/03_errors.t     0    11    12   24 200.00%  1-12
t/05_readdir.t    0    11    12   22 183.33%  2-12
Failed 4/8 test scripts, 50.00% okay. 35/66 subtests failed, 46.97% okay.
make: *** [test_dynamic] Error 255
 * ERROR: dev-perl/IO-AIO-3.3.1 failed:
Comment 1 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-11-24 07:36:15 UTC
I can't reproduce this one at all here. Can you please provide the rest of the build log, and run with TEST_VERBOSE=1?
Comment 2 Torsten Veller (RETIRED) gentoo-dev 2009-12-02 12:04:36 UTC
Created attachment 211758 [details]
TEST_VERBOSE=1 emerge -av =dev-perl/IO-AIO-3.3.1
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-04-01 09:42:44 UTC
Created attachment 226087 [details]
Build log
Comment 4 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-06-28 17:28:38 UTC
Should be fine in the last stable.