Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 294269 - Regressions of app-emulation/qemu-kvm-0.12.1.1 against app-emulation/kvm-88-r1
Summary: Regressions of app-emulation/qemu-kvm-0.12.1.1 against app-emulation/kvm-88-r1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Doug Goldstein (RETIRED)
URL: http://sourceforge.net/tracker/?func=...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-23 19:11 UTC by Thomas Sachau
Modified: 2010-04-03 13:55 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Sachau gentoo-dev 2009-11-23 19:11:10 UTC
There are some regressions i found:

-strg+alt+f doesnt work any more, so no fullscreen switching
-strg+alt+f (without mouse grabbed) does still adjust the sdl window to the current screen size, but also screws up the content of the sdl window of kvm

The first one has an open upstream bug, down know about the second one since i currently cannot access sourceforge, where the kvm bugzilla is.
Comment 1 Doug Goldstein (RETIRED) gentoo-dev 2009-11-24 03:21:38 UTC
Can you please include the link to the upstream bug?
Comment 2 Priit Laes (IRC: plaes) 2009-12-06 19:30:33 UTC
qemu-0.11.1 has been released and its changelog mentions:
'Revert "vga: do not resize the screen on hw_invalidate"'

And yes, I can confirm this issue as regression since kvm ebuild was renamed to qemu-kvm.
Comment 3 Thomas Sachau gentoo-dev 2009-12-22 14:02:20 UTC
Ok, the issues with strg+alt-f seem to have been fixed, but i currently have some more issues:

-rebooting a WinXP client in fullscreen mode does, directly after reboot, resizes the WinXP screen (with wider black areas above and under the screen), then crashes qemu-kvm

-es1370 as sound option directly crashes qemu-kvm, when first sound should be played

-ac97 as sound option does crash qemu-kvm after some minutes, first allows to play some sound, but the sound sounds like from broken speakers.
Comment 4 Doug Goldstein (RETIRED) gentoo-dev 2009-12-23 05:31:55 UTC
You need to realize the change in upstream's development model. Previously they pulled an old version of qemu and applied kvm on top of that and worked in parallel to fix issues in the base code and in their own code. This is what the kvm-### releases were. They called this their "unstable" development. They switched to breaking the kvm bits out into manageable pieces and are rebasing their code atop newer qemu releases as they come now. They call that qemu-kvm-0.x.y and they consider these releases to be more "stable".

They have discontinued all work on the old kvm-## series but acknowledge regressions may happen since some items in the base qemu code might not have received fixes they've put into their own kvm-## code. They are actively working to try to get qemu upstream to adopt any and all fixes to the base code.
Comment 5 Dragos Delcea 2009-12-30 14:57:17 UTC
(In reply to comment #3)
...
> -es1370 as sound option directly crashes qemu-kvm, when first sound should be
> played

I can confirm this one: I have one winXP VM (with es1370 sound) that was working before but now crashes when first sound is played (qemu-kvm host process dies). Can't exactly pinpoint what caused it, as I'm not using the VM daily and in the mean time qemu-kvm, libvirt, virt-manager have gone through an upgrade. I'd say it is a qemu-kvm issue, though based on the qemu malloc error below:

LC_ALL=C PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.3.4:/usr/qt/3/bin HOME=/root USER=root XAUTHORITY=/home/someuser/.Xauthority DISPLAY=:0.0 /usr/bin/qemu -S -M pc-0.11 -enable-kvm -m 384 -smp 1 -name XP-NAT -uuid xxx -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/XP-NAT.monitor,server,nowait -monitor chardev:monitor -localtime -boot c -drive file=/dev/mapper/vgext-xp,if=ide,index=0,boot=on -drive file=/mnt/stuff/SOME.ISO,if=ide,media=cdrom,index=2 -net nic,macaddr=xxx,vlan=0,model=virtio,name=virtio.0 -net tap,fd=41,vlan=0,name=tap.0 -chardev pty,id=serial0 -serial chardev:serial0 -parallel none -usb -usbdevice tablet -vga cirrus -soundhw es1370 
char device redirected to /dev/pts/3
audio: Failed to create voice `es1370.adc'
audio: Failed to create voice `es1370.adc'
A bug was just triggered in audio_run_out
Save all your work and restart without audio
Please send bug report to av1474@comtv.ru
I am sorry
Context:
audio: played=882 sw->total_hw_samples_mixed=881
A bug was just triggered in audio_run_out
Context:
audio: played=881 sw->total_hw_samples_mixed=441
A bug was just triggered in audio_run_out
Context:
audio: played=1150 sw->total_hw_samples_mixed=940
qemu: malloc.c:4591: _int_malloc: Assertion `(unsigned long)(size) >= (unsigned long)(nb)' failed.

NOTE: the above command line was slightly edited to hide real uuid, mac, user name, iso.

So, would you like me to open a separate bug for this, or are you ok with tracking the issue in here?
Comment 6 Thomas Sachau gentoo-dev 2009-12-31 17:15:01 UTC
(In reply to comment #5)
> (In reply to comment #3)
> So, would you like me to open a separate bug for this, or are you ok with
> tracking the issue in here?

i think, we can track that issue here, also it might take some days or more, until i can have another look at it.
Comment 7 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-12-31 19:41:02 UTC
Please test with 0.12.1.2.
Comment 8 Dragos Delcea 2010-01-04 12:14:55 UTC
(In reply to comment #7)
> Please test with 0.12.1.2.
> 
tested with 0.12.1.2:
- with es1370: on first sound qemu process dies and I get the following in the logs:
===
A bug was just triggered in audio_run_out
Save all your work and restart without audio
Please send bug report to av1474@comtv.ru
I am sorry
Context:
audio: played=882 sw->total_hw_samples_mixed=881
A bug was just triggered in audio_run_out
Context:
audio: played=881 sw->total_hw_samples_mixed=441
===
- with ac97: it no longer crashes qemu, but sound is heavily distorted and following appears in the logs (same thing, it just goes on for as long as you play a sound):
===
A bug was just triggered in audio_run_out
Save all your work and restart without audio
Please send bug report to av1474@comtv.ru
I am sorry
Context:
audio: played=940 sw->total_hw_samples_mixed=501
A bug was just triggered in audio_run_out
Context:
audio: played=1383 sw->total_hw_samples_mixed=940
A bug was just triggered in audio_run_out
Context:
audio: played=1383 sw->total_hw_samples_mixed=782
A bug was just triggered in audio_run_out
Context:
audio: played=940 sw->total_hw_samples_mixed=100
===

I haven't seen the malloc error anymore, probably got rid of it by rebuilding world.
Comment 9 Dragos Delcea 2010-01-04 13:17:54 UTC
> I haven't seen the malloc error anymore, probably got rid of it by rebuilding
> world.
> 

additional info: I do have a segmentation fault in the system logs:
qemu[8937]: segfault at fdabfea2 ip b7374acc sp bf94d128 error 5 in libc-2.10.1.so[b72fd000+16c000]
Comment 10 Toralf Förster gentoo-dev 2010-01-17 09:36:40 UTC
http://bugs.gentoo.org/show_bug.cgi?id=294269 
:-)
Comment 11 Thomas Sachau gentoo-dev 2010-04-03 13:55:46 UTC
Seems like the main regressions are fixed, 0.12.3-r1 now includes a fix for the sound issue.