Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 294204 - dev-perl/Cairo-1.06.1 fails tests
Summary: dev-perl/Cairo-1.06.1 fails tests
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
: 387719 (view as bug list)
Depends on:
Blocks: perl-testfailure
  Show dependency tree
 
Reported: 2009-11-23 15:05 UTC by Patrick Lauer
Modified: 2012-06-04 03:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Lauer gentoo-dev 2009-11-23 15:05:27 UTC
>>> Source compiled.
make -j5 test TEST_VERBOSE=0
PERL_DL_NONLAZY=1 /usr/bin/perl5.8.8 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/Cairo.t ......... ^Mt/Cairo.t ......... 1/73
#   Failed test in t/Cairo.t at line 263.

#   Failed test in t/Cairo.t at line 279.
#          got: 'no-memory'
#     expected: 'success'
# Looks like you failed 2 tests of 73.
^M                           ^Mt/Cairo.t ......... Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/73 subtests
t/CairoFont.t ..... ^Mt/CairoFont.t ..... 1/20
#   Failed test in t/CairoFont.t at line 64.
#          got: 'no-memory'
#     expected: 'success'
# Looks like you failed 1 test of 20.
^M                           ^Mt/CairoFont.t ..... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/20 subtests
t/CairoFt.t ....... ^M                         ^Mt/CairoFt.t ....... skipped: need Cairo with FreeType support and Font::FreeType
t/CairoMatrix.t ... ^Mt/CairoMatrix.t ... 1/10 ^M                           ^Mt/CairoMatrix.t ... ok
t/CairoPath.t ..... ^Mt/CairoPath.t ..... 1/4 ^M                         ^Mt/CairoPath.t ..... ok
t/CairoPattern.t .. ^Mt/CairoPattern.t .. 1/25 ^M                           ^Mt/CairoPattern.t .. ok
t/CairoSurface.t .. ^Mt/CairoSurface.t .. 1/72 unknown surface type 4096 encountered at t/CairoSurface.t line 197.
^M                           ^Mt/CairoSurface.t .. ok

Test Summary Report
-------------------
t/Cairo.t       (Wstat: 512 Tests: 73 Failed: 2)
  Failed tests:  68, 73
  Non-zero exit status: 2
t/CairoFont.t   (Wstat: 256 Tests: 20 Failed: 1)
  Failed test:  12
  Non-zero exit status: 1
Files=7, Tests=204,  0 wallclock secs ( 0.10 usr  0.01 sys +  0.20 cusr  0.08 csys =  0.39 CPU)
Result: FAIL
Failed 2/7 test programs. 3/204 subtests failed.
make: *** [test_dynamic] Error 255
 * ERROR: dev-perl/Cairo-1.06.1 failed:


Portage 2.2_rc51 (default/linux/amd64/10.0/server, gcc-4.4.2, glibc-2.11-r0, 2.6.32-rc6-git6 x86_64)
=================================================================                                   
System uname: Linux-2.6.32-rc6-git6-x86_64-AMD_Phenom-tm-_9950_Quad-Core_Processor-with-gentoo-2.0.1
Timestamp of tree: Unknown
app-shells/bash:     4.0_p35
dev-lang/python:     2.6.4, 3.1.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r2
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/4.3/env /usr/kde/4.3/share/config /usr/kde/4.3/shutdown /usr/kde/4.4/env /usr/kde/4.4/share/config /usr/kde/4.4/shutdown /usr/kde/live/env /usr/kde/live/share/config /usr/kde/live/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests buildpkg distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict test unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://localhost/gentoo-portage"
USE="X acl amd64 apache2 berkdb bzip2 cli cracklib crypt cups dri fortran gcj gdbm gpm iconv ipv6 ldap mmx modules mudflap multilib mysql ncurses nls nptl nptlonly objc openmp pam pcre perl pppd python readline reflection session snmp spl sse sse2 ssl sysfs tcpd truetype unicode xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 David Abbott gentoo-dev 2010-01-09 22:39:05 UTC
Passed here on perl-5.10.1

>>> Source compiled.
make -j3 test TEST_VERBOSE=0 
PERL_DL_NONLAZY=1 /usr/bin/perl5.10.1 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/Cairo.t ......... ok     
t/CairoFont.t ..... ok     
t/CairoFt.t ....... skipped: need Cairo with FreeType support and Font::FreeType
t/CairoMatrix.t ... ok     
t/CairoPath.t ..... ok   
t/CairoPattern.t .. ok     
t/CairoSurface.t .. 1/72 unknown surface type 4096 encountered at t/CairoSurface.t line 197.
t/CairoSurface.t .. ok     
All tests successful.
Files=7, Tests=204,  1 wallclock secs ( 0.06 usr  0.01 sys +  0.33 cusr  0.09 csys =  0.49 CPU)
Result: PASS

emerge --info dev-perl/Cairo
Portage 2.1.7.16 (default/linux/amd64/10.0/desktop, gcc-4.4.2, glibc-2.11-r1, 2.6.30-gentoo-r5 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.30-gentoo-r5-x86_64-Dual-Core_AMD_Opteron-tm-_Processor_1220_SE-with-gentoo-2.0.1
Timestamp of tree: Thu, 07 Jan 2010 01:30:21 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.10
dev-lang/python:     2.4.6, 2.6.4
dev-python/pycrypto: 2.1.0_beta1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.0
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.64
sys-devel/automake:  1.6.3-r1, 1.7.9-r1, 1.9.6-r2, 1.10.3, 1.11.1
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests buildsyspkg ccache distlocks fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms sign splitdebug strict test unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://ftp.gtlib.gatech.edu/pub/gentoo http://www.gtlib.gatech.edu/pub/gentoo http://open-systems.ufl.edu/mirrors/gentoo "
LDFLAGS="-Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 aspell automount avahi badval bash-completion berkdb bindist bluetooth branding bzip2 cairo ccache cdaudio cdda cddb cdparanoia cdr cdrom cleartype cli color-console colordiff config-file consolekit cracklib crypt ctype cups curl cxx dbus device-mapper dns dri dts dvd dvdarchive dvdr dvdread emboss encode equalizer evo examples expat extras fam festival ffmpeg filter firefox firefox3 flac fontconfig foomaticdb fortran fortune ftp fts3 gconf gdbm gedit gif gimp git glib glitz gnome gnome-print gnutls gpg gpm gsl gsm gstreamer gtk gtkhtml gtkspell gui guidexml h323 hal htmltidy http-forms http-server iconv ide imlib2 ipv6 jadetex javascript jpeg kdrive lame ldap libnotify lm_sensors logrotate logviewer logwatch mad mailbox mbrola mdnsresponder-compat messages mikmod mjpeg mmx mng modules mp2 mp3 mp3rtp mp4 mp4live mpeg mpeg2 mplayer mudflap multilib mysql nautilus ncurses nls nptl nptlonly nsplugin ogg ogg123 opengl opengl-video opengl-xvmc openmp openssh oss pam pcre pdf perl php pidgin pipechan pixmaps png podcast policykit ppds pppd proj pulseaudio python qt3support quicktime readline reflection reiserfs replytolist rhythmbox rss sdl session sip slang smime sox spamassassin spell spl sqlite sse sse2 ssl startup-notification status stream subversion svg svgz swig sysfs tcl tcpd test theora threads threadsafe thunar thunderbird tiff tk tokenizer truetype twolame type1 unicode unzip usb v4l v4l2 vhook video videos vim vim-pager vim-syntax vim-with-x vorbis wav weather wma wmp x264 xcomposite xfs xinerama xml xmlrpc xorg xulrunner xv xvid zip zlib" ALSA_CARDS="emu10k1x" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-perl/Cairo-1.06.1-r1 was built with the following:
USE="(multilib) test" 
Comment 2 Kent Fredric (IRC: kent\n) gentoo-dev 2011-01-10 21:53:33 UTC
Upstream identical bug: 
   https://rt.cpan.org/Public/Bug/Display.html?id=62603

CPAN test failures:
  http://www.cpantesters.org/cpan/report/21ea2256-d25e-11df-b31b-a2b63073ca9e
  http://www.cpantesters.org/cpan/report/cc9870ba-e9e0-11df-bc12-9f5301b4aa13

Test Grid:
  http://matrix.cpantesters.org/?dist=Cairo+1.061

The distribution of the failures indicate to me it might not be perl-version oriented, and more 'your cairo libraries' oriented.

x11-libs/cairo-1.10.0-r3 + dev-lang/perl-5.12.3_rc1  + dev-perl/Cairo-1.06.1

this combination is failing for me. 

I had installed dev-perl/Cairo 1.06.1 at an earlier time on 5.12.2 without problem.

I have yet to test it with older cairo's, but I think its a good place to start looking.


Comment 3 Kent Fredric (IRC: kent\n) gentoo-dev 2011-01-15 05:19:09 UTC
This bug is no longer repeatable by me with x11-libs/cairo-1.10.2-r1

I suspect the "buggy gradients" patch and what happened with it, as mentioned in the Changelog may have had some impact, but not sure:

*cairo-1.10.2-r1 (13 Jan 2011)

  13 Jan 2011; Dror Levin <spatz@gentoo.org>
  +files/cairo-1.10.0-buggy_gradients.patch, -cairo-1.10.2.ebuild,
  +cairo-1.10.2-r1.ebuild:
  Restore buggy_gradients.patch accidently removed by scarabeus.

1.10.2  from the Mozilla overlay is also without problem for me, but it does NOT use that patch as far as I can make, so its possibly a regression in 1.10.0 thats now been solved.

Comment 4 Torsten Veller (RETIRED) gentoo-dev 2011-01-15 05:57:34 UTC
Maybe related?
*Cairo-1.61 (14 Jan 2011)

  14 Jan 2011; Torsten Veller <tove@gentoo.org> -Cairo-1.06.1.ebuild,
  +Cairo-1.61.ebuild:
  Convert ebuild version. Disable CairoSurface.t (#294204)
Comment 5 Torsten Veller (RETIRED) gentoo-dev 2011-10-31 04:58:57 UTC
*** Bug 387719 has been marked as a duplicate of this bug. ***
Comment 6 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-04-03 18:57:28 UTC
(In reply to comment #3)
> This bug is no longer repeatable by me with x11-libs/cairo-1.10.2-r1

I have that version of cairo and it fails tests for me.
Comment 7 Torsten Veller (RETIRED) gentoo-dev 2012-06-04 03:53:21 UTC
This version was removed and this test failure was fixed.