Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 294121 - dev-python/jinja2-2.2.1 dev-python/sphinx-0.6.3 circular dependencies
Summary: dev-python/jinja2-2.2.1 dev-python/sphinx-0.6.3 circular dependencies
Status: RESOLVED DUPLICATE of bug 268805
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-22 23:42 UTC by David Abbott
Modified: 2009-11-23 01:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Removed >=dev-python/jinja2-2.1 from sphinx ebuild RDEPEND (jinja2_circular.patch,274 bytes, patch)
2009-11-22 23:54 UTC, David Abbott
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Abbott gentoo-dev 2009-11-22 23:42:14 UTC
[nomerge      ] dev-python/sphinx-0.6.3  USE="doc -test" 
[ebuild  N    ]  dev-python/jinja2-2.2.1  USE="doc examples -i18n -test" 
[ebuild  N    ]   dev-python/sphinx-0.6.3  USE="doc -test" 

 * Error: circular dependencies:

('ebuild', '/', 'dev-python/jinja2-2.2.1', 'merge') depends on
  ('ebuild', '/', 'dev-python/sphinx-0.6.3', 'merge') (buildtime)
('ebuild', '/', 'dev-python/sphinx-0.6.3', 'merge') depends on
  ('ebuild', '/', 'dev-python/jinja2-2.2.1', 'merge') (buildtime)

emerge --info                    
Portage 2.1.7.6 (default/linux/amd64/10.0/desktop, gcc-4.4.2, glibc-2.11-r0, 2.6.30-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r5-x86_64-Dual-Core_AMD_Opteron-tm-_Processor_1220_SE-with-gentoo-2.0.1
Timestamp of tree: Sun, 22 Nov 2009 23:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.4.6, 2.6.4
dev-python/pycrypto: 2.1.0_beta1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://ftp.gtlib.gatech.edu/pub/gentoo http://www.gtlib.gatech.edu/pub/gentoo http://open-systems.ufl.edu/mirrors/gentoo ftp://mirror.fslutd.org/linux/distributions/gentoo/ "
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 aspell automount avahi bash-completion berkdb bindist bluetooth branding bzip2 cairo ccache cdaudio cdda cddb cdparanoia cdr cdrom cleartype cli color-console colordiff config-file consolekit cracklib crypt ctype cups curl dbus dns doc dri dts dvd dvdarchive dvdr dvdread emboss encode equalizer evo examples expat extras fam festival ffmpeg filter firefox3 flac fontconfig foomaticdb fortran fortune ftp gconf gdbm gedit gif gimp git glib glitz gnome gnome-print gpm gsm gstreamer gtk gtkhtml gtkspell guidexml h323 hal htmltidy http-forms http-server iconv ide imlib2 ipv6 jadetex javascript jpeg kdrive lame ldap libnotify lm_sensors logrotate logviewer logwatch mad mailbox mbrola mdnsresponder-compat messages mikmod mjpeg mmx modules mp2 mp3 mp3rtp mp4 mp4live mpeg mpeg2 mplayer mudflap multilib mysql nautilus ncurses nls nptl nptlonly nsplugin ogg ogg123 opengl opengl-video opengl-xvmc openmp openssh oss pam pcre pdf perl php pidgin pipechan pixmaps png podcast policykit ppds pppd pulseaudio python quicktime readline reflection reiserfs rhythmbox rss sdl session sip slang sox spell spl sqlite sse sse2 ssl startup-notification status stream subversion svg svgz swig sysfs tcl tcpd theora threads threadsafe thunar thunderbird tiff tk tokenizer truetype twolame type1 unicode unzip usb v4l v4l2 vhook video videos vim vim-pager vim-syntax vim-with-x vorbis wav weather wma wmp x264 xcomposite xfs xinerama xml xmlrpc xorg xulrunner xv xvid zip zlib" ALSA_CARDS="emu10k1x" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nv nvidia" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Reproducible: Always
Comment 1 David Abbott gentoo-dev 2009-11-22 23:54:03 UTC
Created attachment 210939 [details, diff]
Removed >=dev-python/jinja2-2.1 from sphinx ebuild RDEPEND

Removed >=dev-python/jinja2-2.1 from sphinx ebuild RDEPEND. I am pretty sure it is not a runtime dependence for sphinx.
Comment 2 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-11-23 01:52:45 UTC
Comment on attachment 210939 [details, diff]
Removed >=dev-python/jinja2-2.1 from sphinx ebuild RDEPEND

grep jinja2 `qlist sphinx`
Comment 3 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-11-23 01:54:02 UTC

*** This bug has been marked as a duplicate of bug 268805 ***