Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 293823 - media-sound/esound: LD_PRELOAD in /usr/bin/esddsp is wrong
Summary: media-sound/esound: LD_PRELOAD in /usr/bin/esddsp is wrong
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-20 10:20 UTC by Octavian
Modified: 2009-11-21 13:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to replace LD_PRELOAD in /usr/bin/esddsp (esound-0.2.41-ld_preload.patch,347 bytes, patch)
2009-11-20 10:23 UTC, Octavian
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Octavian 2009-11-20 10:20:48 UTC
LD_PRELOAD refers to libraries without path.

Reproducible: Always
Comment 1 Octavian 2009-11-20 10:23:23 UTC
Created attachment 210694 [details, diff]
patch to replace LD_PRELOAD in /usr/bin/esddsp
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-11-20 12:22:51 UTC
not sure how wrong is that, but one thing is clear, using /usr/lib is even worse as it does not take into account multilib setups.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-11-20 12:28:43 UTC
I'd say INVALID for two reasons:

 - nobody has explained why should that be "wrong";
 - as Gilles pointed out /usr/lib will break multilib setups (which is exactly *why* they don't use the full library path).
Comment 4 Octavian 2009-11-21 12:23:23 UTC
You might be right since my knowledge is not too advanced in this area but I have an issue when I use nxclient. I think nxclient uses that script on the remote machine to send the sound over the network. Then a lot of warning are issued that those to libraries are not found.

Do you have a solution to get rid of those warnings? Is there a path defined?

Did you have a look at https://bugs.launchpad.net/ubuntu/+source/esound/+bug/214465 ?

Thank you in advance,
Octavian
Comment 5 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-11-21 12:37:18 UTC
Given a) I have no idea about NX b) you have shown no example of those warnings, no I have no idea how to help you.

The way Ubuntu "fixes" stuff is of no interest to me, they broke so much stuff before this way it's not even funny any more.
Comment 6 Octavian 2009-11-21 12:55:08 UTC
Well,  /usr/bin/esddsp sets the LD_PRELOAD in the script

If one executes 
$> export LD_PRELOAD="libesddsp.so.0 libesd.so.0 $LD_PRELOAD"

then executes for example:
$> locate esddsp

you have the warnings
ERROR: ld.so: object 'libesddsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libesd.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libesddsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libesd.so.0' from LD_PRELOAD cannot be preloaded: ignored.



I still need to investigate when the esddsp reaches the LD_PRELOAD points
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-11-21 12:57:44 UTC
You *really* should open the bug for nxclient.
Comment 8 Octavian 2009-11-21 13:04:48 UTC
one last question. If the library path is not specified where is this taken from? You do need a library path don't you? any IRC we can continue this discussion?
Comment 9 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-11-21 13:10:33 UTC
man ld.so

default library path is set in /etc/ld.so.conf and is prefixed by the LD_LIBRARY_PATH variable, and by the RPATH entry in the executable file.
Comment 10 Octavian 2009-11-21 13:21:15 UTC
Thanks.

the last last question :-)

Since there is no /usr/lib in /etc/ld.so.conf nor in /etc/env.d/* who should set the library path when /usr/bin/esddsp is run?

Am I missing something?

Thank you in advance,
Octavian