Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 293583 - media-sound/shoutcast-trans-bin fetch URL no longer valid
Summary: media-sound/shoutcast-trans-bin fetch URL no longer valid
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-18 06:37 UTC by John L. Poole
Modified: 2009-12-23 21:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John L. Poole 2009-11-18 06:37:28 UTC
emerge requires the user pre-fetch a binary file; however, the URL provided no longer works and I am unable to find the file at the target web site.

Reproducible: Always

Steps to Reproduce:
1. emerge shoutcast-trans-bin
2. go to http://www.shoutcast.com/downloads/sc_trans_posix_040.tgz

Actual Results:  
localhost content # emerge shoutcast-trans-bin
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-sound/shoutcast-trans-bin-0.4.0-r1

!!! media-sound/shoutcast-trans-bin-0.4.0-r1 has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually.  See the comments in the ebuild for more information.

!!! The following are listed in SRC_URI for shoutcast-trans-bin:
!!!   http://www.shoutcast.com/downloads/sc_trans_posix_040.tgz
 * Fetch failed for 'media-sound/shoutcast-trans-bin-0.4.0-r1', Log file:
 *  '/var/tmp/portage/media-sound/shoutcast-trans-bin-0.4.0-r1/temp/build.log'

>>> Failed to emerge media-sound/shoutcast-trans-bin-0.4.0-r1, Log file:

>>>  '/var/tmp/portage/media-sound/shoutcast-trans-bin-0.4.0-r1/temp/build.log'

 * Messages for package media-sound/shoutcast-trans-bin-0.4.0-r1:

 * Fetch failed for 'media-sound/shoutcast-trans-bin-0.4.0-r1', Log file:
 *  '/var/tmp/portage/media-sound/shoutcast-trans-bin-0.4.0-r1/temp/build.log'
localhost content #

visiting http://www.shoutcast.com/downloads/sc_trans_posix_040.tgz
results in: 

We're sorry!
We cannot locate the page you were looking for.
 Please check the address and try again, or take me back to 
Error Code:  
20022

Moreover, I could not find the file or product.

Expected Results:  
a license page or start of a download, similar to what happened for emerging shoutcast
Comment 1 Samuli Suominen gentoo-dev 2009-12-23 11:43:35 UTC
+  23 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+  shoutcast-trans-bin-0.4.0-r1.ebuild:
+  Don't point to SRC_URI in pkg_nofetch message wrt #293583.
Comment 2 John L. Poole 2009-12-23 20:34:33 UTC
(In reply to comment #1)
> +  23 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
> +  shoutcast-trans-bin-0.4.0-r1.ebuild:
> +  Don't point to SRC_URI in pkg_nofetch message wrt #293583.
> 

I don't understand "Don't point..."; is this a patch?  How does your comment resolve this bug?
Comment 3 David Abbott gentoo-dev 2009-12-23 21:07:42 UTC
The source files for shoutcast-trans-bin are not in the repository and have to be downloaded and placed into /usr/portage/distfiles.
Try;
# wget http://yp.shoutcast.com/downloads/sc_trans_posix_040.tgz 
# mv sc_trans_posix_040.tgz /usr/portage/distfiles 
# emerge shoutcast-trans-bin
More info here http://en.gentoo-wiki.com/wiki/Shoutcast#Downloading_Shoutcast


Comment 4 John L. Poole 2009-12-23 21:39:17 UTC
That worked.
So, the problem was the URL: 
valid: http://yp.shout...
invalid: http://www.shout...

Thank you.
Comment 5 Samuli Suominen gentoo-dev 2009-12-23 21:50:06 UTC
The message is now,

* Download sc_trans_posix_040.tgz from http://www.shoutcast.com/.
 * Last known working location is http://yp.shoutcast.com/downloads/sc_trans_posix_040.tgz.