Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 293412 - x11-libs/wxGTK license changed
Summary: x11-libs/wxGTK license changed
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo wxWidgets Herd
URL: http://www.wxwidgets.org/about/newlic...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-16 17:54 UTC by Arne Babenhauserheide
Modified: 2009-11-20 04:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arne Babenhauserheide 2009-11-16 17:54:10 UTC
Hi, 

From the license information site of wxWidgets it seems that they use a simple LGPL 2 or later with an exception stating that derived works in binary form may be distributed on the user's own terms. 

That exception can be stripped away by any contributor, so since Gentoo applies some patches, the wxGTK version in Gentoo can be made either LGPL or wxWinLL-3 by setting the license of the patches as either LGPL or wxWinLL-3. 

Why I write that: I just checked which of my installed programs are NOT under FSF-APPROVED licenses and wxGTK was the only one. Since wxGTK could be made LGPL by the patches, I could then set ACCEPT_LICENSE to "@FSF-APPROVED". 

Reproducible: Always




EXCEPTION NOTICE

  1. As a special exception, the copyright holders of this library give
  permission for additional uses of the text contained in this release of
  the library as licenced under the wxWindows Library Licence, applying
  either version 3.1 of the Licence, or (at your option) any later version of
  the Licence as published by the copyright holders of version
  3.1 of the Licence document.

  2. The exception is that you may use, copy, link, modify and distribute
  under your own terms, binary object code versions of works based
  on the Library.

  3. If you copy code from files distributed under the terms of the GNU
  General Public Licence or the GNU Library General Public Licence into a
  copy of this library, as this licence permits, the exception does not
  apply to the code that you add in this way.  To avoid misleading anyone as
  to the status of such modified files, you must delete this exception
  notice from such code and/or adjust the licensing conditions notice
  accordingly.

  4. If you write modifications of your own for this library, it is your
  choice whether to permit this exception to apply to your modifications. 
  If you do not wish that, you must delete the exception notice from such
  code and/or adjust the licensing conditions notice accordingly.
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2009-11-17 05:43:30 UTC
wxWinLL-3 is basically (L)GPL-2 with a special exemption that you can distribute binaries (modified or not) under your own terms (point 2).  This doesn't apply here since we don't distribute any binaries.  I don't think point 4 applies either as all our modifications/patches are GPL-2 which means we fall under point 3, which just says that any GPL-2 code added to the library doesn't qualify for the exception.

There's nothing that says making GPL-2 licensed modifications changes the license of the library, just that you can distribute binaries under your own terms.  We don't, so we can't.
Comment 2 Arne Babenhauserheide 2009-11-17 07:02:56 UTC
As I understand point point 4, it says that you can choose whether you want the exception to apply to your own code. 

And since your patches are GPL without exception, the whole work can only be put under the GPL - which automatically strips away the exception for the whole work. 

So the binaries produced when using GPL/LGPL patches (the "entire product") are automatically LGPL/GPL without exception, as long as the patch author doesn't carry over the exception into his/her contribution. 

What doesn't change is the license of the code, but the license of the "entire work" has to fit every single part, so adding GPL-2 patches makes the entire work GPL-2. 

(If I had found license notices in the patches, I'd have written that directly)
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2009-11-20 04:51:47 UTC
But what LICENSE reflects is the license of the code as we distribute it, not the binaries that are created through the compilation process, which, i agree, could be considered LGPL or whatever license you choose to distribute them as under the exception.

Furthermore, from a non-technical viewpoint, the license of wxWidgets is explicitly designed to allow the possibility of distributing the wx libraries under licenses that are less permissive than the LGPL, so that distributors are not obliged to distribute the source with the binaries.  So I don't believe that this holds with what @FSF-APPROVED is supposed to represent.  In the end I'd rather accurately and impartially describe the state of the code than strip away upstream's intentions to make it fit in a license group.