Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 292821 - x11-libs/gtk+-2.18: leaves ghosts on scroll
Summary: x11-libs/gtk+-2.18: leaves ghosts on scroll
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.28
  Show dependency tree
 
Reported: 2009-11-11 18:24 UTC by Alexandre Hannud Abdo
Modified: 2009-12-15 05:57 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Hannud Abdo 2009-11-11 18:24:09 UTC
Scrollable windows become messy when scrolling or when new items are introduced.

This started after the updates to gnome-2.28

I'm using ~amd64

Reproducible: Sometimes

Steps to Reproduce:
1. open any scrollable window
2. scroll up and down, click to move the scrollbar, etc...
3. do that until updating fails, ghosts appear, text becomes superposed, etc...

Actual Results:  
window displayed does not correspond to actual window state


Changing desktops back and forth forces an update making things look right

Hitting prtscr also triggers an update, so i can't generate a screenshot

--

Portage 2.1.7.4 (default/linux/amd64/10.0/desktop, gcc-4.4.2, glibc-2.11-r0, 2.6.31-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 11 Nov 2009 14:15:01 +0000
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.6.4, 3.1.1-r1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r2
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.10.2, 1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://www.las.ic.unicamp.br/pub/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en pt_BR pt ar"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/Spring /usr/local/portage"
SYNC="rsync://rsync.samerica.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth bzip2 cairo cdr cli consolekit cracklib crypt cups dbus dri dts dvd dvdr eds emboss encode evo exif expat ffmpeg firefox flac fortran gdbm gif glitz gnome gpm gstreamer gtk guile hal iconv icu ipv6 java jingle jpeg latex ldap libnotify lm_sensors mad mikmod mmx modules mp3 mp4 mpeg mpi mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python quicktime readline reflection sdl session smp spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora threads thunar tiff truetype unicode usb vorbis x264 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en pt_BR pt ar" USERLAND="GNU" VIDEO_CARDS="radeonhd fbdev vesa" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexandre Hannud Abdo 2009-11-11 18:39:35 UTC
Just to clarify...

I should have said "Reproducible: Always" since if you try enough times it does happen on every scrollable window. It's easier to reproduce with larger scrollbars.

Apparently it affects every gtk+ application: scrollable pages on firefox, email lsts on evolution, contact lists and conversations on empathy, file folders on nautilus, etc.
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-11-12 10:56:08 UTC
You will have a better chance at getting this fixed by reporting on upstream bugzilla (https://bugzilla.gnome.org). This is most likely a problem with new "client side window" code but I'm 100% unable to reproduce this problem since I first upgrade to gtk+-2.18 branch weeks ago
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2009-11-20 22:59:45 UTC
I have also seen this, but only in compiz (in metacity without compositing, everything works fine).
To resolve the issue in compiz, you need to enable "force synchronization between X and GLX" in the workarounds plugin in ccsm.
Comment 4 Alexandre Hannud Abdo 2009-11-26 05:51:09 UTC
Ok, after Alexandre Rostovtsev's comment I tried disabling DRI and everything works fine now.

So this might be my fault for using the raedeonhd driver from git, although I've been using it for ages without a glitch.

However, I'm not running compiz (the ebuild isn't installed).

Is there a way for me to set this "force synchronization
between X and GLX" without compiz?

~~
Comment 5 Matthew Turnbull 2009-11-30 04:13:47 UTC
If you're using xserver-1.7.x, you might be running in to an EXA corruption issue

https://bugs.freedesktop.org/show_bug.cgi?id=24300
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-12-13 22:55:20 UTC
how is it with gtk+-2.18.5 ?
Comment 7 Alexandre Hannud Abdo 2009-12-15 05:57:30 UTC
After today's updates (gtk, mesa, xserver, radeonhd) everything works fine :]
I guess the issue was solved upstream.
Thanks!
~~