Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 292480 - Gnome doesn`t show application menu, icons and theme over an nx session
Summary: Gnome doesn`t show application menu, icons and theme over an nx session
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Freedesktop bugs
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
: 292656 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-09 09:04 UTC by Christian Kaps
Modified: 2010-07-08 17:40 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
92_handle_xi_errors.patch (92_handle_xi_errors.patch,6.58 KB, patch)
2010-05-17 13:11 UTC, Pacho Ramos
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Kaps 2009-11-09 09:04:29 UTC
Gnome doesn`t show the application menu, no icons and not the selected gtk theme when I login over an nx session. As nx server I use the net-misc/nxserver-freeedition-3.3.0.14. Gnome is the lates gnome-base/gnome-light-2.26.3 from portage. As client I use the latest from the NoMachine website on a WindowsXP machine. The same problem occurs with the net-misc/nxserver-freenx package.

Reproducible: Always

Steps to Reproduce:
1. Start the freenx client
2. Login into a Gnome Session
3.

Actual Results:  
Gnome doesn`t show the application menu, no icons and not the selected gtk theme
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-11-09 22:52:06 UTC
Most likely because it is not exporting the correct informations. Please look at the informations provided by gnome-menus ebuild or gnome 2.26 migration guide.

*** This bug has been marked as a duplicate of bug 279555 ***
Comment 2 Christian Kaps 2009-11-10 09:08:19 UTC
I have created a file /etc/env.d/99gnomemenu with the content XDG_MENU_PREFIX=gnome-. After env-update && source /etc/profile the menu will be displayed.

But on my amd64 system the GTK-Theme, all desktop icons and most of the menu icons are still missing. When I try to start the gnome-appearance-properties program the window will be killed.

On my x86 systems all icons are shown correct but the GTK-Theme is still lost. On this system I can start the gnome-appearance-properties program but changes have no effects.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-11-10 09:21:37 UTC
theme issues are another bug, please open a new bug report for that.

*** This bug has been marked as a duplicate of bug 279555 ***
Comment 4 Peter Volkov (RETIRED) gentoo-dev 2009-12-07 08:50:36 UTC
This is not duplicate. This issue is about nx.

I've fixed this issue by changing CommandStartGnome at /usr/NX/etc/node.cfg to:
CommandStartGnome="/etc/X11/Sessions/Gnome". But since I've never touched that file I think this should be handled automatically. Probably getDeafultGnomeCmd() in /usr/NX/scripts/setup/nxnode should be changed to use and prefer /etc/X11/Sessions/Gnome.
Comment 5 Bernard Cafarelli gentoo-dev 2009-12-07 15:47:47 UTC
calchan had the same kind of problem with neatx, which ebuild does set /etc/X11/Sessions/Gnome for gnome

freeedition and freenx both still use gnome-session directly, I'll fix them both
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-12-13 22:54:26 UTC
*** Bug 292656 has been marked as a duplicate of this bug. ***
Comment 7 Bernard Cafarelli gentoo-dev 2009-12-15 20:37:27 UTC
Ok, Gnome start command updated to /etc/X11/Sessions/Gnome in nxnode-3.4.0.6-r1 (freeedition) and nxserver-freenx-0.7.3_p104-r3. With neatx already fixed, looks like we're all done here :)
Comment 8 Gilles Dartiguelongue gentoo-dev 2009-12-15 21:58:04 UTC
thanks guys.
Comment 9 Timothy Stotts 2010-01-03 22:25:37 UTC
I am using nxserver-freeedition and still have this bug.

I can use any of the following in my node.cfg, and the bug is still present.
    1. CommandStartGnome="/etc/X11/Sessions/Gnome"
    2. CommandStartGnome="/usr/bin/dbus-launch --exit-with-session gnome-session"
    3. (no CommandStartGnome at all)

What am I doing wrong?
Comment 10 Gilles Dartiguelongue gentoo-dev 2010-01-03 22:30:03 UTC
don't know, nx guys had something to do to fix this on their side I believe. You might want to contact them first.
Comment 11 Bernard Cafarelli gentoo-dev 2010-01-08 14:26:17 UTC
Hi Timothy,

do you have =nxnode-3.4.0.6-r1 installed? CommandStartGnome="/etc/X11/Sessions/Gnome" is the correct one (which should work).
Comment 12 Andrew Mao 2010-03-09 19:46:34 UTC
I am currently running all the unstable versions of NX server/node and I still have this bug. Changing the CommandStartGnome line didn't fix anything.
Comment 13 Bernard Cafarelli gentoo-dev 2010-03-10 12:40:05 UTC
Can you try with a clean profile:
* Remove nxclient/nxnode/nxserver-freeedition, move /usr/NX away (please keep it somewhere else, so we can compare the configuration files compared to a fresh install)
* Merge nxserver-freeedition
* Try to login with a fresh new user (i.e no previous gnome profile, who knows)
I can browse application menu and set gtk theme on a test server where I checked this
Comment 14 Andrew Mao 2010-03-12 00:21:34 UTC
Ok, I did what you asked. 

It seems like there is some strange behavior with the files in /usr/NX, because they seemed to have hung around from earlier versions during emerge upgrades. Anyway, I copied out the old /usr/NX folder, and reinstalled nxserver and nxnode. Then I got the "Your evaluation period has expired" error upon reconnecting, until I copied node.lic from the old folder into the new one.

After the was a recent update to nxserver, I think, I started getting the applications menu again, but it still has missing/blank icons and no GTK theme. This is true for both my original user and the new blank one you asked me to test with. The windows all still look ugly and there are a lot of icons floating around with the red 'X'.
Comment 15 Bernard Cafarelli gentoo-dev 2010-03-15 12:08:06 UTC
Thanks for the tests, looks like I'll have to try and reproduce some broken upgrade path! Reopening in the meantime for nxserver-freeedition

Btw, did you try nxserver-freenx or neatx? No one reported the problem still there with them, I hope these at least are fixed.
Comment 16 Andrew Mao 2010-03-16 19:44:34 UTC
Yes, I can confirm that it looks the same with neatx. I uninstalled nxserver and nxnode. 

I'm starting to think this is an nxclient problem because I remember logging in from someone's KDE NX client and I think that it looked normal.

Do I still need to do the CommandStartGnome thing for neatx?
Comment 17 Tom Flair 2010-04-04 01:58:40 UTC
(In reply to comment #15)
> Thanks for the tests, looks like I'll have to try and reproduce some broken
> upgrade path! Reopening in the meantime for nxserver-freeedition
> 
> Btw, did you try nxserver-freenx or neatx? No one reported the problem still
> there with them, I hope these at least are fixed.
> 

I had this problem using nxserver-freenx and still with neatx.  I've used the nxclient in portage and the Windows binary (both 3.4.0.7) without success.

From both, I created a new user with a clean profile.  This worked some time ago with previous versions.   I would be more than happy to provide any information requested if it helps.
Comment 18 vts 2010-05-03 18:28:27 UTC
(In reply to comment #17)
> (In reply to comment #15)
> > Thanks for the tests, looks like I'll have to try and reproduce some broken
> > upgrade path! Reopening in the meantime for nxserver-freeedition
> > 
> > Btw, did you try nxserver-freenx or neatx? No one reported the problem still
> > there with them, I hope these at least are fixed.
> > 
> 
> I had this problem using nxserver-freenx and still with neatx.  I've used the
> nxclient in portage and the Windows binary (both 3.4.0.7) without success.
> 
> From both, I created a new user with a clean profile.  This worked some time
> ago with previous versions.   I would be more than happy to provide any
> information requested if it helps.
> 

I "fixed" the gtk problem with gconf-editor -> apps -> gnome_settings_daemon -> plugins -> keyboard -> active = disabled

and the no menu problem with comment #2
echo "XDG_MENU_PREFIX=gnome-" >> /etc/env.d/99gnomemenu && env-update && source /etc/profile

no additional changes in the start scripts
Comment 19 Kayvan Sylvan 2010-05-12 23:21:41 UTC
I am seeing the same problems with nxserver-freenx:

# qlist -Iv | grep nx
net-misc/nx-3.3.0-r1
net-misc/nxclient-3.4.0.5
net-misc/nxserver-freenx-0.7.3_p104-r2

Te Gnome menus problem was fixed as above:

# cd /etc/env.d/
# echo "XDG_MENU_PREFIX=gnome-"> 99gnomemenu
# env-update 
>>> Regenerating /etc/ld.so.cache...

However, I am still not getting most of the icons.

Interestingly, the "Root Terminal" icon shows up, but the "Terminal" icon does not.

I am running on an AMD64 box:

# uname -a
Linux ksgxw8600 2.6.32-gentoo-r7 #1 SMP Fri May 7 17:19:02 PDT 2010 x86_64 Intel(R) Xeon(R) CPU E5420 @ 2.50GHz GenuineIntel GNU/Linux
Comment 20 Kayvan Sylvan 2010-05-16 21:15:18 UTC
Seems like this bug on the FreeNX launchpad is similar:

https://bugs.launchpad.net/ubuntu/+source/libxklavier/+bug/409621

kayvan@gentoo ~ $ /usr/libexec/gnome-settings-daemon 
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 102 error_code 1 request_code 150 minor_code 8)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Comment 21 Andrew Mao 2010-05-16 21:21:04 UTC
Yes, I have the same symptoms as you in comment #19

I remember reading somewhere that someone fixed this problem by compiling libxklavier-5.0. But it's hardmasked, and I couldn't get it compiled without messing up a bunch of the libraries on my system, so I just resolved to wait it out.
Comment 22 Pacho Ramos gentoo-dev 2010-05-17 13:10:19 UTC
Great, thanks a lot for the investigation, it looks like a libxklavier problem then
Comment 23 Pacho Ramos gentoo-dev 2010-05-17 13:11:01 UTC
Created attachment 231807 [details, diff]
92_handle_xi_errors.patch

This patch from ubuntu should fix the problem in 4.0, please try if possible. Thanks
Comment 24 Samuli Suominen (RETIRED) gentoo-dev 2010-05-17 13:17:30 UTC
(In reply to comment #23)
> Created an attachment (id=231807) [details]
> 92_handle_xi_errors.patch
> 
> This patch from ubuntu should fix the problem in 4.0, please try if possible.
> Thanks
> 

Exactly why are we trying to fix 4.0, when 5.0 should be in ~arch already? 
All that is needed is someone from gnome@ to apply the necessary patches to libgnomekbd-2.28 from bug 306529.
Comment 25 Pacho Ramos gentoo-dev 2010-05-17 13:21:13 UTC
Has anybody checked it's really fixed in 5.0?
Comment 26 Samuli Suominen (RETIRED) gentoo-dev 2010-05-17 13:27:56 UTC
(In reply to comment #25)
> Has anybody checked it's really fixed in 5.0?
> 

I just checked few chunks of the patch you posted, and it seems to be in 5.0 already.
Comment 27 Andrew Mao 2010-05-17 15:19:36 UTC
I can't get libgnomekbd-2.28.2 to compile after manually unmasking libxklavier-5.0. I'm not good at diagnosing this so anyone else want to try and see why that is?
Comment 28 Pacho Ramos gentoo-dev 2010-05-17 15:31:14 UTC
I am working on my local system to get 2.28 pieces working with libxklavier-5, I have also asked the rest of gnome team for what to do (if fix 2.28 or wait for getting Gnome 2.30 in the tree). 
Comment 29 Kayvan Sylvan 2010-05-22 07:34:32 UTC
Any updates on this? Thank you!
Comment 30 Kayvan Sylvan 2010-05-24 06:22:50 UTC
After some recent updates, emerge of mono and mono-basic just worked, so I suspect this bug is fixed.
Comment 31 Kayvan Sylvan 2010-05-25 08:24:02 UTC
Whoops. My last comment was for another bug. Sorry. This bug (the missing icons in Gnome in an NX session) still persists.
Comment 32 Kayvan Sylvan 2010-05-28 05:00:35 UTC
Is there any more progress with getting libxklavier set up?

Maybe I can play with a local overlay and try installing libxklavier-5.0 to see if the problem goes away. Any suggestions for how to proceed?
Comment 33 Rich 2010-05-30 10:43:22 UTC
> Te Gnome menus problem was fixed as above:
> 
> # cd /etc/env.d/
> # echo "XDG_MENU_PREFIX=gnome-"> 99gnomemenu
> # env-update 
> >>> Regenerating /etc/ld.so.cache...
> 
> However, I am still not getting most of the icons.

Same issues and results with the above on a brand new box emerged this from scratch this weekend, everything from the stable x64 (amd64) tree. Kind of disconcerting on a normally headless machine...I can use Xfce4 for now.
Comment 34 Samuli Suominen (RETIRED) gentoo-dev 2010-06-13 16:54:27 UTC
libxklavier-5 is now unmasked in tree (thanks pacho). 
so I guess this bug is solved with it?
Comment 35 Kayvan Sylvan 2010-06-13 18:51:50 UTC
So, how do I fix this?

"emrege libxklavier" installs libxklavier-4.0

I have performed a sync and everything is up to date.
Comment 36 Andrew Mao 2010-06-13 20:02:02 UTC
emerging libxklavier-5.0 and then doing 

revdep-rebuild --library libxklavier.so.15 (the libxklavier-4.0 library)

causes compile failures on libgnomekbd-2.28. So I did the logical thing, and unmasked libgnomekbd-2.30.1 and ran revdep-rebuild again. Still compile errors.

BTW, this was the same thing that was happening when libxklavier was hard unmasked. So nothing has changed really. Does it work for any of you?
Comment 37 Kayvan Sylvan 2010-06-13 22:22:57 UTC
> BTW, this was the same thing that was happening when libxklavier was hard
> unmasked. So nothing has changed really. Does it work for any of you?

Exactly. I don't think this bug can be marked as resolved/fixed until there is a clear set of instructions for how to fix it and verification by those affected that it is indeed fixed.
Comment 38 Pacho Ramos gentoo-dev 2010-06-13 22:27:36 UTC
The fix is to update to Gnome 2.30 as it uses libxklavier-5, that should fix this issue
Comment 39 Kayvan Sylvan 2010-06-13 22:31:30 UTC
Exactly how do I update to gnome-2.30?

entoo ~ # emerge -pv gnome
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] gnome-base/gnome-2.28.2  USE="cdr cups dvdr ldap policykit -accessibility -mono" 0 kB

Comment 40 Kayvan Sylvan 2010-07-08 06:30:21 UTC
What's the best way to update to gnome-2.30?
Comment 41 Pacho Ramos gentoo-dev 2010-07-08 09:48:07 UTC
(In reply to comment #40)
> What's the best way to update to gnome-2.30?
> 

http://my.opera.com/pacho/blog/on-the-road-of-getting-gnome-2-30-stabilized

;-)
Comment 42 Andrew Mao 2010-07-08 17:40:09 UTC
Nice! Gnome looks normal in NX again (finally, after 6 months.) I'll remove all those things from my package.keywords when 2.30 is stabilized but for now this is great!