Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 292284 - app-misc/mc-4.7.0_pre4 segfault on start
Summary: app-misc/mc-4.7.0_pre4 segfault on start
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Alex Alexander (RETIRED)
URL: http://www.midnight-commander.org/tic...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-07 16:54 UTC by Evgeniy Dushistov
Modified: 2009-12-26 23:57 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Evgeniy Dushistov 2009-11-07 16:54:51 UTC
$mc
Segmentation fault

>LC_ALL="C" gdb mc

warning: Can not parse XML syscalls information; XML support was disabled at compile time.
GNU gdb (Gentoo 7.0 p1) 7.0
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/mc...done.
(gdb) r
Starting program: /usr/bin/mc 
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x08065321 in panel_new_with_dir (panel_name=0x80e4925 "New Right Panel", wpath=0x0) at screen.c:1314
1314    screen.c: No such file or directory.
        in screen.c
(gdb) bt
#0  0x08065321 in panel_new_with_dir (panel_name=0x80e4925 "New Right Panel", wpath=0x0)
    at screen.c:1314
#1  0x08065389 in panel_new (panel_name=0x80e4925 "New Right Panel") at screen.c:1233
#2  0x08099e4f in restore_into_right_dir_panel (lc_index=1, from_widget=0x0) at layout.c:1156
#3  0x0809a278 in set_display_type (num=1, type=0) at layout.c:926
#4  0x0809bed6 in create_panels () at main.c:959
#5  0x0809c04a in setup_mc () at main.c:1430
#6  0x0809e88b in do_nc (argc=Cannot access memory at address 0x1
) at main.c:1872
#7  main (argc=Cannot access memory at address 0x1
) at main.c:2234
(gdb) 


Reproducible: Always




Portage 2.1.6.13 (default/linux/x86/10.0/developer, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r6-i686-AMD_Athlon-tm-_XP_2600+-with-gentoo-1.12.11.1
Timestamp of tree: Sat, 07 Nov 2009 09:00:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.9-r1
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -mfpmath=sse -msse -mmmx -m3dnow -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="${NXDIR}/etc ${NXDIR}/home /etc /home /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -mfpmath=sse -msse -mmmx -m3dnow -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect cvs digest distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms sign splitdebug strict stricter test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="en ru ru_RU"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/nx /usr/portage/local/layman/vmware /usr/portage/local/layman/armagetron /home/evgeniy/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa apache2 arts bash-completion berkdb bluetooth bzip2 cairo cdr chm cjk cli consolekit cracklib crypt cups cyrillic dbus dlloader doc dri dts dvd dvdr dvipdfm emacs emboss encode evo fam fbcon firefox flac font-server foomaticdb fortran gdbm gif gimpprint gpm graphics gstreamer gtk hal iconv jpeg kde kdeenablefinal kdexdeltas kpathsea latex libnotify logrotate mad maildir mailwrapper mbox mikmod mmx modules mp3 mp4 mpeg mudflap mysql ncurses nls nptl nptlonly ogg opengl openmp pam pch pcre pdf perl png ppds pppd pstricks python qt3support qt4 quicktime readline reflection sbcl science sdl session snmp spel spell spl sse ssl startup-notification svg sysfs tcpd tetex tex4ht thunar tiff truetype type1 udev unicode usb vim-syntax vorbis win32codecs x264 x86 xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias pch" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru ru_RU" USERLAND="GNU" VIDEO_CARDS="nvidia fbdev vga vesa nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alex Alexander (RETIRED) gentoo-dev 2009-11-07 22:30:39 UTC
Did you etc-update after updating mc (if its an update)?

Maybe there's some weird folder in your last session that does not exist or contains something that's crashing mc?

Try moving your ~/.mc in ~/.mcOLD to see if it still happens.
Comment 2 Evgeniy Dushistov 2009-11-23 19:19:26 UTC
(In reply to comment #1)
> Did you etc-update after updating mc (if its an update)?
> 

yes


> Try moving your ~/.mc in ~/.mcOLD to see if it still happens.
> 

This helped.

diff old and new created config conatins, things like:

-[New Left Panel]
-display=listing
-reverse=0
-case_sensitive=1
-sort_order=name
-list_mode=full
-user_format=half type name | size | perm
-user_status0=half type name | size | perm
-user_status1=half type name | size | perm
-user_status2=half type name | size | perm
-user_status3=half type name | size | perm
-user_mini_status=0
-panel_display_codepage=Other_8_bit
-
-[New Right Panel]
-display=listing
-reverse=0
-case_sensitive=1
-sort_order=time
-list_mode=full
-user_format=half type name | size | perm
-user_status0=half type name | size | perm
-user_status1=half type name | size | perm
-user_status2=half type name | size | perm
-user_status3=half type name | size | perm
-user_mini_status=0
-panel_display_codepage=Other_8_bit
Comment 3 Alex Alexander (RETIRED) gentoo-dev 2009-12-26 13:49:27 UTC
This was probably a bug with mc's config file handling after a version upgrade.

Pretty much a corner case since no-one else has reported any similar issues, so I'm gonna close it as worksforme.

If you encounter this issue again with the latest 4.7.0 final, feel free to re-open the bug.

thanks :)
Comment 4 Sergei Trofimovich gentoo-dev 2009-12-26 16:02:03 UTC
http://www.midnight-commander.org/ticket/1790 initial description is in russian, but it addresses the same bug (for history)
Comment 5 Alex Alexander (RETIRED) gentoo-dev 2009-12-26 23:54:54 UTC
Reopening to mark as resolved, thanks for the update/link :)