Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 292002 - kde-base/kmail-4.3.3 highlight emails cause cap lock on
Summary: kde-base/kmail-4.3.3 highlight emails cause cap lock on
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 292031 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-05 17:44 UTC by Simon Gao
Modified: 2010-08-29 11:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Gao 2009-11-05 17:44:33 UTC
While trying to select multiple emails to move/copy, first highlight one email, then move cursor down to another email lower on the list, press SHIFT and click on the email, this would cause strange behavior such as enabling CAP lock (even though the system CAP lock is not on), Return key does not work any more in konsole. If press CAPs Lock key, then typing changes to lower case.

Reproducible: Always

Steps to Reproduce:
1.Open Kmail, try to select multiple emails by SHIFT+click on ending email
2.email selection will go crazy
3.Go to konsole, all typing turns to be in CAP, Return key no longer works. only way to get out is logging off and back in.

Actual Results:  
Losing email selection function
CAP is enabled
Losing Return key

Expected Results:  
Work properly with selecting emails in Kmail

Kmail-4.3.3.

This has occurred in the past with 4.2, 4.1.
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2009-11-06 11:21:39 UTC
*** Bug 292031 has been marked as a duplicate of this bug. ***
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-11-06 22:36:04 UTC
This sounds like an upstream bug to me. Did you open a bug in https://bugs.kde.org/ ?
If you do, please paste the link here.
Comment 3 Andreas K. Hüttel gentoo-dev 2010-04-30 20:36:33 UTC
Do you still see this with kde 4.3.5 or 4.4.2?
Comment 4 Andreas K. Hüttel gentoo-dev 2010-08-29 11:33:12 UTC
No reply for 4 months. Resolving as needinfo.