Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 291901 - file uploads via ftp/sftp don't work with =kde-misc/krusader-2.0.1-r1
Summary: file uploads via ftp/sftp don't work with =kde-misc/krusader-2.0.1-r1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2009-11-04 20:09 UTC by johndoeyu
Modified: 2010-02-08 08:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description johndoeyu 2009-11-04 20:09:27 UTC
This is both for stable kde-misc/krusader-2.0.1-r1, and kde-misc/krusader-2.1.0_beta1 from kde-testing overlay. Running everything up to date - stable KDE 4.3.1

You can connect using FTP/SFTP(ssh) to the remote servers, browse and download files, but you can't make uploads. No error message of any kind - after presenting the copy dialog where you pick OK or Queue - nothing happens.

Sometimes it displays file transfer in the jobs tray - but it doesn't matter as I haven't been able to upload anything even if it's shown in jobs tray.

Reproducible: Always

Steps to Reproduce:
1.emerge =kde-misc/krusader-2.0.0-r1
2.connect via FTP/SFTP(ssh) to a server
3.try to upload a file

Actual Results:  
No file is uploaded.

Expected Results:  
That a file uploads.

After trying latest stable available in portage, I tried the version in kde-testing overlay with same results.

After that I reverted to 1.90.0-r1 (unmasked it obviously) where file uploads work. It also seems to work OK with KDE 4.3.1 so far.

Portage (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r5 i686)
System uname: Linux-2.6.29-gentoo-r5-i686-Genuine_Intel-R-_CPU_T2300_@_1.66GHz-with-gentoo-       
Timestamp of tree: Wed, 04 Nov 2009 16:45:01 +0000                                                         
app-shells/bash:     4.0_p28                                                                               
dev-java/java-config: 2.1.9-r1                                                                             
dev-lang/python:     2.5.4-r2, 2.6.2-r1                                                                    
dev-util/cmake:      2.6.4                                                                                 
sys-apps/sandbox:    1.6-r2                                                                                
sys-devel/autoconf:  2.13, 2.63-r1                                                                         
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2                                                       
sys-devel/binutils:  2.18-r3                                                                               
sys-devel/gcc-config: 1.4.1                                                                                
sys-devel/libtool:   2.2.6a                                                                                
virtual/os-headers:  2.6.27-r2                                                                             
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"                                                    
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"   
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
MAKEOPTS="-j4 -s"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-testing /usr/local/overlay"
USE="7zip X a52 aac acl acpi alsa apache2 berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt cups dbus dri dts dvd dvdr eds emboss encode evo fam fortran gdbm gif gpm gstreamer gtk hal iconv ipv6 java jpeg kde libnotify mad mikmod modules mp3 mp4 mpeg msensors mudflap mysql ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl php png ppds pppd python qt3support qt4 quicktime readline reflection samba sasl sdl session spell spl srt ssl startup-notification svg sysfs tcpd thunar tiff truetype unicode usb vorbis win32codecs wma x264 x86 xcomposite xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="vesa nvidia"
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2009-11-06 11:33:54 UTC
For kioslaves in kde you need package

Then sftp should work with new krusader (just tested it on 3 pcs).

Plz reopen when you install the package or confirm you already have it on your pc and it is not working.
Comment 2 johndoeyu 2010-02-08 08:10:42 UTC
(In reply to comment #1)
> For kioslaves in kde you need package
> =kde-base/kdebase-kioslaves-4.3.X
> Then sftp should work with new krusader (just tested it on 3 pcs).
> Plz reopen when you install the package or confirm you already have it on your
> pc and it is not working.

Shouldn't then kioslaves be a dependency for krusader? But it's strange that downloads worked, and uploads didn't ...

Anyway, I was using krusader from 3.5.1 until kde-4.3.3 became stable at what point I've updated the whole system and FTP/SFTP/SCP uploads are working.