Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 291883 - app-misc/strigi-0.7.0 eats up all free disk space
Summary: app-misc/strigi-0.7.0 eats up all free disk space
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-04 18:18 UTC by Krzysiek
Modified: 2010-07-08 18:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
ls -sh1 ~/.strigi/clucene/ (clucene_dir,11.71 KB, text/plain)
2009-11-04 18:21 UTC, Krzysiek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Krzysiek 2009-11-04 18:18:14 UTC
After each KDE4 session start up ~/.strigi/clucene directory growing in size and finally eats all my free disk space (~3GB). To avoid system crash due to insufficient disk space I must regulary deleting ~/.strigi/clucene directory. Now I have anly Documents directory added for indexing (under KDE systemsettings) which have only 2GB size, so its smaller than strigi index after few days!

Reproducible: Always

Steps to Reproduce:
1. Start KDE4 Session
2. logout an start again KDE4 (so strigidaemon starts)
3. du -csh ~/.strigi/clucene

Actual Results:  
~/.strigi/clucene directory growing in size for ~500MB in each KDE4 session start up.

Expected Results:  
~/.strigi/clucene constant in size or growin a little when new files were added for indexing.

$ emerge --info
Portage 2.1.6.13 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)                                                                                                             
=================================================================                                             
System uname: Linux-2.6.30-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8200_@_2.66GHz-with-gentoo-1.12.11.1  
Timestamp of tree: Sat, 31 Oct 2009 07:45:03 +0000                                                            
ccache version 2.4 [enabled]                                                                                  
app-shells/bash:     4.0_p28                                                                                  
dev-java/java-config: 2.1.9-r1                                                                                
dev-lang/python:     2.6.2-r1                                                                                 
dev-python/pycrypto: 2.0.1-r8                                                                                 
dev-util/ccache:     2.4-r7                                                                                   
dev-util/cmake:      2.6.4                                                                                    
sys-apps/baselayout: 1.12.11.1                                                                                
sys-apps/sandbox:    1.6-r2                                                                                   
sys-devel/autoconf:  2.13, 2.63-r1                                                                            
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                                     
sys-devel/binutils:  2.18-r3                                                                                  
sys-devel/gcc-config: 1.4.1                                                                                   
sys-devel/libtool:   2.2.6a                                                                                   
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.prz.rzeszow.pl/   ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/     http://gentoo.tiscali.nl/gentoo/"
LANG="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="pl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a52 aac aalib acl acpi aio akonadi alsa amd64 amrnb amrwb ao ares aspell audiofile avi bash-completion beagle berkdb branding bzip2 bzlib cairo caps cdda cddb cdinstall cdio cdr cli consolekit cracklib crypt cups curl dbus dga dirac directfb djvu dri dts dvd dvdr emboss encode evo exif expat fam fbcon ffmpeg fftw firefox flac fltk fortran ftp fuse gd gdbm gif gimp glib glitz gmp gnutls gpm gs hal hyperestraier iconv id3tag ieee1394 imagemagick imlib inotify isdnlog ithreads jabber jack java java6 jbig jpeg jpeg2k kde kipi ladcca ladspa lame lapack latex lcms libcaca libnotify libsamplerate live lm_sensors logrotate lzma lzo mad mbox md5sum mikmod mmap mmx mmxext mng modplug module modules mono mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz ncurses network nls nptl nptlonly nsplugin ogg openexr opengl openmp pam pcre pdf perl phonon pic plasma png policykit postscript ppds pppd python qt3support qt4 quicktime rdesktop readline reflection schroedinger sdl semantic-desktop session slang smp sndfile sound speex spell spl sse sse2 ssl ssse3 startup-notification svg sysfs syslog tcpd tetex theora threads thumbnail thunar tiff tk truetype unicode urandom usb utempter vcd vim-syntax vorbis wavpack webkit wmf x264 xattr xcb xcomposite xml xorg xosd xpm xprint xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" USERLAND="GNU" VIDEO_CARDS="radeon radeonhd vesa vga fbdev fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Krzysiek 2009-11-04 18:21:22 UTC
Created attachment 209246 [details]
ls -sh1 ~/.strigi/clucene/
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2010-01-24 11:22:53 UTC
Could you try to reproduce it with 0.7.1?

Also what useflags you have enabled for strigi?
Comment 3 Krzysiek 2010-01-24 13:16:04 UTC
app-misc/strigi-0.7.0  USE="clucene dbus exif fam hyperestraier inotify qt4 -debug (-log) -test"

Comment 4 Andreas K. Hüttel gentoo-dev 2010-07-07 18:43:13 UTC
How about strigi-0.7.2 (current stable)?
Comment 5 Krzysiek 2010-07-08 18:15:26 UTC
It looks like now strigi working properly.
I dont know what exactly was changed but it seems that ~/.strigi directory is not used anymore.