Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 291819 - x11-drivers/xf86-input-synaptics-1.2.0 ignores options set in hal .fdi file (especially tap-to-click)
Summary: x11-drivers/xf86-input-synaptics-1.2.0 ignores options set in hal .fdi file (...
Status: RESOLVED DUPLICATE of bug 287230
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gilles Dartiguelongue
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-04 09:23 UTC by Martin Wegner
Modified: 2009-11-05 00:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
File /etc/hal/fdi/policy/20-synaptics.fdi (20-synaptics.fdi,2.64 KB, text/plain)
2009-11-04 09:25 UTC, Martin Wegner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Wegner 2009-11-04 09:23:16 UTC
I've installed x11-drivers/xf86-input-synaptics-1.2.0, sys-apps/hal-0.5.13-r2 and x11-base/xorg-server-1.7.1 . My synaptics touchpad is loaded by xorg via evdev and I use hal to set the appropiate x11 options (will attach .fdi for hal).

The problem is now that when X is started, the hal .fdi seems to be loaded correctly as I get:
$ lshal | grep x11_options
  input.x11_options.AccelFactor = '0.0015'  (string)
  input.x11_options.BottomEdge = '4200'  (string)
  input.x11_options.FingerHigh = '30'  (string)
  input.x11_options.FingerLow = '25'  (string)
  input.x11_options.HorizEdgeScroll = '1'  (string)
  input.x11_options.LeftEdge = '1700'  (string)
  input.x11_options.MaxSpeed = '0.18'  (string)
  input.x11_options.MaxTapMove = '220'  (string)
  input.x11_options.MaxTapTime = '180'  (string)
  input.x11_options.MinSpeed = '0.09'  (string)
  input.x11_options.RightEdge = '5300'  (string)
  input.x11_options.SHMConfig = 'true'  (string)
  input.x11_options.TapButton1 = '1'  (string)
  input.x11_options.TapButton2 = '2'  (string)
  input.x11_options.TapButton3 = '3'  (string)
  input.x11_options.TopEdge = '1700'  (string)
  input.x11_options.VertEdgeScroll = '1'  (string)
  input.x11_options.VertScrollDelta = '100'  (string)

But synclient shows this:
$ synclient -l
[...]
    TapButton1              = 0
    TapButton2              = 0
    TapButton3              = 0
[...]

Tap-to-click does not work.

I'll be happy to provide more information if requested.

Reproducible: Always

Actual Results:  
Options set for synaptics touchpad in hal .fdi file are somehow ignored by the driver.

Expected Results:  
Shouldn't be ignored.

$ paludis -ip xf86-input-synaptics hal xorg-server
Building target list...
Building dependency list: ... 236 steps

These packages will be installed:

* sys-apps/hal [R 0.5.13-r2] <target>
    Reasons: app-misc/hal-info-20090716:0::installed, sys-power/pm-utils-1.2.5:0::installed, 2 more
    X acpi -apm consolekit crypt -debug dell -disk-partition -doc laptop policykit (-selinux) build_options: -optional_tests split strip -trace
* x11-base/xorg-server [R 1.7.1] <target>
    Reasons: x11-drivers/xf86-input-evdev-2.3.0:0::installed, x11-drivers/xf86-input-keyboard-1.4.0:0::installed, 3 more
    -debug -dmx hal -ipv6 -kdrive -minimal nptl sdl -tslib xorg build_options: -optional_tests split strip -trace
* x11-drivers/xf86-input-synaptics [R 1.2.0] <target>
    Reasons: x11-base/xorg-drivers-1.7:0::installed
    -debug hal build_options: -optional_tests split strip -trace

Total: 3 packages (3 rebuilds)

$ paludis --info
paludis 0.42.0
Paludis build information:
    Compiler:
        CXX:                   x86_64-pc-linux-gnu-g++ 4.3.3
        CXXFLAGS:               -march=nocona -O2 -pipe
        LDFLAGS:               -Wl,-O1
        DATE:                  2009-11-02T16:23:00+0100

    Libraries:
        C++ Library:           GNU libstdc++ 20090124

    Paths:
        DATADIR:               /usr/share
        LIBDIR:                /usr/lib64
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc
        PYTHONINSTALLDIR:      /usr/lib64/python2.6/site-packages
        RUBYINSTALLDIR:        /usr/lib64/ruby/site_ruby/1.8/x86_64-linux

System: 
    Linux dionysos 2.6.31-gentoo-r4-mw #5 SMP PREEMPT Fri Oct 30 15:04:52 CET 2009 x86_64 Intel(R) Core(TM)2 Duo CPU T7100 @ 1.80GHz GenuineIntel GNU/Linux

Reduced Privs:
    reduced_uid:               1000
    reduced_uid->name:         martin
    reduced_uid->dir:          /home/martin
    reduced_gid:               1000
    reduced_gid->name:         martin

Environment:
    Format:                    paludis
    Config dir:                /etc/paludis
    World file:                /var/db/pkg/world

Repository installed-virtuals:
    format:                    installed_virtuals
    root:                      /

Repository virtuals:
    format:                    virtuals

Repository gentoo:
    format:                    ebuild
    location:                  /usr/portage
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:
    binary_uri_prefix:
    builddir:                  /var/tmp/paludis
    cache:                     /usr/portage/metadata/cache
    distdir:                   /usr/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    names_cache:               /var/empty
    newsdir:                   /usr/portage/metadata/news
    profile_eapi_when_unspecified: 0
    profiles:                  /usr/portage/profiles/default/linux/amd64/10.0/desktop
    securitydir:               /usr/portage/metadata/glsa
    setsdir:                   /usr/portage/sets
    sync:                      rsync://rsync.de.gentoo.org/gentoo-portage
    sync_options:
    use_manifest:              use
    write_cache:               /var/empty

    Package information:
        app-admin/eselect-compiler: (none)
        app-shells/bash:       4.0_p35
        dev-java/java-config:  2.1.9-r1
        dev-lang/python:       2.4.6 2.5.4-r3 2.6.4 3.1.1-r1
        dev-python/pycrypto:   (none)
        dev-util/ccache:       (none)
        dev-util/cmake:        2.6.4-r3
        dev-util/confcache:    (none)
        sys-apps/baselayout:   2.0.1
        sys-apps/openrc:       0.5.2-r1
        sys-apps/sandbox:      2.2
        sys-devel/autoconf:    2.13 2.63-r1
        sys-devel/automake:    1.10.2 1.11 1.5 1.7.9-r1 1.8.5-r3 1.9.6-r2
        sys-devel/binutils:    2.20
        sys-devel/gcc-config:  1.4.1
        sys-devel/libtool:     2.2.6a
        virtual/os-headers:    2.6.30-r1 (for sys-kernel/linux-headers:0::installed)

Repository installed:
    format:                    vdb
    location:                  /var/db/pkg
    builddir:                  /var/tmp/paludis
    eapi_when_unknown:         0
    names_cache:               /var/empty
    provides_cache:            /var/empty
    root:                      /
Comment 1 Martin Wegner 2009-11-04 09:25:13 UTC
Created attachment 209189 [details]
File /etc/hal/fdi/policy/20-synaptics.fdi
Comment 2 Andreas Arens 2009-11-04 12:21:18 UTC
Did you also update gnome? I ran into the same and it turned out that gnome switched if off (You can reenable using the control center)? Try XSESSION=Xorg or such and see if the problem persists to rule that out.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-11-05 00:10:52 UTC
Assuming you are using gnome 2.28, this is bug #287230

*** This bug has been marked as a duplicate of bug 287230 ***