Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 291724 - app-emulation/bochs-2.4.1-r1 enhancement
Summary: app-emulation/bochs-2.4.1-r1 enhancement
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Luca Barbato
URL: http://bochs.sourceforge.net/
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-03 15:52 UTC by Daniele C.
Modified: 2016-05-28 08:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
app-emulation/bochs-2.4.1-r1 (bochs-2.4.1-r1.ebuild,3.27 KB, text/plain)
2009-11-03 15:54 UTC, Daniele C.
Details
bochs-2.4.1-lpthread.patch (bochs-2.4.1-lpthread.patch,232 bytes, patch)
2009-11-03 15:56 UTC, Daniele C.
Details | Diff
app-emulation/bochs-2.4.1-r1 (bochs-2.4.1-r1.ebuild,3.25 KB, text/plain)
2009-11-03 17:08 UTC, Daniele C.
Details
app-emulation/bochs-2.4.2 (bochs-2.4.2.ebuild,3.15 KB, text/plain)
2010-01-26 08:18 UTC, Daniele C.
Details
app-emulation/bochs-2.4.2 (bochs-2.4.2.ebuild,3.15 KB, text/plain)
2010-01-26 08:23 UTC, Daniele C.
Details
bochs-2.4.2-lpthread.patch (bochs-2.4.2-lpthread.patch,232 bytes, patch)
2010-01-26 08:24 UTC, Daniele C.
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniele C. 2009-11-03 15:52:04 UTC
Here's an enhanced ebuild for Bochs, with several USE flags for a more flexible configuration, necessary for an advanced use of the emulator.
There were problems with the debugger gui: with --enable-plugins and the proper “display_library” option in the bochsrc, it crashes every time. Removing --enable-plugins from the ./configure, it doesn't compile. The lpthread patch makes it compile, then the debugger gui works fine.

Reproducible: Always
Comment 1 Daniele C. 2009-11-03 15:54:43 UTC
Created attachment 209136 [details]
app-emulation/bochs-2.4.1-r1
Comment 2 Daniele C. 2009-11-03 15:56:01 UTC
Created attachment 209137 [details, diff]
bochs-2.4.1-lpthread.patch
Comment 3 Daniele C. 2009-11-03 17:08:08 UTC
Created attachment 209141 [details]
app-emulation/bochs-2.4.1-r1

A little fix.
Comment 4 Justin Lecher (RETIRED) gentoo-dev 2009-11-03 20:22:49 UTC
Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Thanks,
On behalf of the Gentoo Sunrise Team,
Justin.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 5 Justin Lecher (RETIRED) gentoo-dev 2009-11-03 20:28:11 UTC
Sorry for the sunrise gingle. This Is of course invalid as the package is already in the tree!!!!
Comment 6 Daniele C. 2009-11-03 20:53:53 UTC
Yes, what I'm actually proposing is a revision of the current ebuild in the tree.
Comment 7 Samuli Suominen (RETIRED) gentoo-dev 2009-12-08 15:04:10 UTC
I fail to see why bug 165270 is referenced in this bug, removing...
Comment 8 Luca Barbato gentoo-dev 2009-12-09 04:50:26 UTC
Sorry for the delay, this bug looks like an upstream issue, had they been notified?
I hope to look into it soon
Comment 9 Daniele C. 2010-01-26 08:18:27 UTC
Created attachment 217456 [details]
app-emulation/bochs-2.4.2
Comment 10 Daniele C. 2010-01-26 08:23:42 UTC
Created attachment 217458 [details]
app-emulation/bochs-2.4.2

Updated ebuild for Bochs 2.4.2
(sorry for the previous mistake)
Comment 11 Daniele C. 2010-01-26 08:24:48 UTC
Created attachment 217459 [details, diff]
bochs-2.4.2-lpthread.patch
Comment 12 Pacho Ramos gentoo-dev 2016-05-28 08:17:58 UTC
Ebuild patches would need to be updated to 2.6.8 :/