Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 291639 - amarok-1.4.10_p20090130-r3 refuses to build collection
Summary: amarok-1.4.10_p20090130-r3 refuses to build collection
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2009-11-02 22:20 UTC by Lars
Modified: 2009-11-06 17:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Lars 2009-11-02 22:20:05 UTC
I had a music collection in amarok, which is now gone and whatever I do, amarok does not rebuild it.

The day before yesterday everything was working well untill I wanted to rescan my music folder, which is mounted using nfs3 and completely accessable - manual music playing is possible. Since amarok did neither allow me to update nor rescan the collection (zero cpu usage, no status bar, nothing changed after hours, no open files listed by lsof), I thought it would be a mysql problem (using mysql-5.0.84-r1). I have re-created the database on the server. I re-opend amarok serveal times. I created my own mysql database locally. I switched to sqlight. I selected a local folder instead of nfs-mounted one. I unemerged amarok and emerged it again, without any ccache enabled. I compiled it with the debug useflag to see some output (attached below). I deleted my personal settings in ~/.kde/share/amarok and ~/.kde/share/config/amarokrc. I remembered to updated from qt-4.5.2 to qt-4.5.3 the other day, so I downgraded all packages again which were updated (as seen in the /var/log/emerge.log). I ran revdep-rebuild. I tried all these things in different order and some of them two or more times. Non of all this worked!
I'm completly stuck. What more should I do or test?

emerge --info
Portage (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5de x86_64)
System uname: Linux-2.6.30-gentoo-r5de-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P7550_@_2.26GHz-with-gentoo-   
Timestamp of tree: Sun, 01 Nov 2009 20:15:01 +0000                                                               
app-shells/bash:     4.0_p28                                                                                     
dev-java/java-config: 2.1.9-r1                                                                                   
dev-lang/python:     2.6.2-r1                                                                                    
dev-util/cmake:      2.6.4                                                                                       
sys-apps/sandbox:    1.6-r2                                                                                      
sys-devel/autoconf:  2.13, 2.63-r1                                                                               
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                                        
sys-devel/binutils:  2.18-r3                                                                                     
sys-devel/gcc-config: 1.4.1                                                                                      
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -msse -msse2 -msse3 -mmmx"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -msse -msse2 -msse3 -mmmx"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 ao apache2 apm arts audiofile bash-completion berkdb bidi bluetooth branding bzip2 cairo cdda cdinstall cdio cdparanoia cdr chm cli consolekit cracklib crypt css cups dbus dga dirac djvu dri dts dv dvd dvdr dvdread ebook eds emboss enblend encode evo fam ffmpeg firefox flac fortran freetype ftp gcj gdbm gif gimp gnuplot gnutls gpm gstreamer gtk hal history httpd iconv icq ieee1394 ilbc imap irc jabber java javascript jpeg jpeg2k kde kpathsea kqemu kvm lame laptop latex libnotify libwww lirc live lxc mad matroska mbrola mikmod mime mjpeg mmx mng modules mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz mysql nas ncurses nls nntp nocd npp nptl nptlonly nsplugin nvidia ogg oggvorbis openal opengl openmp oscar pam pcmcia pcre pdf perl php png ppds pppd pulseaudio python qemu qt3 qt3support qt4 quicktime raw readline reflection rss samba scga schroedinger sdl session sift smartcard sndfile sox speex spell spl sql sse sse2 sse3 ssl ssse3 startup-notification stream subtitles svg sysfs szip tcpd tetex theora threads thunar tiff truetype unicode usb v4l v4l2 vcd vlm vorbis wavpack webkit wifi wxwindows x264 xcomposite xine xinerama xinetd xml xorg xosd xpm xsl xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel intel8×0 intel8×0m usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" LIRC_DEVICES="devinput" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Comment 1 Lars 2009-11-02 22:28:29 UTC
amarok's debug output when triggering "rescan collection"

amarok: BEGIN: ScanController::ScanController(CollectionDB*, bool, const QStringList&)
amarok: END__: ScanController::ScanController(CollectionDB*, bool, const QStringList&) - Took 0.0082s
amarok: BEGIN: virtual void ThreadManager::Thread::run()
amarok: BEGIN: virtual bool ScanController::doJob()
amarok: BEGIN: MySqlConnection::MySqlConnection(const MySqlConfig*)
amarok:       [CollectionDB] [MySqlConnection::MySqlConnection(const MySqlConfig*)]
amarok:       [CollectionDB] Connection Charset is now: utf8
amarok: END__: MySqlConnection::MySqlConnection(const MySqlConfig*) - Took 0.0012s
amarok: BEGIN: void CollectionDB::createTables(bool)
amarok: END__: void CollectionDB::createTables(bool) - Took 0.035s
amarok: BEGIN: void CollectionDB::prepareTempTables()
amarok: END__: void CollectionDB::prepareTempTables() - Took 0.02s
amarok: BEGIN: void CollectionDB::copyTempTables()
amarok: END__: void CollectionDB::copyTempTables() - Took 0.0088s
amarok: END__: virtual bool ScanController::doJob() - Took 1.6s
amarok: END__: virtual void ThreadManager::Thread::run() - Took 1.6s
amarok: [CollectionDB] JobFinishedEvent from ScanController received.
amarok: [ThreadManager] Job completed: CollectionScanner. Jobs pending: 0
amarok: BEGIN: virtual ScanController::~ScanController()
amarok: END__: virtual ScanController::~ScanController() - Took 0.00014s
amarok: BEGIN: virtual void ThreadManager::Thread::run()
amarok: BEGIN: virtual bool UrlUpdateJob::doJob()
amarok:     [MountPointManager] Trying to update 1 statistics rows
amarok:     [MountPointManager] Trying to update 0 tags_labels rows
amarok: END__: virtual bool UrlUpdateJob::doJob() - Took 0.0015s
amarok: END__: virtual void ThreadManager::Thread::run() - Took 0.0017s
amarok: [ThreadManager] Job completed: UrlUpdateJob. Jobs pending: 0

no more action
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2009-11-06 11:39:27 UTC
kde3 is on way out of tree. Sorry but we dont have manpower to fix it.

Try amarok-2.2 is best thing i can offer to you.
Comment 3 Lars 2009-11-06 17:58:00 UTC
ok. amarok 2 did not even show me the possibility to create a music collection database, but i guess that's another bug ;-)

thanks so far.