Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 291312 - x11-base/xorg-server-1.6.5 Fails to compile
Summary: x11-base/xorg-server-1.6.5 Fails to compile
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 291319 291857 291892 292669 295267 296077 301351 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-31 15:43 UTC by Steve Warren
Modified: 2010-04-13 18:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,23.59 KB, text/plain)
2009-10-31 15:53 UTC, Steve Warren
Details
environment (environment,145.49 KB, text/plain)
2009-10-31 15:56 UTC, Steve Warren
Details
build.log after insallinig x11-libs/libXinerama-1.1 (build.log,24.12 KB, text/plain)
2009-10-31 16:47 UTC, Steve Warren
Details
environment after installing x11-libs/libXinerama-1.1 (environment,145.15 KB, text/plain)
2009-10-31 16:48 UTC, Steve Warren
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Warren 2009-10-31 15:43:03 UTC
emerge xorg-server fails compile with "../Xext/panoramiX.h:44:41: error: X11/extensions/panoramiXext.h: No such file or directory" 

This is on a new install, not an upgrade.

Reproducible: Always

Steps to Reproduce:
1.emerge xorg-server
2.
3.

Actual Results:  
In file included from dispatch.c:134:                                            
../Xext/panoramiX.h:44:41: error: X11/extensions/panoramiXext.h: No such file or directory                                                                        
dispatch.c: In function 'ProcCloseFont':                                         
dispatch.c:1117: warning: 'SecurityLookupIDByType' is deprecated (declared at ../include/resource.h:268)                                                          
make[2]: *** [dispatch.lo] Error 1                                               
make[2]: *** Waiting for unfinished jobs....                                     
mv -f .deps/colormap.Tpo .deps/colormap.Plo                                      
mv -f .deps/devices.Tpo .deps/devices.Plo                                        
make[2]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.6.5/work/xorg-server-1.6.5/dix'                                                               
make[1]: *** [all] Error 2                                                       
make[1]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.6.5/work/xorg-server-1.6.5/dix'                                                               
make: *** [all-recursive] Error 1                                                
 * ERROR: x11-base/xorg-server-1.6.5 failed:                                     
 *   emake failed                                                                
 *                                                                               
 * Call stack:                                                                   
 *     ebuild.sh, line   49:  Called src_compile                                 
 *   environment, line 3561:  Called x-modular_src_compile                       
 *   environment, line 4487:  Called x-modular_src_make                          
 *   environment, line 4526:  Called die                                         
 * The specific snippet of code:                                                 
 *       emake || die "emake failed"                                             
 *                                                                               
 * If you need support, post the output of 'emerge --info =x11-base/xorg-server-1.6.5',                                                                           
 * the complete build log and the output of 'emerge -pqv =x11-base/xorg-server-1.6.5'.                                                                            
 * The complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.6.5/temp/build.log'.                                                             
 * The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-1.6.5/temp/environment'.                                                      
 * S: '/var/tmp/portage/x11-base/xorg-server-1.6.5/work/xorg-server-1.6.5'       

 * Messages for package x11-base/xorg-server-1.6.5:

 * ERROR: x11-base/xorg-server-1.6.5 failed:
 *   emake failed                           
 *                                          
 * Call stack:                              
 *     ebuild.sh, line   49:  Called src_compile
 *   environment, line 3561:  Called x-modular_src_compile
 *   environment, line 4487:  Called x-modular_src_make   
 *   environment, line 4526:  Called die                  
 * The specific snippet of code:                          
 *       emake || die "emake failed"                      
 *                                                        
 * If you need support, post the output of 'emerge --info =x11-base/xorg-server-1.6.5',                                                                           
 * the complete build log and the output of 'emerge -pqv =x11-base/xorg-server-1.6.5'.                                                                            
 * The complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.6.5/temp/build.log'.                                                             
 * The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-1.6.5/temp/environment'.                                                      
 * S: '/var/tmp/portage/x11-base/xorg-server-1.6.5/work/xorg-server-1.6.5'

Expected Results:  
Successful install

Portage 2.2_rc46 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.10.1-r0, 2.6.31-gentoo-01 i686)                                                                      
=================================================================                
System uname: Linux-2.6.31-gentoo-01-i686-Intel-R-_Pentium-R-_4_CPU_3.20GHz-with-gentoo-2.0.1                                                                     
Timestamp of tree: Fri, 30 Oct 2009 23:30:01 +0000                               
app-shells/bash:     4.0_p35                                                     
dev-java/java-config: 2.1.9-r1                                                   
dev-lang/python:     2.6.4                                                       
sys-apps/baselayout: 2.0.1                                                       
sys-apps/openrc:     0.5.2-r1                                                    
sys-apps/sandbox:    2.2                                                         
sys-devel/autoconf:  2.63-r1                                                     
sys-devel/automake:  1.10.2, 1.11                                                
sys-devel/binutils:  2.20                                                        
sys-devel/gcc-config: 1.4.1                                                      
sys-devel/libtool:   2.2.6a                                                      
virtual/os-headers:  2.6.30-r1                                                   
ACCEPT_KEYWORDS="x86 ~x86"                                                       
CBUILD="i686-pc-linux-gnu"                                                       
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"                          
CHOST="i686-pc-linux-gnu"                                                        
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind /var/lib/hsqldb"             
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                                                
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"                        
DISTDIR="/usr/portage/distfiles"                                                 
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox"                                                                 
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"                                                             
LDFLAGS="-Wl,-O1"                                                                
LINGUAS="en_US en ja ko zh_CN zh_TW"                                             
MAKEOPTS="-j3"                                                                   
PKGDIR="/usr/portage/packages"                                                   
PORTAGE_CONFIGROOT="/"                                                           
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                     
PORTAGE_TMPDIR="/var/tmp"                                                        
PORTDIR="/usr/portage"                                                           
SYNC="rsync://rsync.gentoo.org/gentoo-portage"                                   
USE="X a52 aac aalib acl acpi aim alsa ao arts audiofile avi bash-completion berkdb bonobo bzip2 bzlib cairo cdb cddb cdparanoia cdr cjk cli consolekit cracklib crypt cups curl curlwrappers dbus dga dio divix4linux dri dts dvd dvdr dvdread encode esd fam fbcon ffmpeg firefox flac font-server foomaticdb fortran ftp gb gd gdbm gif glitz gmp gnutils gphoto2 gpm gstreamer gtk gtk2 guile hal iconv icq ieee1394 immqt-bc ipv6 isdnlog jack java javascript jikes jpeg kde libg++ mad mbox mime mmap mmx mng modules mozilla mp3 mpeg mplayer msn mudflap mysql ncurses nls nptl nptlonly nvidia offensive ogg openal opengl openmp oss pam pcre pdf perl png posix ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba session slang sockets softmmu spell spl sql sqlite sse ssl svg svga sysfs tcl tcpd tetex theora tiff tk truetype unicode usb vcd videos vim-syntax vorbis webkit win32codecs x264 x86 xcomposite xine xinetd xml xml2 xorg yahoo zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en ja ko zh_CN zh_TW" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Steve Warren 2009-10-31 15:53:52 UTC
Created attachment 208861 [details]
build.log
Comment 2 Steve Warren 2009-10-31 15:56:32 UTC
Created attachment 208862 [details]
environment
Comment 3 Markus Wernig 2009-10-31 16:04:54 UTC
Do you have libXinerama installed?
# equery b panoramiXext.h 
on my system shows the file belongs to x11-libs/libXinerama-1.1.
Maybe the xorg-server ebuild is missing this dependency.
Comment 4 Steve Warren 2009-10-31 16:31:01 UTC
I didn't have x11-libs/libXinerama-1.1, so I installed livXinerama and now
xorg-server fails with:

In file included from ../Xext/panoramiX.h:44,                                   
                 from dispatch.c:134:                                           
/usr/include/X11/extensions/panoramiXext.h:49: error: expected ')' before '*'
token                                                                           
/usr/include/X11/extensions/panoramiXext.h:54: error: expected '=', ',', ';',
'asm' or '__attribute__' before 'XPanoramiXQueryVersion'                        
/usr/include/X11/extensions/panoramiXext.h:64: error: expected '=', ',', ';',
'asm' or '__attribute__' before 'XPanoramiXGetState'                            
/usr/include/X11/extensions/panoramiXext.h:70: error: expected '=', ',', ';',
'asm' or '__attribute__' before 'XPanoramiXGetScreenCount'                      
/usr/include/X11/extensions/panoramiXext.h:76: error: expected '=', ',', ';',
'asm' or '__attribute__' before 'XPanoramiXGetScreenSize'                       
dispatch.c: In function 'ProcCloseFont':                                        
dispatch.c:1117: warning: 'SecurityLookupIDByType' is deprecated (declared at
../include/resource.h:268)                                                      
make[2]: *** [dispatch.lo] Error 1
Comment 5 Steve Warren 2009-10-31 16:47:13 UTC
Created attachment 208867 [details]
build.log after insallinig x11-libs/libXinerama-1.1
Comment 6 Steve Warren 2009-10-31 16:48:03 UTC
Created attachment 208869 [details]
environment after installing x11-libs/libXinerama-1.1
Comment 7 Sebastian Luther (few) 2009-10-31 16:55:25 UTC
*** Bug 291319 has been marked as a duplicate of this bug. ***
Comment 8 Markus Wernig 2009-10-31 20:10:18 UTC
*** Bug 291319 has been marked as a duplicate of this bug. ***
Comment 9 Markus Wernig 2009-10-31 20:18:23 UTC
This seems to affect xorg-server-1.6.5 only. After removing all nvidia stuff, emerge jumped directly to xorg-server-1.7.1, which compiled without issues.

Google found this post: http://www.mail-archive.com/xorg@lists.freedesktop.org/msg04615.html , but I'm not quite sure what to make of it.
Comment 10 Steve Warren 2009-10-31 21:13:00 UTC
Unfortunately there are no nvidia drivers that will work with xorg-server-1.7.1, which meant that xorg-server-1.7.1 is not a fix. The most up to date nvidia driver for my card is 173.14.20 with no idea when there will be a 173.14.21
and nvidia is not talking.
Comment 11 Markus Wernig 2009-10-31 21:15:58 UTC
Have you tried the nv driver from xorg as a temporary alternative?
Comment 12 Rémi Cardona gentoo-dev 2009-10-31 23:20:46 UTC
If you want to go back to xorg-server 1.6, you need to add the following list to your portage.mask list :

>=x11-apps/xinput-1.5.0
>=x11-base/xorg-drivers-1.7
>=x11-base/xorg-server-1.7.1
>=x11-libs/libX11-1.3.2
>=x11-libs/libXScrnSaver-1.2.0
>=x11-libs/libXext-1.1.1
>=x11-libs/libXi-1.3
>=x11-libs/libXinerama-1.1
>=x11-libs/libXtst-1.1.0
>=x11-libs/libXxf86dga-1.1.1
>=x11-libs/libXxf86vm-1.1.0
>=x11-proto/bigreqsproto-1.1.0
>=x11-proto/fixesproto-4.1.1
>=x11-proto/inputproto-2.0
>=x11-proto/recordproto-1.14
>=x11-proto/scrnsaverproto-1.2.0
>=x11-proto/xcmiscproto-1.2.0
>=x11-proto/xextproto-7.1.1
>=x11-proto/xf86bigfontproto-1.2.0
>=x11-proto/xf86dgaproto-2.1
>=x11-proto/xf86driproto-2.1.0
>=x11-proto/xf86vidmodeproto-2.3
>=x11-proto/xineramaproto-1.2

Better yet, fully upgrade your system to 1.7 with "emerge -DuNa world".

Thanks
Comment 13 Steve Kutnar 2009-11-01 16:53:33 UTC
I'm running into this issue doing a re-emerge of my entire system.

Please explain why this is "RESOLVED INVALID".  There should be blocks/deps in place that prevent any of the xorg-server 1.7 pieces from being installed if it is discovered that nvidia-drivers (or whatever) will not work with that version.  Similar situations have occurred before.  I don't understand why this is different.
Comment 14 Rémi Cardona gentoo-dev 2009-11-01 17:52:12 UTC
(In reply to comment #13)
> Please explain why this is "RESOLVED INVALID".  There should be blocks/deps in
> place that prevent any of the xorg-server 1.7 pieces from being installed if it
> is discovered that nvidia-drivers (or whatever) will not work with that
> version.

Portage wants to pull both xorg-server 1.7 and nvidia-drivers, but the blocker in place tells portage to stop. Portage cannot pick which one you want, xorg 1.7 or nvidia-drivers. That's up to _you_ to tell portage which one you want.

> Similar situations have occurred before.  I don't understand why this
> is different.

Right and like last times, you have to put masks. The only difference here is that you need to use the list we provided for package.mask.

Thanks
Comment 15 Steve Kutnar 2009-11-01 18:46:06 UTC
(In reply to comment #14)
> Portage wants to pull both xorg-server 1.7 and nvidia-drivers, but the blocker
> in place tells portage to stop. Portage cannot pick which one you want, xorg
> 1.7 or nvidia-drivers. That's up to _you_ to tell portage which one you want.
> 
> > Similar situations have occurred before.  I don't understand why this
> > is different.
> 
> Right and like last times, you have to put masks. The only difference here is
> that you need to use the list we provided for package.mask.
> 
> Thanks
> 

In those past situations, emerge basically 'shouts' that the situation cannot be resolved by displaying hard blocks and listing all the affected packages pulling in the deps.  At least then we know we have to take a look somewhere for information and decide how to handle it.

This time, I never saw a single block and had no clue xorg-server-1.7 even existed until xorg-server-1.6.5 failed to compile.  All these items you show that need to be masked for xorg-server-1.6.5 actually are installed and seemingly working fine with my existing setup.  I only ran into this issue when trying to rebuild xorg-server.

So, no, this time is definitely not like those past situations.  The solution in my mind is to put the proper deps into xorg-server-1.6.5 and wherever else so it won't pull in these items that are supposed to be masked.  Conversely, put deps into these newer items that prevent them from being installed if xorg-server-1.6.5 is present.  Maybe both.
Comment 16 Rémi Cardona gentoo-dev 2009-11-01 19:41:57 UTC
Again, that can't happen because ebuilds don't support range dependencies (for example "need libXi >=1.2 and <2.0")

So no, there's nothing we can do here. We expect people to upgrade to all the latest ~arch packages, other mixes are really hard to support, especially with the current EAPIs.

Thanks
Comment 17 Markus Wernig 2009-11-01 21:47:27 UTC
I'm not sure if I got this right, but wouldn't something like
RDEPEND !>x11-libs/libXinerama-1.0.3 in the xorg-server-1.6.5 ebuild
or
RDEPEND !>x11-base/xorg-server-1.6.5 in the libXinerama-1.1 ebuild 
(and the others)
have prevented this and led to more meaningful messages?
Comment 18 Steve Warren 2009-11-02 23:54:35 UTC
Without nividia-drivers that work with xorg-server-1.7.1 going to 1.7.1 is not an option.  Why should I prefer the 2d nv driver that has less functionality to the nvidia 3d driver that makes for more functionality?  It seems to me that xorg-server-1.7.1 would downgrade the usefulness of my computer at this time.

 
Comment 19 Steve Kutnar 2009-11-03 02:47:57 UTC
(In reply to comment #18)
> Without nividia-drivers that work with xorg-server-1.7.1 going to 1.7.1 is not
> an option.  Why should I prefer the 2d nv driver that has less functionality to
> the nvidia 3d driver that makes for more functionality?  It seems to me that
> xorg-server-1.7.1 would downgrade the usefulness of my computer at this time.
> 
> 

If you have a supported card, unmask the following:
x11-drivers/nvidia-drivers-190.42-r2
media-video/nvidia-settings-190.42 if you use this

Both work fine for me with an 8600 GT.  Check with nVidia to see if there will be any updates to the older drivers to support the newer ABI.
Comment 20 Steve Warren 2009-11-04 03:03:07 UTC
> 
> If you have a supported card, unmask the following:
> x11-drivers/nvidia-drivers-190.42-r2
> media-video/nvidia-settings-190.42 if you use this
> 
> Both work fine for me with an 8600 GT.  Check with nVidia to see if there will
> be any updates to the older drivers to support the newer ABI.
> 

My card is a 5950 ULTRA which is supported with x11-drivers/nvidia-drivers-173.14.20.  Until nvidia releases a new driver xorg-server is useless to me.  xorg-server-1.6.5 is the highest ~x86 that I can use.
Comment 21 Rémi Cardona gentoo-dev 2009-11-04 20:33:13 UTC
*** Bug 291892 has been marked as a duplicate of this bug. ***
Comment 22 Rémi Cardona gentoo-dev 2009-11-04 20:34:07 UTC
*** Bug 291857 has been marked as a duplicate of this bug. ***
Comment 23 Miguel R. Caudevilla 2009-11-04 20:56:26 UTC
> In those past situations, emerge basically 'shouts' that the situation cannot
> be resolved by displaying hard blocks and listing all the affected packages
> pulling in the deps.  At least then we know we have to take a look somewhere
> for information and decide how to handle it.
> 
> This time, I never saw a single block and had no clue xorg-server-1.7 even
> existed until xorg-server-1.6.5 failed to compile.  All these items you show
> that need to be masked for xorg-server-1.6.5 actually are installed and
> seemingly working fine with my existing setup.  I only ran into this issue when
> trying to rebuild xorg-server.
> 
> So, no, this time is definitely not like those past situations.  The solution
> in my mind is to put the proper deps into xorg-server-1.6.5 and wherever else
> so it won't pull in these items that are supposed to be masked.  Conversely,
> put deps into these newer items that prevent them from being installed if
> xorg-server-1.6.5 is present.  Maybe both.
> 

I have the same issue you have been suffering but IMHO i think that the message
Gentoo gives as feedback in my case is very clear:

Actual Results:  
!!! One or more updates have been skipped due to a dependency conflict:

x11-base/xorg-server:0

  ('ebuild', '/', 'x11-base/xorg-server-1.7.1', 'merge') conflicts with
    <x11-base/xorg-server-1.6.99 required by ('installed', '/',
'x11-drivers/nvidia-drivers-96.43.13', 'nomerge')


I think that as Remi Cardona said: "That's up to _you_ to tell portage which
one you want." and at least you can look around to see if others have the same
problem and that you discover once again that closed source is a pain in the
neck for all of us... ;)

Again, i would like to thank the gentoo team for the help in this issue, but
IMHO i think that recommending nv driver isn't quite a great solution in the
21st century. 90% of the users will want 3d support so i think that maybe a new
USE flag could be great... something like legacy-nvidia. With this USE flag,
portage could understand that this users don't want to upgrade to
xorg-server-1.7.1

Ok, it is only an idea and i don't really know if this would work.
Comment 24 kavol 2009-11-04 22:40:52 UTC
(In reply to comment #14)
> Portage wants to pull both xorg-server 1.7 and nvidia-drivers, but the blocker
> in place tells portage to stop. Portage cannot pick which one you want, xorg
> 1.7 or nvidia-drivers. That's up to _you_ to tell portage which one you want.

excuses, excuses, excuses ...

I HAVE TOLD to portage that I want nvidia-drivers by explicitly emerging them which leads to nvidia-drivers being recorded in "world"

I have NOT told to portage that I want xorg-server (of any version) - it was pulled in as dependency

it is NOT my job to manually resolve dependencies, it is portage's job
Comment 25 Rémi Cardona gentoo-dev 2009-11-05 07:12:28 UTC
(In reply to comment #24)
> excuses, excuses, excuses ...

Then send us patches instead of complaining. I have done _everything_ portage allows me to do.

So thanks for the token of gratitude, you make me glow.
Comment 26 kavol 2009-11-05 15:40:49 UTC
(In reply to comment #25)
> (In reply to comment #24)
> > excuses, excuses, excuses ...
> Then send us patches instead of complaining.

I'm not a Python programmer

everyone has his role and no one can do everything - I contribute to F/OSS by testing, some translations and Fedora packaging (competition! heretic! burn him! :-)

> I have done _everything_ portage allows me to do.

then it is portage what needs to be improved; what is the bug number I can vote for?

> So thanks for the token of gratitude, you make me glow.

the point is not what you are doing for the packaging; in no way I am saying that I am not grateful for all the work that the developers, including you, do for us, the users

the point is that you are telling us there is no bug while users keep running into it - sorry, no gratitude for this

you could choose to say "sorry guys, it is really hard for us to support it, please use this workaround, WONTFIX" instead of "it is your fault that portage is unable to resolve the dependecies correctly, INVALID"

sorry for me being a bit impolite, but I got hurt first

but this leads to nowhere; I'm just explaining my attitude, take it or leave it


so, to be constructive:

what is wrong with the solution proposed within comment #17?
Comment 27 Kent Fredric (IRC: kent\n) gentoo-dev 2009-11-05 15:54:28 UTC
(In reply to comment #12)
> If you want to go back to xorg-server 1.6, you need to add the following list
> to your portage.mask list :
> 
> >=x11-apps/xinput-1.5.0
> >=x11-base/xorg-drivers-1.7
> >=x11-base/xorg-server-1.7.1
> >=x11-libs/libX11-1.3.2
> >=x11-libs/libXScrnSaver-1.2.0
> >=x11-libs/libXext-1.1.1
> >=x11-libs/libXi-1.3
> >=x11-libs/libXinerama-1.1
> >=x11-libs/libXtst-1.1.0
> >=x11-libs/libXxf86dga-1.1.1
> >=x11-libs/libXxf86vm-1.1.0
> >=x11-proto/bigreqsproto-1.1.0
> >=x11-proto/fixesproto-4.1.1
> >=x11-proto/inputproto-2.0
> >=x11-proto/recordproto-1.14
> >=x11-proto/scrnsaverproto-1.2.0
> >=x11-proto/xcmiscproto-1.2.0
> >=x11-proto/xextproto-7.1.1
> >=x11-proto/xf86bigfontproto-1.2.0
> >=x11-proto/xf86dgaproto-2.1
> >=x11-proto/xf86driproto-2.1.0
> >=x11-proto/xf86vidmodeproto-2.3
> >=x11-proto/xineramaproto-1.2
> 
> Better yet, fully upgrade your system to 1.7 with "emerge -DuNa world".
> 
> Thanks
> 

Thanks remi, this mask list is exactly what I needed. 

Although the resolution may be by nature a bit harsh, Wontfix ( ie: cant be
fixed for whatever reason and cite the reason ) will hopefully have less
user-spite. 
Comment 28 Rémi Cardona gentoo-dev 2009-11-14 16:07:18 UTC
*** Bug 292669 has been marked as a duplicate of this bug. ***
Comment 29 Vladimir Berezhnoy 2009-11-14 17:16:17 UTC
I might be misunderstanding something, but ebuild for ati-drivers does have a dual dependency for xorg-serrver and it works just as expected. So why is it not possible to add deps to xorg-server ebuild in the same way?

RDEPEND="
    !>=x11-base/xorg-server-1.7.0
    >=x11-base/xorg-server-1.5.3-r7
"
Comment 30 Rémi Cardona gentoo-dev 2009-12-01 19:44:11 UTC
*** Bug 295267 has been marked as a duplicate of this bug. ***
Comment 31 Rémi Cardona gentoo-dev 2009-12-08 13:55:57 UTC
*** Bug 296077 has been marked as a duplicate of this bug. ***
Comment 32 Rémi Cardona gentoo-dev 2009-12-08 14:19:28 UTC
*** Bug 296077 has been marked as a duplicate of this bug. ***
Comment 33 Sebastian Luther (few) 2009-12-08 14:42:42 UTC
*** Bug 296077 has been marked as a duplicate of this bug. ***
Comment 34 Rémi Cardona gentoo-dev 2009-12-08 20:53:14 UTC
*** Bug 296077 has been marked as a duplicate of this bug. ***
Comment 35 Rémi Cardona gentoo-dev 2009-12-09 07:29:35 UTC
*** Bug 296077 has been marked as a duplicate of this bug. ***
Comment 36 Rémi Cardona gentoo-dev 2009-12-09 07:42:53 UTC
*** Bug 296077 has been marked as a duplicate of this bug. ***
Comment 37 Rémi Cardona gentoo-dev 2009-12-09 14:19:23 UTC
Sorry for all the noise folks, I'll just un-CC you in case there are more duped bugs (or if the war waging in bug #296077 doesn't settle down).

Cheers :)
Comment 38 Rémi Cardona gentoo-dev 2010-01-20 22:03:08 UTC
*** Bug 301351 has been marked as a duplicate of this bug. ***
Comment 39 Jacob Martin 2010-02-02 03:55:29 UTC
Three months after the initial report, I've run into the same bug.  

It's definitely a PITA, so I don't see why it is "RESOLVED" or "INVALID".

Just my one cent.
Comment 40 gentoo 2010-04-13 16:30:48 UTC
I also got bit with this one.  There is nothing we can do?
Comment 41 gentoo 2010-04-13 18:02:43 UTC
On my system I needed to mask these as well:
>=x11-libs/libdmx-1.1.0
>=x11-proto/dmxproto-2.3


(In reply to comment #12)
> If you want to go back to xorg-server 1.6, you need to add the following list
> to your portage.mask list :
> 
> >=x11-apps/xinput-1.5.0
> >=x11-base/xorg-drivers-1.7
> >=x11-base/xorg-server-1.7.1
> >=x11-libs/libX11-1.3.2
> >=x11-libs/libXScrnSaver-1.2.0
> >=x11-libs/libXext-1.1.1
> >=x11-libs/libXi-1.3
> >=x11-libs/libXinerama-1.1
> >=x11-libs/libXtst-1.1.0
> >=x11-libs/libXxf86dga-1.1.1
> >=x11-libs/libXxf86vm-1.1.0
> >=x11-proto/bigreqsproto-1.1.0
> >=x11-proto/fixesproto-4.1.1
> >=x11-proto/inputproto-2.0
> >=x11-proto/recordproto-1.14
> >=x11-proto/scrnsaverproto-1.2.0
> >=x11-proto/xcmiscproto-1.2.0
> >=x11-proto/xextproto-7.1.1
> >=x11-proto/xf86bigfontproto-1.2.0
> >=x11-proto/xf86dgaproto-2.1
> >=x11-proto/xf86driproto-2.1.0
> >=x11-proto/xf86vidmodeproto-2.3
> >=x11-proto/xineramaproto-1.2
> 
> Better yet, fully upgrade your system to 1.7 with "emerge -DuNa world".
> 
> Thanks
>