Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 291034 - x11-libs/pango-* failes to create the proper pango.modules files
Summary: x11-libs/pango-* failes to create the proper pango.modules files
Status: RESOLVED DUPLICATE of bug 145737
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-29 16:41 UTC by Ben
Modified: 2009-10-30 00:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2009-10-29 16:41:26 UTC
On and ~amd64 multilib system pango forgets to create files for 32 bit programs like acrobat reader. Pango should create a pango.modules file for 32 bit programs in /etc/pango/i686-pc-linux-gnu as well as in /etc/pango/x86_64-pc-linux-gnu. Of course the path to the library should be changed accordingly.

If this file doesn't exist 32 bit programs try to load 64 bit libraries which of course doesn't work.

Reproducible: Always

Steps to Reproduce:
1.emerge pango
2.
3.

Actual Results:  
/etc/pango/x86_64-pc-linux-gnu/pango.modules file gets created

Expected Results:  
/etc/pango/x86_64-pc-linux-gnu/pango.modules and /etc/pango/i686-pc-linux-gnu/pango.modules file get created.
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-10-30 00:41:07 UTC
pango doesn't build the library for 32 bits apps anyway, what you want is real multilib support which does not exist yet.

*** This bug has been marked as a duplicate of bug 145737 ***