Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 290528 - Compiz does not return focus to last window
Summary: Compiz does not return focus to last window
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Desktop-Effects herd
URL: https://bugs.edge.launchpad.net/ubunt...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-26 01:04 UTC by Canek Peláez Valdés
Modified: 2010-03-14 16:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch from Ubuntu to solve the problem (compiz-0.8.4-fix-focus.patch,2.29 KB, patch)
2009-10-26 01:05 UTC, Canek Peláez Valdés
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Canek Peláez Valdés 2009-10-26 01:04:53 UTC
In Compiz 0.8.4 when you close the active window, the focus does not return to the last window that had it.

Reproducible: Always

Steps to Reproduce:
1. Open gnome-terminal
2. Launch gedit from gnome-terminal
3. Close gedit

Actual Results:  
The focus does not return to gnome-terminal.

Expected Results:  
The focus should return to gnome-terminal.

Reported in Launchpad in https://bugs.edge.launchpad.net/ubuntu/+source/compiz/+bug/455900
Comment 1 Canek Peláez Valdés 2009-10-26 01:05:58 UTC
Created attachment 208272 [details, diff]
Patch from Ubuntu to solve the problem

Patch from Ubuntu to solve the problem; I've been using it without any problems in my local overlay.
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-10-31 13:27:31 UTC
As far as I can see, no one reported this bug upstream.
Can you please report it upstream and include the link here? We prefer to follow upstream and to avoid adding local patches.
Comment 3 Romain Perier (RETIRED) gentoo-dev 2009-10-31 19:05:11 UTC
Firstly thanks for your patch and for feedbacks :)
Secondly I totally agree with Jorge, that's cool and nice to help us for patches inclusions but we always must report on upstream for bug like that.
Especially because upstream devs know compiz better than us (original devs so that's normal) :)

1. go to http://compiz-fusion.org and open a bug
2. Attach your patch on this bug
3. paste this gentoo bug as "downstream bug" (and ubuntu bug too)
4. please add us in CC list ;)  (desktop-effects@gentoo.org)
5. Add this upstream bug in URL field
6. please get back us

thanks in advance :)
Comment 4 Romain Perier (RETIRED) gentoo-dev 2009-10-31 19:07:05 UTC
Please reopen this bug when this will done
Comment 5 Dmitry Bashkatov 2010-03-14 16:17:33 UTC
I have found this bug in mainstream and send them a patch
Here it is http://bugs.opencompositing.org/show_bug.cgi?id=1271

Please fix URL.
And bug is unresolved. As it is marked RESOLVED, this is hard to find this bug. Please change this.