Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 290088 - gnome-base/gnome-applets-2.28.0: patch for stickynotes dying w/ "Quit Unexpectedly" when creating a new note
Summary: gnome-base/gnome-applets-2.28.0: patch for stickynotes dying w/ "Quit Unexpec...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.28
  Show dependency tree
 
Reported: 2009-10-22 01:08 UTC by Clemmitt M. Sigler
Modified: 2009-10-28 23:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Updated ebuild to emerge patched gnome-base/gnome-applets-2.28.0 (gnome-applets-2.28.0-r0.ebuild,3.73 KB, text/plain)
2009-10-22 01:11 UTC, Clemmitt M. Sigler
Details
Patch from Gnome git commit to fix problem with stickynotes 2.28.0 crashing (stickynotes-duplicate-labels-ui.patch,1.20 KB, patch)
2009-10-22 01:13 UTC, Clemmitt M. Sigler
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Clemmitt M. Sigler 2009-10-22 01:08:58 UTC
Under gnome-base/gnome-applets-2.28.0, the Sticky Notes applet that can be added to the Gnome Panel crashes with a "Quit Unexpectedly -- Reload/Don't Reload" error dialog box when creating a new note.  This is fixed by the patch given in this git commit:

http://git.gnome.org/cgit/gnome-applets/commit/?h=gnome-2-28&id=26488f7c397fd3e41c7c64eaf2b14b577605e97e

I took only that patch and used it to make my own ebuild of gnome-applets, which I installed.  Now Sticky Notes Works For Me :^)

I'll attach my ebuild and the patch I used.  HTH.

Clemmitt


Reproducible: Always

Steps to Reproduce:
1. Emerge gnome-base/gnome-applets-2.28.0 along with the Gnome desktop environment.
2. Add the Sticky Notes applet to the Gnome panel.
3. Right-click the Sticky Notes icon and select New Note.
4. Applet crashes with "Quit Unexpectedly -- Reload/Don't Reload" error dialog box.
Comment 1 Clemmitt M. Sigler 2009-10-22 01:11:56 UTC
Created attachment 207877 [details]
Updated ebuild to emerge patched gnome-base/gnome-applets-2.28.0

This is the updated ebuild I created to emerge my own gnome-applets-2.28.0-r0 which only adds the patch I reference in this bug report.

Clemmitt
Comment 2 Clemmitt M. Sigler 2009-10-22 01:13:29 UTC
Created attachment 207878 [details, diff]
Patch from Gnome git commit to fix problem with stickynotes 2.28.0 crashing

This is the patch I grabbed from the Gnome git repository to only patch the stickynotes crashing problem in gnome-applets-2.28.0

Clemmitt
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-10-28 23:44:55 UTC
Fixed in overlay. Thanks for reporting.