Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 289665 - app-office/openoffice-3.1.1: Copying from calc to writer causes crash.
Summary: app-office/openoffice-3.1.1: Copying from calc to writer causes crash.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Office Team
Depends on:
Reported: 2009-10-19 04:28 UTC by Damien John-Alan Sticklen
Modified: 2011-07-29 12:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Damien John-Alan Sticklen 2009-10-19 04:28:27 UTC
On arch amd64, installed from portage will crash when copying from calc to writer.

Reproducible: Always

Steps to Reproduce:
To replicate fault on AMD64 (untried on other arch) open two documents; one writer, the other calc.  Copying from calc and paste in writer.  Crashes.
Actual Results:  
A screen displays offering that the documents are being saved.  Then when openoffice is opened again, it offers recovery.

Expected Results:  
The software should have copied the table from calc and inserted it into writer.

Comment 1 Damien John-Alan Sticklen 2009-10-19 13:18:16 UTC
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe -march=nocona"
CXXFLAGS="-O2 -pipe -march=nocona"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult before changing.
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="vorbis cups ppds fbcon xcomposite opengl dri consolekit encode gtk gnome dvd alsa cdr mmx sse sse2 X acpi dbus ffmpeg cdparanoia firefox foomaticdb gif gnome-keyring gnutls gphoto2 gstreamer hal java jpeg jpeg2k lame mp3 multilib ogg pulseaudio rss svg tcl tk theora truetype usb wifi win32codecs xcomposite"
Comment 2 Damien John-Alan Sticklen 2009-10-19 22:12:40 UTC
Rebuilt package openoffice on the same system with the following command:

MAKEOPTS="-j2" emerge openoffice

No change in bug behaviour.
Comment 3 Damien John-Alan Sticklen 2009-10-20 11:11:22 UTC
Rebuilt package openoffice on the same system with the following command:

MAKEOPTS="-j1" emerge openoffice

No change in bug behaviour.
Comment 4 Damien John-Alan Sticklen 2009-10-20 21:48:51 UTC
Tried rebuilding with the following:

USE="binfilter cups dbus debug eds gnome gstreamer gtk kde ldap mono nsplugin odk opengl pam templates" emerge openoffice

no change in behaviour.
Comment 5 Damien John-Alan Sticklen 2009-10-22 13:14:57 UTC
Another, possibly related bug, is that formulas that are saved in writer do not survive the save and reopen process.
Comment 6 Niko Böckerman 2009-10-25 21:25:13 UTC
I am facing this bug too. I first noticed it with formulas not surviving the save and reopen process when saved in writer. Now I tested that the copying doesn't work either.

I am using my own ebuild to emerge openoffice but the only difference in that ebuild is MY_PV= instead of And one line change in one of the patches but that doesn't affect this bug.

This bug appears to be related to some use-flag. With no use-flags except linguas_en_GB enabled it works. Also it works with use flags "gtk java ldap". But it won't work with use flags "bash-completion cups dbus eds gnome gtk java ldap".

I am trying to find out which use flag causes the error but emerging openoffice takes half an hour so I don't have more info at the moment.

# emerge --info openoffice
Portage 2.2_rc46 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
                        System Settings
System uname: Linux-2.6.30-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 24 Oct 2009 23:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
CFLAGS="-march=core2 -O2 -pipe"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch paraller-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
LINGUAS="en en_GB"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/njw /usr/local/portage/layman/flameeyes-overlay /usr/local/portage/my_overlay"
USE="X a52 aac acl acpi alsa amd64 avahi bash-completion berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups dbus dri dts dvd dvdr eds emboss encode evo fam firefox flac fortran ftp gdbm gif gnome gpm gstreamer gtk hal htmlhandbook iconv ipv6 isdnlog jack java jpeg ldap libnotify logitech-mouse mad mikmod mmx modules mono mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nntp nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd pulseaudio python qt3support quicktime readline reflection samba sdl session smp spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd threads thunar tiff truetype unicode usb vim-syntax vorbis x264 xcomposite xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" USERLAND="GNU" VIDEO_CARDS="fglrx" 

                        Package Settings

app-office/openoffice-3.1.1 was built with the following:
USE="bash-completion cups dbus eds gnome gtk java ldap (multilib) (-aqua) -binfilter -debug -gstreamer (-kde) -mono -nsplugin -odk -opengl -pam -templates" LINGUAS="en_GB -af -ar -as_IN -be_BY -bg -bn -br -brx -bs -ca -cs -cy -da -de -dgo -dz -el -en -en_US -en_ZA -eo -es -et -eu -fa -fi -fr -ga -gl -gu -he -hi_IN -hr -hu -id -it -ja -ka -kk -km -kn_IN -ko -kok -ks -ku -lt -mai -mk -ml_IN -mn -mni -mr_IN -nb -ne -nl -nn -nr -ns -oc -or_IN -pa_IN -pl -pt -pt_BR -ru -rw -sa_IN -sat -sd (-sh) -sk -sl -sr -ss -st -sv -sw_TZ -ta -ta_IN -te_IN -tg -th -ti_ER -tn -tr -ts -uk -ur_IN -uz -ve -vi -xh -zh_CN -zh_TW -zu" 
CFLAGS="-march=core2 -pipe"
CXXFLAGS="-march=core2 -pipe"
Comment 7 AJ Spagnoletti 2009-10-26 01:56:47 UTC
I can also confirm this bug on a stable x86 machine with this version of openoffice installed:

$ eix openoffice
[I] app-office/openoffice
     Installed versions:  3.1.1(03:21:09 10/13/09)(cups dbus gnome gtk java nsplugin opengl pam)
     Description:, a full office productivity suite.
Comment 8 Niko Böckerman 2009-10-26 06:17:17 UTC
This bug occurs if openoffice is built with gnome use flag. I tested that with the ebuild from portage too. When I built it with command 'USE="-gnome" emerge openoffice' formulas in writer work fine but with gnome use flag they don't.
Comment 9 Niko Böckerman 2009-10-26 13:17:17 UTC
I tested this a bit more and found out that the configuration parameter --enable-gio causes this bug. My testing was done using default use flags for my system and -gnome and enabling one of the three gnome use flag dependent configuration options at a time. With the other to (--enable-gconf and --enable-lockdown) openoffice worked as it should and with --enable-gio this bug appeared again.
Comment 10 Damien John-Alan Sticklen 2009-10-26 22:03:39 UTC
I can confirm what Niko states about the use flags.  A workaround is not to include gnome support.  I'll leave this bug as unresolved until the maintainer finds a fix or recommends it closed.

Comment 11 Andreas Proschofsky (RETIRED) gentoo-dev 2009-11-25 09:31:17 UTC
Sorry for taking so long to respond... Anyway: I can reproduce this bug on ~x86. Could you please file a bug at

which is the correct upstream for ooo-build related issues and post the link here?
Comment 12 Andreas Proschofsky (RETIRED) gentoo-dev 2009-11-25 09:46:02 UTC
A quick alternative for the ebuild in portage would be to go back to using gnome-vfs instead of gio, though dependency (and cruft-) wise that's not something I'd prefer to pursue. 
Comment 13 Damien John-Alan Sticklen 2009-12-20 06:41:33 UTC
(In reply to comment #11)
> Sorry for taking so long to respond... Anyway: I can reproduce this bug on
> ~x86. Could you please file a bug at
> which is the correct upstream for ooo-build related issues and post the link
> here?

I will file a bug within two days at the above URL
Comment 14 Hanno Zysik (geki) 2009-12-29 18:50:15 UTC
JFYI, with OOo 3.2 RC1 it does not crash but still does not paste in writer.
Comment 15 Damien John-Alan Sticklen 2010-01-01 02:21:10 UTC
(In reply to comment #11)
> Sorry for taking so long to respond... Anyway: I can reproduce this bug on
> ~x86. Could you please file a bug at
> which is the correct upstream for ooo-build related issues and post the link
> here?

I have filed bug 567846 with Novell.

A URL is provided below:
Comment 16 Damien John-Alan Sticklen 2010-11-02 01:02:17 UTC
This bug seems to have been worked around.  I refer to the 3.2.1 ebuild:

#gio support still gives crashes, see i#108993
	echo "--disable-gio" >> ${CONFFILE}

Though checking the bug number in this comment, it seems unrelated.  However, it seems we have this one worked around without losing too much functionality.  I am suggesting we close this bug and mark it either LATER or UPSTREAM.

Comment 17 Andreas Proschofsky (RETIRED) gentoo-dev 2011-07-29 12:04:55 UTC
Should be fixed nowaday (in libreoffice), also upstream issue