Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 289570 - x11-libs/qt-assistant-4.6.0_beta1 build error: libQtCLucene not found
Summary: x11-libs/qt-assistant-4.6.0_beta1 build error: libQtCLucene not found
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Blocks: systemwide-gold
  Show dependency tree
Reported: 2009-10-18 12:06 UTC by Franz Trischberger
Modified: 2009-10-31 19:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Franz Trischberger 2009-10-18 12:06:18 UTC
It finishes with this error:

/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/../../../../x86_64-pc-linux-gnu/bin/ld: warning:, needed by /var/tmp/paludis/x11-libs-qt-assistant-4.6.0_beta1/work/qt-everywhere-opensource-src-4.6.0-beta1/lib/, not found (try using -rpath or -rpath-link) 
And many many "undefined references" concerning libQtCLucene (of course).

But libQtCLucene just can be found in ${S}/lib:
# ls /var/tmp/paludis/x11-libs-qt-assistant-4.6.0_beta1/work/qt-everywhere-opensource-src-4.6.0-beta1/lib/
libQtAssistantClient.prl  libQtCLucene.prl  libQtHelp.prl    pkgconfig

I tried with paludis and portage, both give the same error.
Here an emerge --info:
Portage 2.2_rc46 (default/linux/amd64/2008.0/desktop, gcc-4.4.1, glibc-2.9_p20081201-r2, 2.6.31-gentoo-r3 x86_64)
System uname: Linux-2.6.31-gentoo-r3-x86_64-AMD_Athlon-tm-_64_Processor_3700+-with-gentoo-2.0.1                  
Timestamp of tree: Sun, 18 Oct 2009 07:15:01 +0000                                                               
distcc 3.1 x86_64-pc-linux-gnu [disabled]                                                                        
ccache version 2.4 [enabled]                                                                                     
app-shells/bash:     4.0_p33                                                                                     
dev-java/java-config: 1.3.7-r1, 2.1.8-r1                                                                         
dev-lang/python:     2.6.3, 3.1.1-r1                                                                             
dev-python/pycrypto: 2.0.1-r8                                                                                    
dev-util/ccache:     2.4-r8                                                                                      
dev-util/cmake:      2.6.4-r3                                                                                    
sys-apps/baselayout: 2.0.1                                                                                       
sys-apps/openrc:     0.5.1-r1                                                                                    
sys-apps/sandbox:    2.1                                                                                         
sys-devel/autoconf:  2.13, 2.63-r1                                                                               
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                                             
sys-devel/binutils:  2.18-r3                                                                                     
sys-devel/gcc-config: 1.4.1                                                                                      
sys-devel/libtool:   2.2.6a                                                                                      
virtual/os-headers:  2.6.27-r2                                                                                   
CFLAGS="-march=k8 -O2 -pipe -msse3"                                                                              
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"                                                       
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                                                                                                                           
CXXFLAGS="-march=k8 -O2 -pipe -msse3"                                                                                                                                  
FEATURES="assume-digests ccache collision-protect distlocks fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox"                                                                                                                 
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/initng /usr/local/portage/layman/portato /usr/local/portage /usr/local/overlays/qt"
USE="3dnow 3dnowext X a52 aac acl acpi aiglx alsa amd64 bash-completion berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt cscope cups dbus dri dts dvb dvd dvdr dvdread emboss encode evo exceptions exif exiv2 fam fbcon ffmpeg flac flash fortran gdbm gif ginac glitz gphoto2 gpm hal iconv imagemagick ipv6 isdnlog java jpeg jpeg2k kde kdehiddenvisibility kipi lcms libnotify lm_sensors mad mikmod mmx mmxext modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin nvidia odbc ogg openal openexr opengl openmp pam pcre pdf perl png ppds pppd python qt-copy qt3 qt3support qt4 quicktime readline reflection scanner sdl session spell spl sqlite sqlite3 sse sse2 ssl ssse3 startup-notification svg sysfs tcpd tetex theora threads thunar tiff truetype unicode usb vcd vorbis x264 xcomposite xine xml xml2 xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" SANE_BACKENDS="epson" USERLAND="GNU" VIDEO_CARDS="fbdev nv nvidia"

Reproducible: Always
Comment 1 Franz Trischberger 2009-10-18 12:11:30 UTC
sry, just forgot while testing several things:
The error occurs while linking assistant-binary. libQtHelp just built (and linked) fine, with this little problem:
# ldd /var/tmp/paludis/x11-libs-qt-assistant-4.6.0_beta1/work/qt-everywhere-opensource-src-4.6.0-beta1/lib/ | grep Lucene => not found
Although can be found in the same directory.

The "undefined references" look like this:
/var/tmp/paludis/x11-libs-qt-assistant-4.6.0_beta1/work/qt-everywhere-opensource-src-4.6.0-beta1/lib/ undefined reference to `QCLuceneIndexWriter::setMergeFactor(int)'                                                                                                                                                          
/var/tmp/paludis/x11-libs-qt-assistant-4.6.0_beta1/work/qt-everywhere-opensource-src-4.6.0-beta1/lib/ undefined reference to `QCLuceneIndexReader::isLocked(QString const&)'                                                                                                                                                     
/var/tmp/paludis/x11-libs-qt-assistant-4.6.0_beta1/work/qt-everywhere-opensource-src-4.6.0-beta1/lib/ undefined reference to `QCLuceneIndexSearcher::close()'
[ and so on ]

If you need some more Infos, please ask!
Comment 2 Franz Trischberger 2009-10-18 20:20:22 UTC
Damn, solved...
This is a bug in the gold-linker in current stable binutils-2.18-r3.
I updated to ~amd64 (2.19.1-r1), and assistant built just fine...
Comment 3 cucu ionut 2009-10-31 19:03:52 UTC
I have binutils 2.20 and don't have the gold use active still assistant-4.6 beta fails with the same error, also ldd /var/tmp/paludis/x11-libs-qt-assistant-4.6.0_beta1/work/qt-everywhere-opensource-src-4.6.0-beta1/lib/|grep Lucene yealds: => not found
I am using ~amd64 arch, here is my paludis --info:
Paludis build information:                                                                                                   
        CXX:                   x86_64-pc-linux-gnu-g++ 4.4.1                                                                 
        CXXFLAGS:               -march=athlon64 -O2 -pipe -pedantic                                                          
        LDFLAGS:               -Wl,-O1                                                                                       
        DATE:                  2009-09-29T20:57:20+0300                                                                      

        C++ Library:           GNU libstdc++ 20090722

        DATADIR:               /usr/share
        LIBDIR:                /usr/lib64
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc        
        RUBYINSTALLDIR:        /usr/lib64/ruby/site_ruby/1.8/x86_64-linux

    Linux cuci 2.6.30-gentoo-r4 #2 SMP Fri Aug 14 23:27:35 EEST 2009 x86_64 AMD Athlon(tm) Dual Core Processor 4850e AuthenticAMD GNU/Linux                                                                                                               

Reduced Privs:
    reduced_uid:               1000
    reduced_uid->name:         cuci
    reduced_uid->dir:          /home/cuci
    reduced_gid:               1000      
    reduced_gid->name:         cuci      

    Format:                    paludis
    Config dir:                /etc/paludis
    World file:                /var/db/pkg/world

Repository installed-virtuals:
    format:                    installed_virtuals
    root:                      /                 

Repository virtuals:
    format:                    virtuals

Repository gentoo:
    format:                    ebuild
    location:                  /usr/portage
    append_repository_name_to_write_cache: true
    binary_destination:        false           
    builddir:                  /var/tmp/paludis
    cache:                     /usr/portage/metadata/cache
    distdir:                   /var/tmp/dist              
    eapi_when_unknown:         0                          
    eapi_when_unspecified:     0                          
    eclassdirs:                /usr/portage/eclass        
    ignore_deprecated_profiles: false                     
    layout:                    traditional                
    names_cache:               /var/cache/paludis/gentoo  
    newsdir:                   /usr/portage/metadata/news 
    profile_eapi_when_unspecified: 0                      
    profiles:                  /usr/portage/profiles/default/linux/amd64/10.0
    securitydir:               /usr/portage/metadata/glsa                    
    setsdir:                   /usr/portage/sets                             
    sync:                      rsync://       
    use_manifest:              use                                           
    write_cache:               /var/cache/paludis/metadata                   

    Package information:
        app-admin/eselect-compiler: (none)
        app-shells/bash:       4.0_p35    
        dev-java/java-config:  1.3.7-r1 2.1.9-r1
        dev-lang/python:       2.4.4-r9 2.5.4-r2 2.6.3 3.1.1-r1
        dev-python/pycrypto:   2.0.1-r8                        
        dev-util/ccache:       2.4-r8                          
        dev-util/cmake:        2.6.4-r3                        
        dev-util/confcache:    (none)                          
        sys-apps/baselayout:   2.0.1                           
        sys-apps/openrc:       0.5.2-r1                        
        sys-apps/sandbox:      2.2                             
        sys-devel/autoconf:    2.13 2.63-r1                    
        sys-devel/automake:    1.10.2 1.11 1.5 1.6.3 1.7.9-r1 1.8.5-r3 1.9.6-r2
        sys-devel/binutils:    2.20                                            
        sys-devel/gcc-config:  1.4.1                                           
        sys-devel/libtool:     2.2.6a                                          
        virtual/os-headers:    2.6.30-r1 (for sys-kernel/linux-headers::installed)

Repository installed:
    format:                    vdb
    location:                  /var/db/pkg
    builddir:                  /var/tmp/paludis
    eapi_when_unknown:         0               
    names_cache:               /var/cache/paludis/names
    provides_cache:            /var/cache/paludis/provides
    root:                      /