Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 289238 - media-video/kaffeine-1.0_pre2:4 version bump
Summary: media-video/kaffeine-1.0_pre2:4 version bump
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High enhancement (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-15 20:02 UTC by Jan Kohnert
Modified: 2009-12-01 15:28 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for kaffeine-1.0_pre2 (kaffeine-1.0_pre2.ebuild,1.32 KB, text/plain)
2009-10-21 14:51 UTC, Jan Kohnert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Kohnert 2009-10-15 20:02:45 UTC
The Kaffeine mediaplayer in portage builds against kde3. The preview release of kaffeine build now against kde4. As kde4 is now stable on amd64, we should probably add an ebuild for the new version.

See http://kaffeine.kde.org/

Reproducible: Always
Comment 1 Matteo Modesti 2009-10-16 07:52:11 UTC
I concur. It would also:
1. let people submit bugs, helping the creation of a stable app
2. let some people (like me) unmerge kdelibs 3.5, which creates problems with 4.3
Comment 2 Jan Kohnert 2009-10-21 14:51:31 UTC
Created attachment 207829 [details]
ebuild for kaffeine-1.0_pre2

This is a first version of an ebuild for the current kaffeine development version. It is tested and working on amd64 and x86, the apps are working and playing video/sound.
Comment 3 Samuli Suominen gentoo-dev 2009-10-25 12:10:16 UTC
In portage.
Comment 4 Manfred Knick 2009-11-09 16:14:33 UTC
(In reply to comment #3)


Missing DVB-T.

No consideration of 'dvb' USE flag in ebuild.

Please re-open.
Comment 5 Samuli Suominen gentoo-dev 2009-11-09 16:23:07 UTC
(In reply to comment #4)
> (In reply to comment #3)
> Missing DVB-T.
> No consideration of 'dvb' USE flag in ebuild.
> Please re-open.

There is no such configure flag. And DVB is working even without, see e.g.
http://forums.gentoo.org/viewtopic-t-799456-highlight-kaffeine.html
Comment 6 Manfred Knick 2009-11-09 16:43:42 UTC
(In reply to comment #5)

> And DVB is working even without ...

Hi,  Samuli,

FACTUM est:

-) I had a working kaffeine including DVB-T (0.8.x)
-) Somebody decided to mark this _RC_ as _STABLE_ .
-) Relying, i upgraded - not any warning message at all.
-) Now, I find no DVB-T ability at all.
-) ... searching for reasons ... solutions ... and time goes by ...

I'm not amused.
And I doubt that this policy is what Gentoo should stand for.
At least, it does not comply with the very good job of the KDE release team.

I also have the wish to get rid of the last reminiscent KDE-3 chunks ...
but not this way.

P.S.:
You hint
> ... And DVB is working even without, see e.g.
> http://forums.gentoo.org/viewtopic-t-799456-highlight-kaffeine.html
was not really helpful ;(

cite <sera>: "Very strange considering this is a Gentoo system."

Comment 7 Manfred Knick 2009-11-09 16:45:18 UTC
(In reply to comment #6)

> cite <sera>:
"I finally understand why people claim kde to be an upgrade hell.
Took me the hole course of the evening to just emerge kaffeine-1.0_pre2."

Comment 8 Samuli Suominen gentoo-dev 2009-11-09 16:50:04 UTC
Bugzilla is not a helpdesk, it's been working for everyone I've talked to either straight away or after small setupping. If you have *real bugs* to report, *with useful information*, open a new bug. Adding a "dvb" use flag which doesn't do anything, won't help your case.
Comment 9 Manfred Knick 2009-11-09 17:02:33 UTC
(In reply to comment #8)

> Bugzilla is not a helpdesk,

I did not ask for that ...

> .. it's been working for everyone I've talked to
> either straight away or after small setupping.

Fine. Now you have another report where it didn't.
And there are postings da core ...

> Adding a "dvb" use flag
> which doesn't do anything, won't help your case.

Again: I didn't aks for that.


> If you have *real bugs* to
> report, *with useful information*, open a new bug.

Breaking a stable installation IS a bug - at least in my eyes ...

#########


Sorry, but your answers totally a-miss the point imortant to me:

IFF somebody marks a RC as being _stable_ ,
then he takes over the responsibility
that the dependant user's upgrades do NOT BREAK working installations.
At the very least, the emerge should give a notable warning.

I thought that this was why we can rely on Gentoo 
for _stable_ systems as well ...

... just my 2 cents ...
Comment 10 Matteo Modesti 2009-11-10 19:00:43 UTC
Forgot to say that it works perfectly for me, even DVB-T: thank you.


(In reply to comment #9)
> IFF somebody marks a RC as being _stable_ ,
> then he takes over the responsibility
> that the dependant user's upgrades do NOT BREAK working installations.
> At the very least, the emerge should give a notable warning.

Probably 1.0_pre2 is more stable than 0.8.8. Moreover, having kdelibs 3.5 installed gave me lots of problems, maybe someone else have my same problem...

It didn't break my system, so I think you really should post another bug describing what problems you have (because you didn't say it here), because it's not an everyone's bug.
Solutions to problems are bugs reports and fixes, not keeping a package masked until all its bugs are fixed, because there will always be a bug in every package ;)

> I thought that this was why we can rely on Gentoo 
> for _stable_ systems as well ...
> 
> ... just my 2 cents ...

It's far more stable than other distros (even than Debian in my opinion), believe me ;)
Comment 11 M. R. 2009-12-01 11:13:20 UTC
(In reply to comment #8)
> Bugzilla is not a helpdesk, it's been working for everyone I've talked to
> either straight away or after small setupping. If you have *real bugs* to
> report, *with useful information*, open a new bug. Adding a "dvb" use flag
> which doesn't do anything, won't help your case.
> 

new machine installation with kde 4.3.3, dvb useflag globally set in make.conf, dvb adapter configured in kernel and working in my previous installation. Emerged kaffeine and it has no dvb flag and doesn't put ANY dvb-utils dependencies on my sistem... this is definitely a BUG, this ebuild doesn't work as expetcted and doesn't cover all program features.
Comment 12 Matteo Modesti 2009-12-01 14:31:10 UTC
(In reply to comment #11)
> new machine installation with kde 4.3.3, dvb useflag globally set in make.conf,
> dvb adapter configured in kernel and working in my previous installation.
> Emerged kaffeine and it has no dvb flag and doesn't put ANY dvb-utils
> dependencies on my sistem... this is definitely a BUG, this ebuild doesn't work
> as expetcted and doesn't cover all program features.

1. You should read previous replies before posting.
2. As already said, dvb USE flag doesn't affect the package.
3. As already said, DVB works without any flag (I'm actually using it).
4. There isn't anything called dvb-utils (and similar) in the tree. If it's a package that you need, install it yourself or open a bug report requesting to add it in the tree, DON'T ASK IT HERE.
Comment 13 M. R. 2009-12-01 15:28:29 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > new machine installation with kde 4.3.3, dvb useflag globally set in make.conf,
> > dvb adapter configured in kernel and working in my previous installation.
> > Emerged kaffeine and it has no dvb flag and doesn't put ANY dvb-utils
> > dependencies on my sistem... this is definitely a BUG, this ebuild doesn't work
> > as expetcted and doesn't cover all program features.
> 
> 1. You should read previous replies before posting.
> 2. As already said, dvb USE flag doesn't affect the package.
> 3. As already said, DVB works without any flag (I'm actually using it).
> 4. There isn't anything called dvb-utils (and similar) in the tree. If it's a
> package that you need, install it yourself or open a bug report requesting to
> add it in the tree, DON'T ASK IT HERE.
> 
 I read all replies, I know that dvb flag doesn't affect this ebuild but it should. kaffeine doesn't pull ANY dependencies about dvb and dvb doesn't work. that's the point.
 try a fresh installation and figure it out yourself, no "source" in dvb channel config pages and this is a bug related to missing dependencies in ebuild.