Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 289113 - [Perl 5.10.1] mail-filter/spamassassin-3.2.1 | 3.2.5 ACCESS VIOLATION
Summary: [Perl 5.10.1] mail-filter/spamassassin-3.2.1 | 3.2.5 ACCESS VIOLATION
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Perl team
URL: https://issues.apache.org/SpamAssassi...
Whiteboard:
Keywords:
: 230991 300699 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-14 21:21 UTC by David Abbott (RETIRED)
Modified: 2010-01-13 16:52 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge_info,4.06 KB, text/plain)
2009-10-14 21:22 UTC, David Abbott (RETIRED)
Details
sandbox.patch (sandbox.patch,635 bytes, patch)
2009-10-14 21:23 UTC, David Abbott (RETIRED)
Details | Diff
build.log (build.log,46.59 KB, text/plain)
2009-10-14 21:23 UTC, David Abbott (RETIRED)
Details
eclass-debug (eclass-debug.log,2.31 KB, text/plain)
2009-10-14 21:24 UTC, David Abbott (RETIRED)
Details
sandbox.log (sandbox-26236.log,555 bytes, text/plain)
2009-10-14 21:24 UTC, David Abbott (RETIRED)
Details
environment (environment,105.00 KB, text/plain)
2009-10-14 21:25 UTC, David Abbott (RETIRED)
Details
OA-errors (QA-notice,7.05 KB, text/plain)
2009-10-14 21:35 UTC, David Abbott (RETIRED)
Details
Fixes the problem for me (spamassassin-3.2.5-DESTDIR.patch,8.65 KB, patch)
2009-10-21 21:42 UTC, Peter Alfredsen (RETIRED)
Details | Diff
ebuild.patch (spamassassin-3.2.5.ebuild.patch,742 bytes, patch)
2009-10-21 22:47 UTC, David Abbott (RETIRED)
Details | Diff
ebuild.patch (spamassassin-3.2.5.ebuild.patch,744 bytes, patch)
2009-10-21 23:00 UTC, David Abbott (RETIRED)
Details | Diff
ebuild.patch (spamassassin-3.2.5.ebuild.patch,746 bytes, patch)
2009-10-21 23:03 UTC, David Abbott (RETIRED)
Details | Diff
spamassassin-3.2.5.ebuild.patch (spamassassin-3.2.5.ebuild.patch,712 bytes, patch)
2009-10-21 23:41 UTC, David Abbott (RETIRED)
Details | Diff
updated ebuild with correct doc files (spamassassin-3.2.5-r1.ebuild,7.74 KB, text/plain)
2009-10-25 16:27 UTC, David Abbott (RETIRED)
Details
removed src_prepare tested on 5.8.8 and 5.10.1 (spamassassin-3.2.5-r1.ebuild,7.74 KB, text/plain)
2009-10-25 16:31 UTC, David Abbott (RETIRED)
Details
spamassassin-3.2.5-r1.ebuild (spamassassin-3.2.5-r1.ebuild,7.74 KB, text/plain)
2009-10-25 16:55 UTC, David Abbott (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Abbott (RETIRED) gentoo-dev 2009-10-14 21:21:56 UTC
This bug has been around for awhile and I think it is still present in 5.8.8. It would be nice to get it fixed for the move to 5.10.1. I created a patch from information gathered from other bug reports and it does get past the sandbox violation but then generates a bunch of QA notices. I can not test if it really works as expected but it does install fine.

Reproducible: Always
Comment 1 David Abbott (RETIRED) gentoo-dev 2009-10-14 21:22:52 UTC
Created attachment 207146 [details]
emerge --info
Comment 2 David Abbott (RETIRED) gentoo-dev 2009-10-14 21:23:25 UTC
Created attachment 207148 [details, diff]
sandbox.patch
Comment 3 David Abbott (RETIRED) gentoo-dev 2009-10-14 21:23:45 UTC
Created attachment 207149 [details]
build.log
Comment 4 David Abbott (RETIRED) gentoo-dev 2009-10-14 21:24:13 UTC
Created attachment 207150 [details]
eclass-debug
Comment 5 David Abbott (RETIRED) gentoo-dev 2009-10-14 21:24:44 UTC
Created attachment 207152 [details]
sandbox.log
Comment 6 David Abbott (RETIRED) gentoo-dev 2009-10-14 21:25:11 UTC
Created attachment 207154 [details]
environment
Comment 7 David Abbott (RETIRED) gentoo-dev 2009-10-14 21:35:41 UTC
Created attachment 207157 [details]
OA-errors
Comment 8 Peter Alfredsen (RETIRED) gentoo-dev 2009-10-21 21:42:12 UTC
Created attachment 207861 [details, diff]
Fixes the problem for me

Backport of upstream revisions 789978 and 801099. Works for me. Please confirm if it works for you.
Comment 9 Peter Alfredsen (RETIRED) gentoo-dev 2009-10-21 21:45:30 UTC
*** Bug 230991 has been marked as a duplicate of this bug. ***
Comment 10 Peter Alfredsen (RETIRED) gentoo-dev 2009-10-21 21:48:56 UTC
Comment on attachment 207148 [details, diff]
sandbox.patch

The reason dabbot's patch isn't correct is that in some cases it will work (for those who encounter this bug), but in all other cases, it will install into ${D}/usr/share/spamassassin and ${D}/etc INSIDE $D. This is a bug with how spamassassin (ab)uses makemaker.
Comment 11 David Abbott (RETIRED) gentoo-dev 2009-10-21 22:47:48 UTC
Created attachment 207863 [details, diff]
ebuild.patch

Peter very nice, works fine here. I renamed the patch 3.2.5-DESTDIR.patch
Comment 12 David Abbott (RETIRED) gentoo-dev 2009-10-21 23:00:10 UTC
Created attachment 207865 [details, diff]
ebuild.patch

Forgot the ""
Comment 13 David Abbott (RETIRED) gentoo-dev 2009-10-21 23:03:54 UTC
Created attachment 207866 [details, diff]
ebuild.patch
Comment 14 Peter Alfredsen (RETIRED) gentoo-dev 2009-10-21 23:20:25 UTC
Just add:
PATCHES=( "${FILESDIR}/${PN}-3.2.5-DESTDIR.patch" )
Just before src_compile. That should take care of it.
(perl-modules uses autopatch from base.eclass)
Comment 15 David Abbott (RETIRED) gentoo-dev 2009-10-21 23:41:53 UTC
Created attachment 207869 [details, diff]
spamassassin-3.2.5.ebuild.patch

Thank you Peter for taking the time to teach :) Used your patch as is, I did not rename it this time.
Comment 16 David Abbott (RETIRED) gentoo-dev 2009-10-25 16:27:28 UTC
Created attachment 208215 [details]
updated ebuild with correct doc files
Comment 17 David Abbott (RETIRED) gentoo-dev 2009-10-25 16:31:13 UTC
Created attachment 208217 [details]
removed src_prepare tested on 5.8.8 and 5.10.1
Comment 18 David Abbott (RETIRED) gentoo-dev 2009-10-25 16:55:34 UTC
Created attachment 208218 [details]
spamassassin-3.2.5-r1.ebuild

removed the quotes from EAPI
Comment 19 Peter Alfredsen (RETIRED) gentoo-dev 2009-10-27 07:22:31 UTC
+*spamassassin-3.2.5-r1 (27 Oct 2009)
+
+  27 Oct 2009; Peter Alfredsen <loki_val@gentoo.org>
+  +spamassassin-3.2.5-r1.ebuild, +files/spamassassin-3.2.5-DESTDIR.patch:
+  Fix bug 289113. Thanks to David Abbott for ebuild fixups.
+
Comment 20 Torsten Veller (RETIRED) gentoo-dev 2010-01-13 16:52:57 UTC
*** Bug 300699 has been marked as a duplicate of this bug. ***