Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288945 - ~kde-base/printer-applet-4.3.2 crash: printer-applet-kde refuses to start
Summary: ~kde-base/printer-applet-4.3.2 crash: printer-applet-kde refuses to start
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-13 20:39 UTC by Rahul Jain
Modified: 2012-01-27 10:29 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rahul Jain 2009-10-13 20:39:35 UTC
rahul@googly ~ $ printer-applet-kde
KCrash: Application 'printer-applet-kde' crashing...
sock_file=/home/rahul/.kde4/socket-googly/kdeinit4__0

[1]+  Stopped                 printer-applet-kde



Reproducible: Always




rahul@googly ~ $ emerge --info                     
Portage 2.2_rc46 (default/linux/x86/10.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.31-zen2-02791-g5692ded i686)
=================================================================                                             
System uname: Linux-2.6.31-zen2-02791-g5692ded-i686-Genuine_Intel-R-_CPU_T2300_@_1.66GHz-with-gentoo-2.0.1    
Timestamp of tree: Tue, 13 Oct 2009 19:45:01 +0000                                                            
app-shells/bash:     4.0_p33                                                                                  
dev-java/java-config: 2.1.9-r1                                                                                
dev-lang/python:     2.6.3                                                                                    
dev-util/cmake:      2.6.4-r3                                                                                 
sys-apps/baselayout: 2.0.1                                                                                    
sys-apps/openrc:     0.5.1                                                                                    
sys-apps/sandbox:    2.1                                                                                      
sys-devel/autoconf:  2.13, 2.63-r1                                                                            
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                                                         
sys-devel/binutils:  2.19.1-r1                                                                                
sys-devel/gcc-config: 1.4.1                                                                                   
sys-devel/libtool:   2.2.6a                                                                                   
virtual/os-headers:  2.6.30-r1                                                                                
ACCEPT_KEYWORDS="x86 ~x86"                                                                                    
CBUILD="i686-pc-linux-gnu"                                                                                    
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"                                                         
CHOST="i686-pc-linux-gnu"                                                                                     
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"                                    
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                                                          
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"                                                           
DISTDIR="/usr/portage/distfiles"                                                                                  
FEATURES="assume-digests distlocks fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"                                                     
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/"                                                       
LANG="en_GB.utf8@euro"                                                                                            
LDFLAGS="-Wl,-O1"                                                                                                 
LINGUAS="en en_GB"                                                                                                
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-testing /usr/local/portage/layman/qting-edge /usr/local/portage/layman/x11 /usr/local/portage/layman/bugzilla"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa avahi bash-completion berkdb bluetooth branding bzip2 cairo cdparanoia cdr cli consolekit cracklib crypt css ctype cups curl curlwrappers cxx dbus dga directfb djvu dri dts dvd dvdr emboss encode evo exif fam fbcon ffmpeg firefox flac fontconfig fortran gd gdbm gif gimp gnutls gphoto2 gpm hal hddtemp htmlhandbook iconv ieee1394 imagemagick ipv6 isdnlog java java6 javascript joystick jpeg jpeg2k kde lcms ldap libnotify mad mikmod mmx modules mono motif mp3 mp4 mpeg mplayer mtp mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcmcia pcre pdf perl plasma png posix ppds pppd python qt3support qt4 quicktime readline reflection samba scanner sdl session smp sndfile spell spl sse sse2 ssl startup-notification svg svga sysfs syslog tcpd theora threads thunar tiff truetype type1 unicode usb v4l2 vcd vim-syntax vorbis wavpack win32codecs wmf x264 x86 xcomposite xine xinerama xml xorg xpm xulrunner xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" USERLAND="GNU" VIDEO_CARDS="intel fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Maciej Mrozowski gentoo-dev 2009-10-14 10:02:44 UTC
Please try to get some valuable backtrace.
printer-applet is a python application, so it should be possible to get full backtrace.
Oh, I cannot reproduce it and I'm using 4.3.9999 (same code in printer-applet as in 4.3.2).
Comment 2 Rahul Jain 2009-10-14 11:35:13 UTC
OK, I tried to get a trace using python-ptrace (gdb does not recognize printer-applet-kde as an executable) and here is what I get. Please tell me if there is any other way / better way of doing this.

rahul@googly ~ $ strace.py -v /usr/bin/printer-applet-kde           
execve(/usr/bin/printer-applet-kde, ['/usr/bin/printer-applet-kde'], [/* 40 vars */]) = 11068
Attach <PtraceProcess #11068> to debugger                                                    
Set <PtraceProcess #11068> options to 1                                                      
brk(NULL)                                = 0x08cc1000                                        
access('/etc/ld.so.preload', <R_OK> (4)) = -2 (No such file or directory)                    
open('/etc/ld.so.cache', O_RDONLY)       = 3                                                 
fstat64(3, 0xbff30808)                   = 0                                                 
mmap2(NULL, 130722, <PROT_READ> (1), 2, 3, 0) = 0xb789f000                                   
close(3)                                 = 0                                                 
open('/lib/libc.so.6', O_RDONLY)         = 3                                                 
read(3, 0xbff30924, 512)                 = 512 (0x00000200)                                  
fstat64(3, 0xbff3084c)                   = 0                                                 
mmap2(NULL, 4096, <PROT_READ|PROT_WRITE> (3), 34, -1, 0) = 0xb789e000                        
mmap2(NULL, 1325352, <PROT_READ|PROT_EXEC> (5), 2050, 3, 0) = 0xb775a000                     
mmap2(0xb7898000, 12288, <PROT_READ|PROT_WRITE> (3), 2066, 3, 318) = 0xb7898000              
mmap2(0xb789b000, 10536, <PROT_READ|PROT_WRITE> (3), 50, -1, 0) = 0xb789b000                 
close(3)                                 = 0                                                 
mmap2(NULL, 4096, <PROT_READ|PROT_WRITE> (3), 34, -1, 0) = 0xb7759000                        
set_thread_area(<user_desc entry_number=6L, base_addr=3077936832L, limit=1048575L, _bits_='Q'>) = 0
mprotect(0xb7898000, 8192, 1)            = 0                                                       
mprotect(0x0804d000, 4096, 1)            = 0
mprotect(0xb78dc000, 4096, 1)            = 0
munmap(0xb789f000, 130722)               = 0
brk(NULL)                                = 0x08cc1000
brk(0x08ce2000)                          = 0x08ce2000
open('/usr/lib/locale/locale-archive', <O_LARGEFILE> (0100000)) = 3
fstat64(3, 0xb789aae0)                   = 0
mmap2(NULL, 2097152, <PROT_READ> (1), 2, 3, 0) = 0xb7559000
mmap2(NULL, 4096, <PROT_READ> (1), 2, 3, 569) = 0xb78be000
close(3)                                 = 0
Debugger error: [ProcessSignal] Signal signal<133>
Traceback (most recent call last):
  File "/usr/bin/strace.py", line 248, in _main
    self.runDebugger()
  File "/usr/bin/strace.py", line 236, in runDebugger
    self.syscallTrace(process)
  File "/usr/bin/strace.py", line 182, in syscallTrace
    self.syscall(process)
  File "/usr/bin/strace.py", line 186, in syscall
    syscall = state.event(self.syscall_options)
  File "/usr/lib/python2.6/site-packages/ptrace/debugger/syscall_state.py", line 13, in event
    return self.exit()
  File "/usr/lib/python2.6/site-packages/ptrace/debugger/syscall_state.py", line 38, in exit
    self.process.waitSignals(SIGTRAP)
  File "/usr/lib/python2.6/site-packages/ptrace/debugger/process.py", line 712, in waitSignals
    return self.debugger.waitSignals(*signals, **{'pid': self.pid})
  File "/usr/lib/python2.6/site-packages/ptrace/debugger/debugger.py", line 176, in waitSignals
    raise event
ProcessSignal: Signal signal<133>
Quit debugger
Terminate <PtraceProcess #11068>
Comment 3 Rahul Jain 2009-10-14 11:39:48 UTC
Maybe this is what you were looking for:

rahul@googly ~ $ python -m trace --count /usr/bin/printer-applet-kde
Traceback (most recent call last):
  File "/usr/lib/python2.6/runpy.py", line 122, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.6/runpy.py", line 34, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.6/trace.py", line 813, in <module>
    main()
  File "/usr/lib/python2.6/trace.py", line 801, in main
    t.run('execfile(%r)' % (progname,))
  File "/usr/lib/python2.6/trace.py", line 498, in run
    exec cmd in dict, dict
  File "<string>", line 1, in <module>
  File "/usr/bin/printer-applet-kde", line 66, in <module>
    from statereason import StateReason
ImportError: No module named statereason
Comment 4 Maciej Mrozowski gentoo-dev 2009-10-14 12:49:45 UTC
Does your printer-applet package install statereason.py?
Do you have system-config-printer-common installed?
Please wait a bit for system-config-printer-common1.1.13 to be added to tree, it may fix your issue.
Comment 5 Rahul Jain 2009-10-14 13:51:39 UTC
(In reply to comment #4)
> Does your printer-applet package install statereason.py?

googly rahul # find / -iname "statereason.py"
/usr/share/system-config-printer/statereason.py
/usr/share/apps/printer-applet/statereason.py

> Do you have system-config-printer-common installed?

googly rahul # eix system-config-printer-common
[I] app-admin/system-config-printer-common
     Available versions:  (~)1.1.8 (~)1.1.12 (~)1.1.13[1] {doc}
     Installed versions:  1.1.13[1](09:11:00 09/24/09)(-doc)
     Homepage:            http://cyberelk.net/tim/software/system-config-printer/
     Description:         Common modules of Red Hat's printer administration tool

[1] "kde" /usr/local/portage/layman/kde-testing

> Please wait a bit for system-config-printer-common1.1.13 to be added to tree,
> it may fix your issue.
> 
Well, I already have it installed (kde-testing overlay). Maybe the inclusion in portage fixes it .... how I don't know (unless there is an update I am not aware of).
Comment 6 Rahul Jain 2009-10-15 09:51:09 UTC
I reinstalled the following packages:

app-admin/system-config-printer-common-1.1.13
kde-base/system-config-printer-kde-4.3.2
kde-base/printer-applet-4.3.2

It did not solve my problem.
Comment 7 Maciej Mrozowski gentoo-dev 2009-10-15 13:32:04 UTC
Well, I'm running out of ideas, your sip and PyQt4 version?

your could try to run emerge -vaDu world to ensure system is in consistent state.
Also, have you been upgrading python recently? (and/or for instance switched to python3)
Comment 8 Rahul Jain 2009-10-16 12:29:09 UTC
dev-python/sip-4.9
dev-python/PyQt-4.6

Both from the qting-edge overlay. This could be the problem.
Comment 9 Libor Bukata 2009-11-07 14:40:11 UTC
(In reply to comment #8)
> dev-python/sip-4.9
> dev-python/PyQt-4.6
> 
> Both from the qting-edge overlay. This could be the problem.
> 
I have the same error. Next command solved it.

Try that:
printer-applet-kde --show
Comment 10 Francisco Ares 2009-11-28 13:00:21 UTC
perhaps this bug is a reflex in a bug somewhere else

$ printer-applet-kde --show
ASSERT failure in QDBusConnection::registerObject: "Invalid object path given", file qdbusconnection.cpp, line 706
KCrash: Application 'printer-applet-kde' crashing...
Comment 11 Andreas K. Hüttel gentoo-dev 2010-07-07 18:55:03 UTC
Is this still a problem with more recent versions (kde, pyqt, sip, ...)?
Comment 12 NickNill 2010-08-06 13:55:44 UTC
This problem is resolved in recent versions. Please, close bug
Comment 13 NickNill 2010-08-06 13:58:41 UTC
I'm sorry, there is no problem for kde 4.4, but i don't know what about 4.3
Comment 14 Andreas K. Hüttel gentoo-dev 2010-11-12 23:23:22 UTC
Well 4.3 is gone now...
Comment 15 gstier 2012-01-27 10:29:08 UTC
printer-applet crashed too. KDE 4.7.4

denise@LAPdenise ~ $ printer-applet-kde
KCrash: Application 'printer-applet-kde' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/denise/.kde4/socket-LAPdenise/kdeinit4__0


Any ideas?