Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 288895 - dev-db/postgresql-{base,server}-7.4.26 USE=kerberos - configure: error: header file <com_err.h> is required for Kerberos 5
Summary: dev-db/postgresql-{base,server}-7.4.26 USE=kerberos - configure: error: heade...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: PgSQL Bugs
URL:
Whiteboard:
Keywords:
Depends on: 234957
Blocks: 285475
  Show dependency tree
 
Reported: 2009-10-13 16:23 UTC by Jeroen Roovers
Modified: 2009-10-22 19:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Use <et/com_err.h> (postgresql-7.4-com_err.patch,1.44 KB, patch)
2009-10-13 16:28 UTC, Jeroen Roovers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2009-10-13 16:23:54 UTC
Should be <et/com_err.h>

Patch to be attached shortly. I had one for configure.in, but it only checked and didn't set the proper values where they were being used, so I'm working on that now.
Comment 1 Jeroen Roovers gentoo-dev 2009-10-13 16:28:11 UTC
Created attachment 206980 [details, diff]
Use <et/com_err.h>

A pkgconfig patch to configure.in would have been nicer.
Comment 2 Jeroen Roovers gentoo-dev 2009-10-14 00:24:55 UTC
The same bug and patch apply to postgresql-server.
Comment 3 Patrick Lauer gentoo-dev 2009-10-22 19:19:59 UTC
Committed, thanks for the patch