Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288785 - dev-python/PyQt4-4.5.4-r4 failed to build
Summary: dev-python/PyQt4-4.5.4-r4 failed to build
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Python Gentoo Team
Depends on:
Reported: 2009-10-12 23:51 UTC by Yann Forget
Modified: 2009-11-20 15:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build environment (environment,146.27 KB, text/plain)
2009-10-15 01:15 UTC, Yann Forget

Note You need to log in before you can comment on or make changes to this bug.
Description Yann Forget 2009-10-12 23:51:31 UTC
dev-python/PyQt4-4.5.4-r4 failed to build with the following error:

rm: cannot remove directory `pyuic/uic/port_v3': Directory not empty
 * ERROR: dev-python/PyQt4-4.5.4-r4 failed.
 * Call stack:
 *     , line   49:  Called src_prepare
 *             environment, line 3658:  Called python_execute_function '-s' 'preparation'
 *             environment, line 3070:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *  The die message:
 *   Preparation failed with Python 2.6 in preparation() function
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-python/PyQt4-4.5.4-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/PyQt4-4.5.4-r4/temp/environment'.

The parameters are:
USE="X dbus kde opengl sql svg webkit -assistant -debug -doc -examples -phonon -xmlpatterns"

Reproducible: Always

Steps to Reproduce:
1. emerge dev-python/PyQt4 or any KDE package
Comment 1 Yann Forget 2009-10-12 23:52:26 UTC
hal:~#  emerge --info
Portage (default/linux/amd64/10.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
System uname: Linux-2.6.30-gentoo-r5-x86_64-with-gentoo-
Timestamp of tree: Mon, 12 Oct 2009 10:15:02 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
CFLAGS="-march=k8 -pipe -O2"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -pipe -O2"
FEATURES="autoclean distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="fr hi gu en gu_IN hi_IN"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/zugaina /usr/portage/local/layman/sunrise /usr/portage/local/layman/kde3 /usr/portage/local/layman/kde"
USE="7zip X a52 aac acl alsa amd64 arts avi bash-completion berkdb bittorrent bzip2 cdr cjk cli cracklib crypt css cups dbus djvu dri dv dvb dvd dvdr dvdread enca encode exif fbcon ffmpeg foomaticdb fortran ftp gdbm gif gimp gimpprint gphoto2 gpm hal iconv imlib innodb java jpeg kde kdeenablefinal logrotate maildir mbox mime mng modules mozilla mozsvg mp3 mpeg mplayer mudflap multilib mysql ncurses network nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png posix postfix pppd print python qt qt3support qt4 quicktime readline realmedia recode reflection replytolist rtc rtsp scanner sdl serial session smp spl sse sse2 ssl stream svg sysfs tcpd tetex theora threads tiff transcode truetype unicode usb userlocales v4l v4l2 vcd vdr vim-syntax vorbis wma xine xml xorg xpm xprint xvid xvmc zlib" ALSA_CARDS="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr hi gu en gu_IN hi_IN" USERLAND="GNU" VIDEO_CARDS="ati vesa fbdev mach64"
Comment 2 Davide Pesavento gentoo-dev 2009-10-14 08:51:10 UTC
Makes no sense. The ebuild runs 'rm -fr pyuic/uic/port_v3', so it shouldn't choke on non-empty dirs...
Comment 3 Davide Pesavento gentoo-dev 2009-10-14 17:39:12 UTC
Please attach the env file located at '/var/tmp/portage/dev-python/PyQt4-4.5.4-r4/temp/environment'
Comment 4 Yann Forget 2009-10-15 01:15:32 UTC
Created attachment 207176 [details]
build environment
Comment 5 Davide Pesavento gentoo-dev 2009-10-15 21:12:44 UTC
Could you run something like
ls -lR /var/tmp/portage/dev-python/PyQt4-4.5.4-r4/work/PyQt-x11-gpl-4.5.4-2.6/pyuic/uic/port_v3
just after the failure occurs and show us the output?
Comment 6 Yann Forget 2009-10-15 21:26:52 UTC
ls -lR /var/tmp/portage/dev-python/PyQt4-4.5.4-r4/work/PyQt-x11-gpl-4.5.4-2.6/pyuic/uic/port_v3:
total 24
-rw-r--r-- 2 root root 316 2009-07-27 20:09
-rw-r--r-- 2 root root 106 2009-07-27 20:09
-rw-r--r-- 2 root root   0 2009-07-27 20:09
-rw-r--r-- 2 root root 541 2009-07-27 20:09
-rw-r--r-- 2 root root 523 2009-07-27 20:09
-rw-r--r-- 2 root root 101 2009-07-27 20:09
-rw-r--r-- 2 root root  54 2009-07-27 20:09

Is this OK? I think it is quite strange to have such restrictive permissions.
ls -ld
drwx------ 4  250 250 4096 2009-10-13 01:34 work
Comment 7 Davide Pesavento gentoo-dev 2009-10-15 22:33:37 UTC
Why /var/tmp/portage/dev-python/PyQt4-4.5.4-r4/work is owned by uid/gid 250?
Comment 8 Yann Forget 2009-10-16 08:59:19 UTC
(In reply to comment #7)
> Why /var/tmp/portage/dev-python/PyQt4-4.5.4-r4/work is owned by uid/gid 250?

In fact it is 
drwx------ 4 portage portage 4096 Oct 13 01:34 work

250 is portage:

This is seen from outside Gentoo.
Comment 9 Davide Pesavento gentoo-dev 2009-10-16 09:51:42 UTC
Ah ok... what happens if you manually rm -rf pyuic/uic/port_v3 as root after the failure? Does it fail in the same way?
Comment 10 Yann Forget 2009-10-16 21:06:36 UTC
(In reply to comment #9)
> Ah ok... what happens if you manually rm -rf pyuic/uic/port_v3 as root after
> the failure? Does it fail in the same way?

The file is created by the e-build.
Comment 11 Davide Pesavento gentoo-dev 2009-10-17 10:09:55 UTC
(In reply to comment #10)
> The file is created by the e-build.

What do you mean?

Since I can't reproduce, I asked you to emerge PyQt4, let it fail and then try to manually rm -rf pyuic/uic/port_v3 as root to see what happens.
Comment 12 Davide Pesavento gentoo-dev 2009-10-22 21:31:18 UTC
Please provide the requested info or I won't be able to debug the issue. Seems you're the only one experiencing it, and moreover it looks rather weird!
Comment 13 Yann Forget 2009-10-23 18:11:58 UTC
This repertory is created during the build. I obviously tried to remove it manually, but it is recreated each time.
Comment 14 Davide Pesavento gentoo-dev 2009-10-23 19:41:13 UTC
You misunderstood me, I didn't intend to suggest a workaround. I just wanted to know if rm fails to remove those files even when called outside of the ebuild function.
Comment 15 Luciano Bueno 2009-11-05 01:34:04 UTC
I had the same problem while updating my gentoo install into a chroot'ed enviroment (I wanted to upgrade to kde 4.3, so i needed to clean up my kde 4.2 install while having my PC functioning properly for everyday use, so I made a copy of my install into a dir and chroot'ed into it)

After finding this bug and no resolution i ran python-updater (also made sure the /dev and /proc were mounted, can't remember if they were when the problem was trigered) and now my problem got fixed

Hope it helps

Comment 16 Davide Pesavento gentoo-dev 2009-11-08 20:56:52 UTC
Yann, could you try running python-updater and see if it solves your problem?