Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288689 - [FEATURES=test failure] gnome-base/libbonobo-2.24.3 fails tests with FEATURES="userpriv"
Summary: [FEATURES=test failure] gnome-base/libbonobo-2.24.3 fails tests with FEATURES...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
: 312413 (view as bug list)
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-10-12 08:01 UTC by Hans de Graaff
Modified: 2010-09-25 14:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info.txt,12.17 KB, text/plain)
2010-03-14 11:42 UTC, Hans de Graaff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans de Graaff gentoo-dev 2009-10-12 08:01:42 UTC
make  check-TESTS
make[4]: Entering directory `/var/tmp/portage/gnome-base/libbonobo-2.24.2/work/libbonobo-2.24.2/tests/test-activation'

** (process:24295): WARNING **: Owner of /tmp/orbit-graaff is not the current user

PASSED 1 of 17: Activation event source okay
Time to query '0.000401272'
PASSED 2 of 17: timed query
Waiting to see if the server erroneously quits
** Message: Activation callback successfully called on register

** (process:24295): WARNING **: Async activation error activating 'IDL:Empty:1.0' : 'System exception: IDL:Bonobo/GeneralError:1.0 : Child process did not give an error message, unknown failure occurred'
FAILED 3 of 17: async activation
Test by async query succeeded
PASSED 4 of 17: async activation
** Message: Activation callback successfully called on register
Test from id succeeded
PASSED 5 of 17: IID activation
Test from aid succeeded
PASSED 6 of 17: AID activation
Test from aid succeeded
PASSED 7 of 17: plugin activation
PASSED 8 of 17: Broken link test : Couldn't find the factory server
PASSED 9 of 17: activation server okay
Broken exe test PASSED 10 of 17: Broken exe test : Couldn't spawn a new process:Failed to execute child process "this-executable-doesnt-exist" (No such file or directory)
PASSED 11 of 17: activation server okay
PASSED 12 of 17: Circular link test : Location loop
PASSED 13 of 17: activation server okay
PASSED 14 of 17: Server that doesn't register IID test : Child process did not give an error message, unknown failure occurred
PASSED 15 of 17: activation server okay
PASSED 16 of 17: Server with IID but no type or location
PASSED 17 of 17: activation server okay

16 of 17 tests passed (some failures)
Comment 1 Hans de Graaff gentoo-dev 2009-10-12 08:02:21 UTC
Adding 'unset ORBIT_SOCKETDIR' as we discussed in bug 246136 fixed this problem for me. All tests run and PASS.
Comment 2 Pacho Ramos gentoo-dev 2010-03-12 12:08:21 UTC
On the other hand I don't suffer this problem at all :-/
Comment 3 Hans de Graaff gentoo-dev 2010-03-14 11:42:35 UTC
Created attachment 223513 [details]
emerge --info

I also have FEATURES="userpriv" which I think is causing this problem. emerge --info attached in case it depends on something else instead.
Comment 4 Pacho Ramos gentoo-dev 2010-03-14 12:36:18 UTC
FEATURES="${FEATURES} userpriv usersandbox" emerge -1 libbonobo

and tests still succeeds  for me, then, the problem must be in another place :-/
Comment 5 Pacho Ramos gentoo-dev 2010-03-14 13:13:10 UTC
Reproduced (silly me!, I had gconf running)

The problem is that I have failed to make tests pass even unsetting as much variables as nautilus is currently doing, then, more investigation will be needed :-(
Comment 6 Pacho Ramos gentoo-dev 2010-03-19 17:33:27 UTC
Can you try to "unset XAUTHORITY"? (I would try it myself but, today, I am unable to reproduce again :-@)

Thanks
Comment 7 Hans de Graaff gentoo-dev 2010-03-27 07:50:06 UTC
(In reply to comment #6)
> Can you try to "unset XAUTHORITY"? (I would try it myself but, today, I am
> unable to reproduce again :-@)

Tried today but this does not make a difference.

However, I also tried to unset ORBIT_SOCKETDIR, and that does the trick:

src_test() {
	unset ORBIT_SOCKETDIR
	emake check || die
}
Comment 8 Pacho Ramos gentoo-dev 2010-03-27 09:41:19 UTC
+  27 Mar 2010; Pacho Ramos <pacho@gentoo.org> libbonobo-2.24.2.ebuild:
+  Let tests pass with FEATURES=userpriv unsetting ORBIT_SOCKETDIR, thanks to
+  Hans de Graaff in bug 288689 for finding the solution.
+
Comment 9 Pacho Ramos gentoo-dev 2010-03-30 12:14:55 UTC
I have reverted this in 2.24.3 as explained in changelog:
+*libbonobo-2.24.3 (30 Mar 2010)
+
+  30 Mar 2010; Pacho Ramos <pacho@gentoo.org> +libbonobo-2.24.3.ebuild:
+  Version bump fixing some bugs: Set up dbus environment in
+  test-activation/test.sh (due to this, ebuild no longer unsets
+  ORBIT_SOCKETDIR, feel free to comment in bug #288689 if the problem
+  reappears), fix memory corruption, updated translations.


Then, please check if this is still needed with 2.24.3 and, if required, feel free to reopen this and I will re-revert it ;-)

Thanks
Comment 10 Hans de Graaff gentoo-dev 2010-04-02 14:12:30 UTC
(In reply to comment #9)

> Then, please check if this is still needed with 2.24.3 and, if required, feel
> free to reopen this and I will re-revert it ;-)

2.24.3 fails in the same way as the initial failure for me:

make  check-TESTS
make[4]: Entering directory `/var/tmp/portage/gnome-base/libbonobo-2.24.3/work/libbonobo-2.24.3/tests/test-activation'
No protocol specified

** (process:12694): WARNING **: Owner of /tmp/orbit-graaff is not the current user

PASSED 1 of 17: Activation event source okay
Time to query '0.000625352'
PASSED 2 of 17: timed query
Waiting to see if the server erroneously quits
** Message: Activation callback successfully called on register

** (process:12694): WARNING **: Async activation error activating 'IDL:Empty:1.0' : 'System exception: IDL:Bonobo/GeneralError:1.0 : Child process did not give an error message, unknown failure occurred'
FAILED 3 of 17: async activation
Test by async query succeeded
PASSED 4 of 17: async activation
Comment 11 Pacho Ramos gentoo-dev 2010-04-05 19:03:26 UTC
*** Bug 312413 has been marked as a duplicate of this bug. ***
Comment 12 Pacho Ramos gentoo-dev 2010-04-05 19:07:55 UTC
I have added the "unset stuff" again to 2.24.3

Thanks a lot for testing
Comment 13 Hans de Graaff gentoo-dev 2010-04-12 19:16:52 UTC
(In reply to comment #12)
> I have added the "unset stuff" again to 2.24.3

I still get the same failure as in comment #10.
Comment 14 Pacho Ramos gentoo-dev 2010-04-12 20:10:59 UTC
:-S, looks like a different problem then, can you verify it's a regression over 2.24.2? (both versions in the tree should be running exactly the same test phase)
Comment 15 Hans de Graaff gentoo-dev 2010-04-13 07:05:03 UTC
(In reply to comment #14)
> :-S, looks like a different problem then, can you verify it's a regression over
> 2.24.2? (both versions in the tree should be running exactly the same test
> phase)

It's not a regression, since I originally reported this exact problem for 2.24.2 :-) (see top of this bug). But it's been a fun ride to get to this point again.

I'm wondering how much effort we should still put into this, given that libbonobo is on its way out the door for Gnome.
Comment 16 Pacho Ramos gentoo-dev 2010-08-24 12:11:43 UTC
I am still a bit surprised about how "randomly" it fails for me while you seem to reproduce it always :-/

Have you tried to change DEBUG_TIMEOUT values at tests/test-activation/bonobo-activation-test-async.c ?
Comment 17 Hans de Graaff gentoo-dev 2010-08-29 18:40:55 UTC
(In reply to comment #16)
> I am still a bit surprised about how "randomly" it fails for me while you seem
> to reproduce it always :-/
> 
> Have you tried to change DEBUG_TIMEOUT values at
> tests/test-activation/bonobo-activation-test-async.c ?

No, but when I run the tests manually (make check in /var/tmp/portage) then all 17 tests pass, so I think it is more likely a permission problem, not a timing problem.

Comment 18 Pacho Ramos gentoo-dev 2010-08-31 15:47:13 UTC
The problem is that after months of checking this bug from time to time, I have seen that the problem occurs randomly for me even compiling with emerge or manually :-(
Comment 19 Pacho Ramos gentoo-dev 2010-09-25 14:20:08 UTC
Bah, they have just failed for me on a different way here:

getInfo (dltd storage):	passed
listContents (deleted):	passed
16 of 16 tests passed
PASS: test-storage-mem
Starting factory
Starting client
**
ERROR:test-generic-factory.c:54:run_tests: assertion failed: (obj1 != CORBA_OBJECT_NIL)
Waiting for factory to terminate; Please hold on a second, otherwise hit Ctrl-C.
Comparing factory output with model...
--- ./models/generic-factory.output	2009-04-18 14:27:41.000000000 +0200
+++ generic-factory.output	2010-09-25 16:14:48.000000000 +0200
@@ -1,4 +0,0 @@
-new instance: #1
-instance #1 destroyed
-new instance: #2
-instance #2 destroyed
...DIFFERENT!
FAIL: test-generic-factory.sh
main loop level = 1
timeout
PASS: test-main-loop
===========================================================================================
1 of 8 tests failed
Please report to http://bugzilla.gnome.org/enter_bug.cgi?product=bonobo&component=libbonobo
===========================================================================================
make[3]: *** [check-TESTS] Error 1
make[3]: Leaving directory `/home/pacho/libbonobo-2.24.3/tests'
make[2]: *** [check-am] Error 2
make[2]: Leaving directory `/home/pacho/libbonobo-2.24.3/tests'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/home/pacho/libbonobo-2.24.3/tests'
make: *** [check-recursive] Error 1


And hanged on other try emerging, I think I will simply restrict them since it's obvious tests tend to fail in several ways from time to time and upstream no longer develops it.
Comment 20 Pacho Ramos gentoo-dev 2010-09-25 14:32:06 UTC
+  25 Sep 2010; Pacho Ramos <pacho@gentoo.org> -libbonobo-2.24.2.ebuild,
+  libbonobo-2.24.3.ebuild:
+  Don't build tests and examples when not needed (bug #226223), also fix
+  intltoolize broken file as my local check says it's broken; finally
+  RESTRICT tests since they tend to fail on several ways even manually
+  compiling, upstream is aware but they don't seem to care, probably because
+  libbonobo is deprecated (bug #288689). Remove old testing.
+