Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288580 - Upgrading x11-libs/qt to 4.5.3 breaks kmail's and kwallet's password dialogs
Summary: Upgrading x11-libs/qt to 4.5.3 breaks kmail's and kwallet's password dialogs
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Qt Bug Alias
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-11 16:12 UTC by Dirk Heinrichs
Modified: 2010-10-01 22:37 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Heinrichs 2009-10-11 16:12:24 UTC
After upgrading QT packages to 4.5.3, kmail's and kwallet's password dialogs stopped working. "OK" button didn't react to clicks anymore and the dialog stayed on the screen until "Cancel" was clicked. Downgrading QT to 4.5.2 brought everything back to normal again. So I suggest to mask 4.5.3 until the issue is resolved upstream.

Reproducible: Always

Steps to Reproduce:
1. Update QT to 4.5.3
2. Restart KDE session
3. Run kmail or some app that uses kwallet
Actual Results:  
Password dialog not working.

Expected Results:  
Password dialog should go away and open access to whatever was requested.
Comment 1 PhobosK 2009-10-11 20:10:07 UTC
As a workaround the following may be used:
1. Enter the password
2. Click "Open" dialog button or click "Enter" keyboard button
3. Minimize the dialog
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2009-11-06 11:56:30 UTC
Solved with respective qt packages 4.5.3-r1 bumps.

Please update.
Comment 3 Albert Holm 2009-12-03 15:39:23 UTC
I just upgraded to qt-4.6.0 and after that to kde-4.3.4. This issue seems to have reappeared. Atleast I get the same behaviour as in the original description and the workaround in #1 works.
Comment 4 Dirk Heinrichs 2009-12-03 18:27:41 UTC
Yep, for me too. I wonder if it could be a side effect of the patch-2.6.0 bug?
Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2009-12-03 19:16:44 UTC
as per user statements reopening
Comment 6 Dirk Heinrichs 2009-12-03 20:58:13 UTC
I can confirm now that after downgrade of sys-devel/patch and recompiling all QT packages the problem still persists.
Comment 7 Ben de Groot (RETIRED) gentoo-dev 2009-12-04 01:00:22 UTC
The qt-core elog messages have some suggestions in case something breaks. Did you follow those?
Comment 8 Dirk Heinrichs 2009-12-07 10:52:31 UTC
(In reply to comment #7)
> The qt-core elog messages have some suggestions in case something breaks. Did
> you follow those?

Yes, but as was the case with 4.5.3, that didn't change anything.
Comment 9 Albert Holm 2009-12-08 06:05:07 UTC
(In reply to comment #7)
> The qt-core elog messages have some suggestions in case something breaks. Did
> you follow those?

I reinstalled all of kde and all other packages that depend on qt-core after the upgrade from qt-4.5.3 to qt-4.6.0. I still have to minimize the kwallet passphrase dialog to start kmail properly. Out of three installs, two show this behaviour but I am not sure what the difference between those two and the third is. All three were upgraded from kde-4.3.3/qt 4.5.3 but I have not reinstalled the working install as frequent as the others (after the qt upgrade).
Comment 10 skyguy 2009-12-08 22:35:05 UTC
I can confirm this. Seems to be a qt related "feature". Same bug here after upgrading to qt-4.6.0 and before and after upgrade from kde-4.3.3 to 4.3.4.
Comment 11 Andreas K. Hüttel gentoo-dev 2010-07-07 18:42:42 UTC
Does this problem still happen with kde-4.4.4?
Comment 12 Andreas K. Hüttel gentoo-dev 2010-10-01 22:37:41 UTC
No response for three months, so I'll assume this is fixed in kde-4.4.

Please reopen if the problem reappears with current kde versions.