Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288570 - xorg-server-1.6.3.901-r2 won't start with xf86-video-vesa-2.2.1 "No matching modes"
Summary: xorg-server-1.6.3.901-r2 won't start with xf86-video-vesa-2.2.1 "No matching ...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-11 15:33 UTC by Pierre Asselin
Modified: 2009-10-25 13:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
failing Xorg.0.log (Xorg.0.vesa-bad.log,6.98 KB, text/plain)
2009-10-11 15:37 UTC, Pierre Asselin
Details
xorg.conf (xorg.conf,1.81 KB, text/plain)
2009-10-11 15:37 UTC, Pierre Asselin
Details
Xorg.0.log with the openchrome driver (Xorg.0.log,41.85 KB, text/plain)
2009-10-11 15:41 UTC, Pierre Asselin
Details
working xorg.conf for openchrome-0.2.904 (xorg-openchrome.conf,1.05 KB, text/plain)
2009-10-11 15:42 UTC, Pierre Asselin
Details
output from "lspci -vvv -nn" (lspci-vvv-nn,10.81 KB, text/plain)
2009-10-14 00:34 UTC, Pierre Asselin
Details
output from dmidecode (dmidecode,6.82 KB, text/plain)
2009-10-14 00:35 UTC, Pierre Asselin
Details
output from biosdecode (biosdecode,973 bytes, text/plain)
2009-10-14 00:35 UTC, Pierre Asselin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Asselin 2009-10-11 15:33:31 UTC
After upgrade to xorg-server-1.6.3.901-r2 and xf86-video-vesa-2.2.1 the server fails to start.  Temporary workaround for me, use xf86-video-openchrome-0.2.904 despite instability.  From Xorg.0.log,

(II) VESA(0): VESA VBE DDC read failed
(II) VESA(0): VESA VBE PanelID invalid
(II) VESA(0): Searching for matching VESA mode(s):

(II) VESA(0): Total Memory: 512 64KB banks (32768kB)
(EE) VESA(0): No matching modes

Could be hardware-specific, Averatec 32xx laptop, but this is a regression.

Reproducible: Always

Steps to Reproduce:
1. startx -- -logverbose [-depth 16]
2.
3.

Actual Results:  
Xorg fails to start.  Will attach Xorg.0.log.

Expected Results:  
Xorg should start.


Portage 2.1.6.13 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r6-i686-mobile_AMD_Athlon-tm-_XP-M_-LV-_2200+-with-gentoo-1.12.11.1
Timestamp of tree: Sat, 10 Oct 2009 11:30:17 +0000
app-shells/bash:     4.0_p28
dev-lang/python:     2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://mirror.datapipe.net/gentoo http://mirrors.acm.cs.rpi.edu/gentoo/ http://cudlug.cudenver.edu/gentoo/ http://gentoo.cs.lewisu.edu/gentoo/ http://mirror.usu.edu/mirrors/gentoo/ http://mir1.ovh.net/gentoo-distfiles/ http://gentoo.arcticnetwork.ca/"
LANG="fr_CA.utf8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt dbus doc dri dts dvd dvdr eds emboss encode esd evo fam fftw firefox flac fortran gdbm gif gpm gstreamer gtk hal hdf5 iconv ipv6 isdnlog jpeg kpathsea ldap libnotify loop-aes mad mikmod modules mp3 mp4 mpeg mudflap ncurses netcdf nls nptl nptlonly ogg opengl pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse ssl startup-notification svg sysfs tcpd thunar tiff truetype unicode usb vorbis win32codecs x264 x86 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="via vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Pierre Asselin 2009-10-11 15:37:04 UTC
Created attachment 206763 [details]
failing Xorg.0.log

In the past there would be a long list of rejected modes, that could be made to work by tweaking xorg.conf .  This time the tweaks have no effect.
Comment 2 Pierre Asselin 2009-10-11 15:37:43 UTC
Created attachment 206765 [details]
xorg.conf
Comment 3 Pierre Asselin 2009-10-11 15:41:48 UTC
Created attachment 206767 [details]
Xorg.0.log with the openchrome driver

xf86-video-openchrome-0.2.904 (currently ~x86) succeeds but is dangerous with 3D apps.
xf86-video-openchrome-0.2.903 fails to find any modes.  No logs, sorry.
Comment 4 Pierre Asselin 2009-10-11 15:42:40 UTC
Created attachment 206769 [details]
working xorg.conf for openchrome-0.2.904
Comment 5 Pierre Asselin 2009-10-14 00:33:38 UTC
(In reply to comment #0)

It is hardware-dependent.  FWIW will attach output from lspci, dmidecode, biosdecode.

Similar bug was reported upstream,
https://bugs.freedesktop.org/show_bug.cgi?id=24348
Comment 6 Pierre Asselin 2009-10-14 00:34:32 UTC
Created attachment 207029 [details]
output from "lspci -vvv -nn"
Comment 7 Pierre Asselin 2009-10-14 00:35:06 UTC
Created attachment 207030 [details]
output from dmidecode
Comment 8 Pierre Asselin 2009-10-14 00:35:37 UTC
Created attachment 207031 [details]
output from biosdecode
Comment 9 Rémi Cardona gentoo-dev 2009-10-24 12:28:51 UTC
Please file a bug upstream [1] and paste the URL here so I can track the issue.

Thanks

[1] https://bugs.freedesktop.org/ => "xorg" product
Comment 10 Pierre Asselin 2009-10-25 11:46:44 UTC
It's already upstream.  I added a link to here.

https://bugs.freedesktop.org/show_bug.cgi?id=24348
Comment 11 Rémi Cardona gentoo-dev 2009-10-25 12:11:48 UTC
Reopening
Comment 12 Rémi Cardona gentoo-dev 2009-10-25 13:36:06 UTC
And closing with the proper resolution. Let's track the bug upstream.

Thanks