Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288187 - kde-base/kopete-4.3.1: doesn't compile with libgadu support
Summary: kde-base/kopete-4.3.1: doesn't compile with libgadu support
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-08 11:31 UTC by Michał Przybyła
Modified: 2010-06-06 23:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
Build log (kopete-4.3.1.build.logs.tbz,48.48 KB, application/octet-stream)
2009-10-28 12:28 UTC, Michał Przybyła
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Przybyła 2009-10-08 11:31:47 UTC
Configure finds LIBGADU library, but it looks for a libgadu.h in 
/usr/kerberos/include/ instead of /usr/include/

>>> Configuring source in /var/tmp/portage/kde-base/kopete-4.3.1/work/kopete-4.3.1 ...
(...)
-- Found LIBGADU: /usr/lib/libgadu.so  
grep: /usr/kerberos/include/libgadu.h: No such file or directory
-- libgadu must be compiled with pthreads support


Reproducible: Always




emerge --info
Portage 2.1.6.13 (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.10.1-r0, 2.6.30-tuxonice-r5 i686)
=================================================================                                       
System uname: Linux-2.6.30-tuxonice-r5-i686-Intel-R-_Core-TM-2_Duo_CPU_T7500_@_2.20GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 07 Oct 2009 09:30:01 +0000                                                      
app-shells/bash:     4.0_p33                                                                            
dev-java/java-config: 2.1.9-r1                                                                          
dev-lang/python:     2.6.3, 3.1.1-r1                                                                    
dev-util/cmake:      2.6.4-r3                                                                           
sys-apps/baselayout: 2.0.1                                                                              
sys-apps/openrc:     0.4.3-r3                                                                           
sys-apps/sandbox:    2.1                                                                                
sys-devel/autoconf:  2.13, 2.63-r1                                                                      
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                                         
sys-devel/binutils:  2.19.1-r1                                                                          
sys-devel/gcc-config: 1.4.1                                                                             
sys-devel/libtool:   2.2.6a                                                                             
virtual/os-headers:  2.6.30-r1                                                                          
ACCEPT_KEYWORDS="x86 ~x86"                                                                              
CBUILD="i686-pc-linux-gnu"                                                                              
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"                                                 
CHOST="i686-pc-linux-gnu"                                                                               
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"                                              
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"                                         
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"                                                                 
DISTDIR="/usr/portage/distfiles"                                                                                          
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                                                                                                    
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"                     
LANG="pl_PL.utf8"                                                                                                         
LC_ALL="pl_PL.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="pl en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acl acpi additions admin administrator aften aio akode alisp alsa amarok2 amr amrnb amrwb apache2 archive artworkextra ass async audacious automount avahi bash-completion berkdb binary-drivers bl bluetooth branding bzip2 cairo cdda cddb cdinstall cdparanoia cdr cleartype cli colordiff consolekit corefonts cracklib crypt css ctype cups custom-optimization cvs dbus directfb disk-partition dri dts dv dvd dvdnav dvdr eds embedded emboss emerald enca encode esd evo exif extraemoticons extraicons extramodules fam fat fbcon fbcondecor fbsplash ffmpeg filter firefox firefox3 flac flash fortran ftp fuse fusion gadu gd gdbm gif gimp git glib glitz gmail gnet gphoto2 gpm grub gstreamer gtk hal handbook hddtemp hdri hpn htmlhandbook icons iconv id3 id3tag idn ieee1394 imagemagick innodb inotify iostats isdnlog jack java jpeg jpeg2k kde kerberos kontact lame laptop lcms ldap libnotify lm_sensors logrotate mad matroska mdnsresponder-compat memlimit mikmod mmx mmxext mng modules mono mp2 mp3 mp4 mpeg mudflap mysql mysqli ncurses new-login nls nocd nptl nptlonly nsplugin ntfs nvidia oci8-instant-client ogg openexr opengl openmp oracle pam passwordsave pcap pcf pch pcmcia pcre pdf perl pixmaps plasma plotutils pmu png posix postgres postscript powerkadu ppds pppd psf pvr python qt3support qt4 query-browser quicktime raw rdesktop readline redland reflection rss rtc samba sdl sensord session slang smp spell spl sql sqlite sqlite3 sse sse2 sse3 ssl ssse3 startup-notification stream suid svg sysfs syslog systray taglib tcpd theora threads thunar tidy tiff tk truetype unicode usb v4l v4l2 vcd vcdinfo vcdx vhosts videos visualization vnc vorbis wavpack webkit wifi win32codecs wmf wxwindows x264 x86 xcb xcomposite xine xinerama xml xorg xpm xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2009-10-08 11:54:06 UTC
Please sync in about 1 hour and try again.
Comment 2 Michał Przybyła 2009-10-08 12:48:19 UTC
(In reply to comment #1)
> Please sync in about 1 hour and try again.
> 

No change ;( libgadu was alredy compliled with the threads flag, to be sure I recompiled libgadu, did not help.
Comment 3 Michał Przybyła 2009-10-09 10:12:05 UTC
I found something interesting in the file /var/tmp/portage/kde-base/kopete-4.3.1/work/CMakeCache.txt:

PC_LIBGADU_CFLAGS:INTERNAL=-pthread;-I/usr/kerberos/include

IMHO it should be PC_LIBGADU_CFLAGS:INTERNAL=-pthread;-I/usr/include

So there is something wrong in FindLibgadu.cmake file. 
Hope it helps, I don't know how cmake works, so I can't resolve it myself ;(
Comment 4 Maciej Mrozowski gentoo-dev 2009-10-19 13:31:52 UTC
Are you sure you don't have local copy of libgadu in /usr/local ?
Comment 5 Michał Przybyła 2009-10-19 19:50:41 UTC
(In reply to comment #4)
> Are you sure you don't have local copy of libgadu in /usr/local ?
> 

Yes, I'm sure (/usr/local/lib contains only the ".keep" file and an empty directory "kde4").

I also did "emerge -e world". No effect :/
Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-10-28 11:12:33 UTC
Please post the complete build log. It seems you either have a polluted environment or that there's some "collision" with a kerberos package. Do you have heimdal or mit-krb5?
Comment 7 Michał Przybyła 2009-10-28 12:28:54 UTC
Created attachment 208508 [details]
Build log
Comment 8 Michał Przybyła 2009-10-28 12:31:29 UTC
(In reply to comment #6)
> Please post the complete build log. It seems you either have a polluted
> environment or that there's some "collision" with a kerberos package. Do you
> have heimdal or mit-krb5?
> 
no heimdal or mit-krb5

Comment 9 Michał Przybyła 2009-10-28 12:33:44 UTC
> no heimdal or mit-krb5
> 

SORRY!!! 
arrrrghh.... I made a typo when checking it, I have mit-krb5-1.7-r1 installed ;((
Comment 10 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-10-29 00:58:11 UTC
I noticed the following in your environment:
C_INCLUDE_PATH=/usr/lib/oracle/11.1.0.7.0/client/include

In the build log you also have:
-- checking for module 'libgadu'
--   found libgadu, version 1.8.2
-- Found LIBGADU: /usr/lib/libgadu.so
grep: /usr/kerberos/include/libgadu.h: Nie ma takiego pliku ani katalogu
-- libgadu must be compiled with pthreads support

Can you translate the above error message?
Comment 11 Michał Przybyła 2009-10-29 09:10:00 UTC
(In reply to comment #10)
> I noticed the following in your environment:
> C_INCLUDE_PATH=/usr/lib/oracle/11.1.0.7.0/client/include
> 
> In the build log you also have:
> -- checking for module 'libgadu'
> --   found libgadu, version 1.8.2
> -- Found LIBGADU: /usr/lib/libgadu.so
> grep: /usr/kerberos/include/libgadu.h: Nie ma takiego pliku ani katalogu
> -- libgadu must be compiled with pthreads support
> 
> Can you translate the above error message?
> 

grep: /usr/kerberos/include/libgadu.h: No such file or directory
Comment 12 Miroslaw Mieszczak 2009-12-15 12:24:02 UTC
I have the same with kopete 4.3.4
So the problem persist with the new version of kde.
Comment 13 Miroslaw Mieszczak 2009-12-15 13:07:44 UTC
It seems that the problem is somewhere else than kopete/kde.
I checked in /usr/lib64/pkgconfig/libgadu.pc, and there is:

prefix=/usr
exec_prefix=${prefix}
libdir=/usr/lib64
includedir=${prefix}/include

Name: libgadu
Version: 1.8.2
Description: libgadu
Requires:  openssl
Libs: -L${libdir} -lgadu  -pthread  -lssl -lcrypto -ldl -lz  
Cflags: -I${includedir}  -pthread -I/usr/kerberos/include  



Then I checked what other files contain /usr/kerberos/include, and I found:
libssl.pc, openssl.pc, and libcrypto.pc.
It seems that dependencies for ssl can't be correctly compiled at all.
Comment 14 Sebastian Dörner 2010-04-03 11:22:16 UTC
I cannot reproduce this problem with kopete-4.3.5 on x86:

-- checking for module 'libgadu'
--   found libgadu, version 1.8.2
-- Found LIBGADU: /usr/lib/libgadu.so
#define GG_CONFIG_HAVE_PTHREAD 
-- Looking for include files HAVE_VALGRIND_H

Gadu support is available in kopete as expected (although I didn't test it because I lack an account). Portage told me to set the threads use flag for libgadu.
Comment 15 Andreas K. Hüttel gentoo-dev 2010-04-03 16:36:09 UTC
Miroslav, what's your ssh version and useflags?
What happens after you re-emerge that? 

Do you need kerberos support? If not, can you disable it for ssh?
Comment 16 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-06-06 23:24:32 UTC
As there was no more feedback and I can build the gadu support here (even though I can't test it), I'm going to close this as WORKSFORME.
Please reopen if you hit this issue again.