Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 287995 - media-video/mplayer-1.0_rc2_p20090731-r1 not respecting system compile flags
Summary: media-video/mplayer-1.0_rc2_p20090731-r1 not respecting system compile flags
Status: RESOLVED DUPLICATE of bug 269975
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-07 03:02 UTC by Sebastian Pipping
Modified: 2009-10-11 11:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Pipping gentoo-dev 2009-10-07 03:02:45 UTC
My CFLAGS from make.conf are

  CFLAGS="-march=nocona -O2 -pipe"

but compilation runs with

  -O4 -march=native -mtune=native

and a few others.  Upstream's non-autoconf configure script seems to be adding them.  I found this block in it:

=============================================================
# Checking for CFLAGS
_install_strip="-s"
if test "$_profile" != "" || test "$_debug" != "" ; then
  CFLAGS="-W -Wall -O2 $_march $_mcpu $_pipe $_debug $_profile"
  _install_strip=
elif test -z "$CFLAGS" ; then
  if test "$cc_vendor" = "intel" ; then
    CFLAGS="-O2 $_march $_mcpu $_pipe -fomit-frame-pointer -wd167 -wd556 -wd144"
  elif test "$cc_vendor" != "gnu" ; then
    CFLAGS="-O2 $_march $_mcpu $_pipe"
  else
    CFLAGS="-Wall -Wno-switch -Wpointer-arith -Wredundant-decls -O4 $_march $_mcpu $_pipe -ffast-math -fomit-frame-pointer"
    extra_ldflags="$extra_ldflags -ffast-math"
  fi
else
  _warn_CFLAGS=yes
fi
=============================================================

While mplayer-1.0_rc4_p20090919-r2.ebuild for some reason does not compile with -O4 and friends (maybe due to "Drop custom-cflags due to gcc-4 bug, filter flags, bug 269975" (ChangeLog)) the block above is still present in configure and may need further attention.

Reproducible: Always
Comment 1 Sebastian Pipping gentoo-dev 2009-10-07 03:04:14 UTC
CC'ing Steve, as we spoke about it earlier.
Comment 2 Jeroen Roovers gentoo-dev 2009-10-07 04:24:29 UTC
@Sebastian: Please Assign bugs yourself (now that you have the Power).
Comment 3 Samuli Suominen gentoo-dev 2009-10-11 11:39:01 UTC

*** This bug has been marked as a duplicate of bug 269975 ***