Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 287786 - sys-apps/coreutils-7.{4,5} fails misc/stty test on sparc
Summary: sys-apps/coreutils-7.{4,5} fails misc/stty test on sparc
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2009-10-05 15:32 UTC by Dustin Polke
Modified: 2017-11-23 21:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
test-suite.log (test-suite.log,122.46 KB, text/plain)
2009-10-05 15:33 UTC, Dustin Polke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dustin Polke 2009-10-05 15:32:05 UTC
Find test-suite.log attached.

Reproducible: Always




Portage 2.1.6.13 (default/linux/sparc/experimental/multilib/server, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r6 sparc64)
=================================================================
System uname: Linux-2.6.30-gentoo-r6-sparc64-sun4u-with-gentoo-1.12.11.1
Timestamp of tree: Mon, 05 Oct 2009 07:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p28
dev-lang/python:     2.6.2-r1
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="sparc"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=ultrasparc -pipe -ggdb"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=ultrasparc -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms splitdebug strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://mirror.netcologne.de/gentoo/     ftp://gentoo.tiscali.nl/pub/mirror/gentoo/     ftp://mirror.cambrium.nl/pub/os/linux/gentoo/     ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo     ftp://ftp6.uni-muenster.de/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=500"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sping /usr/local/portage/layman/sunrise /usr/local/portage/modified /usr/local/portage/own"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="acl admin apache2 bash-completion berkdb bzip2 cgi cli courier coverpage cracklib crypt cups dri fortran gd gdbm git gpm iconv iproute2 isdnlog javascript jpeg kerberos keyscrub ldap logrotate loop-aes mime modules mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl php png posix postgres pppd python readline reflection sasl session snmp sparc spl ssl suhosin sysfs syslog tcpd threads tiff truetype unicode userlocales xml xorg zlib" ALSA_CARDS="cs4231" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias asis auth_basic auth_digest authn_anon authn_dbm     authn_file authz_host autoindex cache cern_meta charset_lite dav dav_fs     deflate dir disk_cache env expires ext_filter file_cache filter headers     include info log_config logio mem_cache mime mime_magic negotiation proxy     proxy_connect proxy_ftp proxy_http rewrite setenvif speling status unique_id     userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="mach64"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS_FLAGS
Comment 1 Dustin Polke 2009-10-05 15:33:26 UTC
Created attachment 206139 [details]
test-suite.log
Comment 2 Dustin Polke 2009-10-06 08:38:44 UTC
I tested coreutils-7.5 as well, since it is being stabilized in bug 287219.
I can reproduce the same failure with coreutils-7.5.
Comment 3 Rolf Eike Beer archtester 2017-11-23 19:19:45 UTC
In newer versions this test is skipped:

+ skip_ 'requires controlling input terminal
This test must have a controlling input "terminal", so it may not be
run via "batch", "at", or "ssh".  On some systems, it may not even be
run in the background.'

I guess this can be closed now, no?
Comment 4 Thomas Deutschmann gentoo-dev Security 2017-11-23 21:21:16 UTC
Yes, upstream is skipping the test now when you don't run test suite in front of the system (via tty). Would be still interesting if the test passes when run via tty on sparc.