Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 287735 - ati-drivers-9.9-r2: black screen but can login through ssh
Summary: ati-drivers-9.9-r2: black screen but can login through ssh
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-05 11:03 UTC by urcindalo
Modified: 2009-10-28 12:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xorg.0.log for ati-drivers-9.8 (xorg.0.log 9.8.txt,36.47 KB, text/plain)
2009-10-05 11:04 UTC, urcindalo
Details
xorg.0.log for ati-drivers-9.9-r2 (xorg.0.log 9.9.txt,16.53 KB, text/plain)
2009-10-05 11:04 UTC, urcindalo
Details
/etc/X11/xorg.conf (xorg.conf,881 bytes, text/plain)
2009-10-10 17:06 UTC, urcindalo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description urcindalo 2009-10-05 11:03:01 UTC
I use a mostly stable amd64 box (main unstable packages are KDE 4.3.1 and some scientific packages), including the amd64 stable gentoo-sources kernel.

I own a laptop with 4GB RAM and an ATI HD4570/512MB.

I can't use the recently stable ati-drivers-9.9-r2, because I get a black screen, but I can still login through ssh. However, ati-drivers-9.8 work.

I have attached the xorg.0.log for both ati-drivers versions. You can see the device identifier is not the same (I don't know if that's relevant). Also, the log for the 9.9-r2 version is much shorter: after the following line

===
(II) fglrx(0): Using adapter: 2:0.0.
=== 

the log for the 9.9 version is empty!!


What can I do? I'm worried because I know I won't be able to use the 9.8 version with kernel >=2.6.31

Thanks.

Reproducible: Always

Steps to Reproduce:
1. emerge the stable amd64 ati-drivers
2.
3.

Actual Results:  
Black screen

Expected Results:  
The drivers work

My emerge --info:

Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r5-x86_64-AMD_Athlon-tm-_X2_Dual-Core_QL-65-with-gentoo-1.12.11.1
Timestamp of tree: Sun, 04 Oct 2009 20:30:01 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64-sse3 -mtune=athlon64-sse3 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64-sse3 -mtune=athlon64-sse3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.mirror.dkm.cz/pub/gentoo/"
LANG="es_ES.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="es_ES es en_US en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local /usr/local/portage/layman/science /usr/local/portage/layman/roslin /usr/local/portage/layman/sunrise /usr/local/portage/layman/pro-audio /usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnowext X a52 aac aalib acl acpi additions adns ads aften aim aio akode akonadi alsa amazon amd64 apbs apm ares ass async audio audiofile autoipd avahi bash-completion battery bcmath beagle berkdb bidi binary-drivers binfilter bittorrent-external bluetooth bonjour branding bzip2 cairo caps cblas cdda cddb cdr cgi cgraph charconv chasen chm clamav cli client-only clisp cmake consolekit context contrib corefonts cracklib crypt css cups cupsddk curl custom-optimization cvs dbus desktopglobe detex dga dhclient dhcpcd dia directfb dosformat dri dts dv dvd dvdr dvi dvi2tty dvipdfm eap-sim editor eds emboss emovix encode esd evo exif extra fam fat fbcon ffmpeg fftw firefox firefox3 flac fontconfig foomaticdb fortran ftp fuse gcj gdbm geoip geolocation gif gimp ginac gnome gnuplot gnutls gphoto2 gpm gps graphics graphviz gsl gstreamer gtk gtkhtml gtkstyle gzip hal hddtemp hdri hfs hibernate-script iconv icu idn imagemagick imap imlib ioctl ipod ipv6 isdnlog jack jadetex java java6 javascript jce jpeg jpeg2k justify kate kde kde4 lame lapack laptop lasi latex latex3 lcms ldap libass libcaca libnotify libwww live lm_sensors logrotate lqr lzo mad madwifi maildir mailwrapper matroska matrox mbox mcve mdnsresponder-compat memlimit metric mikmod mime mmap mmx mmxext mng modules mono mopac7 motif moznomail mp3 mp4 mpeg mplayer msn mudflap multilib musepack nas ncurses network networkmanager nforce2 nls npp nptl nptlonly nsplugin ntfs numpy octave ogg omega opal openal openbabel openexr opengl openmp osc oscar osdmenu oss pam pcre pdf perl plasma plotutils pm-utils pmu png policykit portaudio posix postscript povray ppds ppm ps ps3 psf pstoedit pstricks publishers pulseaudio pymol python qt3 qt3support qt4 quicktime rar raw rdesktop readline realmedia recode reflection reiser4 reiserfs rss ruby samba sasl scanner science sdl sdl-image semantic-desktop session sharedmem shorten simplexml skype slang slp smartcard smp sndfile snmp sockets solver sox sparse spell spl sse sse2 sse3 ssl ssse3 startup-notification subtitles subversion svg svgz sysfs syslog szip taglib tcl tcpd tex4ht tga theora threads thunar tidy tiff tk transcode trash-plugin truetype type3 unicode usb userlocales v4l v4l2 vcd vhook video video-file vnc vorbis wavpack webinterface wifi winbind winpopup wma wmf wpg wps wxwidgets x264 xattr xcomposite xetex xfce xindy xine xinerama xml xorg xosd xplanet xpm xprint xscreensaver xulrunner xv xvid yahoo zeroconf zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="fuji ptp2" ELIBC="glibc" FOO2ZJS_DEVICES="hp1000" INPUT_DEVICES="synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es_ES es en_US en" SANE_BACKENDS="epson2 hp" USERLAND="GNU" VIDEO_CARDS="fglrx radeon vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 urcindalo 2009-10-05 11:04:02 UTC
Created attachment 206070 [details]
xorg.0.log for ati-drivers-9.8
Comment 2 urcindalo 2009-10-05 11:04:36 UTC
Created attachment 206071 [details]
xorg.0.log for ati-drivers-9.9-r2
Comment 3 urcindalo 2009-10-05 11:07:27 UTC
I forgot. This is the relevant part in xorg.conf:

====

Section "Device"
        Identifier  "ATI"
        Driver      "fglrx"
        VideoRam    524288
        Option      "XAANoOffscreenPixmaps" "true"
        BusID       "PCI:2:0:0"
EndSection

====

The BusID line was added by "aticonfig --initial".
Comment 4 Justin Lecher (RETIRED) gentoo-dev 2009-10-09 18:52:56 UTC
PLease attach the complete xorg.conf
Comment 5 Justin Lecher (RETIRED) gentoo-dev 2009-10-09 18:54:55 UTC
Check wether it is a duplicate off bug 282256 and the solution from there fixes it.
Comment 6 urcindalo 2009-10-10 17:06:24 UTC
Created attachment 206691 [details]
/etc/X11/xorg.conf
Comment 7 urcindalo 2009-10-10 17:08:39 UTC
(In reply to comment #5)
> Check wether it is a duplicate off bug 282256 and the solution from there fixes
> it.
> 

No, it isn't. The first thing I did was to check every open or fixed bug related to ati-drivers.

Thanks for your help.
Comment 8 urcindalo 2009-10-22 06:53:28 UTC
Nothing yet? Am I the only one suffering from this?
I have 4GB RAM, and I read somew time ago there were some problems with 4GB RAM and ATI drivers (versions lower than 9.9). Some people decreased RAM to 2 GB and everything worked again. Could this be he cause?

Or maybe a udev problem? I use the stable 141.
Comment 9 urcindalo 2009-10-26 12:25:11 UTC
New version 9.10 solves the problem. May I suggest it to go stable? 9.9 version was a headache for too many people.
Comment 10 Gregor Kališnik 2009-10-27 10:42:56 UTC
(In reply to comment #9)
> New version 9.10 solves the problem. May I suggest it to go stable? 9.9 version
> was a headache for too many people.
> 

9.10 still doesn't work for me. But i'm not sure if my problem is the same.

I submitted the bug:
http://bugs.gentoo.org/show_bug.cgi?id=284960
Comment 11 urcindalo 2009-10-27 13:03:39 UTC
(In reply to comment #10)
> 9.10 still doesn't work for me. But i'm not sure if my problem is the same.

I can imagine how desperate you are, because I was. Please tell me if I can be of any help. Although I'm just a regular user, I can provide you with the .config for my kernel or any other config file you may ask for, the list of my installed packages, my hardware specs... Just anything that could be useful for comparison purposes between your box and mine.
Comment 12 Gregor Kališnik 2009-10-27 13:18:11 UTC
I think I posted all the configs to the bug report there.

HW spec is:
- Radeon HD 4850
- Athlon X2 3800+
- 6GiB RAM
- Asus mother board wih nvidia chipset

And I have xinerama (which might be the problem).

I also used my brothers computer as a comparison, and couldn't pint point the problem. I would also theorize that memory corruption is not connected to the ati-drivers.

I think that memory corruption occurs on hard-shutdown of the machine. But I don't know what causes it.

When I got to the log (uncorrupted :S), I got the same output like you. Stopped at 
(II) fglrx(0): Using adapter: 3:0.0.
line.

(In reply to comment #11)
> (In reply to comment #10)
> > 9.10 still doesn't work for me. But i'm not sure if my problem is the same.
> 
> I can imagine how desperate you are, because I was. Please tell me if I can be
> of any help. Although I'm just a regular user, I can provide you with the
> .config for my kernel or any other config file you may ask for, the list of my
> installed packages, my hardware specs... Just anything that could be useful for
> comparison purposes between your box and mine.
> 

Comment 13 Tomáš Chvátal (RETIRED) gentoo-dev 2009-10-27 13:28:38 UTC
I can only ask one question:
Do you really need ati-drivers?
Because basicaly xf86-video-ati should work for anyone and i can give some help with these setups, but i am seriously just commiter&dependency checker for the ati-drivers, nothing more...

Also when there is 2.6.32 kernel 3d will be availible for all ati cards.
Comment 14 Gregor Kališnik 2009-10-27 13:37:42 UTC
I think I'll wait a little while for open source 3D support to mature a little bit (not going to change my graphics card any time soon).

But I would really like to solve this problem :) (especially the memory corruption thingy), since I beleive it's unconnected to the ati drivers.

Some time later I'll try to hard-shutdown my machine to look for memory corruptions so I could confirm my suspicions.

(In reply to comment #13)
> I can only ask one question:
> Do you really need ati-drivers?
> Because basicaly xf86-video-ati should work for anyone and i can give some help
> with these setups, but i am seriously just commiter&dependency checker for the
> ati-drivers, nothing more...
> 
> Also when there is 2.6.32 kernel 3d will be availible for all ati cards.
> 

Comment 15 Rémi Cardona gentoo-dev 2009-10-27 14:21:49 UTC
(In reply to comment #14)
> I think I'll wait a little while for open source 3D support to mature a little
> bit (not going to change my graphics card any time soon).

The sooner you try the OSS drivers, the sooner you can report bugs and the sooner upstream can fix them.

I've been maintaining Intel drivers for more than a year now, and this is the _exact_ pattern that I've seen over and over and over.

Please try those drivers and help upstream make them better faster. It might not be perfect at first, you might get bugs and maybe crashes, but it's _worth_ the trouble.

AMD's binary drivers are a plague. Even AMD seems to have stopped caring about them. They regularly update their public docs and have hired a few X devs to work on the OSS drivers. That and there's absolutely no support from AMD on the binary drivers, we don't have any way of reporting bugs to them.

> But I would really like to solve this problem :) (especially the memory
> corruption thingy), since I beleive it's unconnected to the ati drivers.

There's a track record for binary drivers here. Most of them are just awful at memory management. Even the free ones have issues, but they get fixed really quickly.

Again, I can't stress how important it is to try the free drivers and help improve them.

Tomas, please close this bug CANTFIX since there's nothing we can do.

Thanks
Comment 16 Tomáš Chvátal (RETIRED) gentoo-dev 2009-10-27 14:27:59 UTC
Right, thats true resolution. We sadly cant help on this matter :/ try forums to get some support from other users, but really try the OSS drivers.
Comment 17 Gregor Kališnik 2009-10-28 07:58:16 UTC
Ok.. I'll try to use the OSS drivers. How is the current state of the r700 3D support? Have to use the code from git? And also, is this wiki up to date?
http://en.gentoo-wiki.com/wiki/RadeonHD
Comment 18 Rémi Cardona gentoo-dev 2009-10-28 08:08:03 UTC
(In reply to comment #17)
> Ok.. I'll try to use the OSS drivers. How is the current state of the r700 3D
> support? Have to use the code from git? And also, is this wiki up to date?
> http://en.gentoo-wiki.com/wiki/RadeonHD

Eew, most of this is either useless or wrong.

Just add "radeon" to VIDEO_CARDS and build the radeon DRM module in your kernel and you should be fine.

Thanks
Comment 19 Gregor Kališnik 2009-10-28 08:30:28 UTC
(In reply to comment #18)
> 
> Eew, most of this is either useless or wrong.
> 
> Just add "radeon" to VIDEO_CARDS and build the radeon DRM module in your kernel
> and you should be fine.
> 
> Thanks
> 

I'm kinda confused with radeon and radeonhd names. What are the differences?
Comment 20 Rémi Cardona gentoo-dev 2009-10-28 08:58:23 UTC
2 different drivers. "radeon" installs xf86-video-ati which is the historical ATI OSS driver. "radeonhd" installs xf86-video-radeonhd which is a newer driver meant only for HD-series chips.

For a long time, radeonhd was the only one to support newer cards. But that's no longer the case and xf86-video-ati is the preferred driver for all radeon chips.

Long story short : VIDEO_CARDS="radeon" is what you should be using.

Thanks
Comment 21 Gregor Kališnik 2009-10-28 09:02:43 UTC
(In reply to comment #20)
> 2 different drivers. "radeon" installs xf86-video-ati which is the historical
> ATI OSS driver. "radeonhd" installs xf86-video-radeonhd which is a newer driver
> meant only for HD-series chips.
> 
> For a long time, radeonhd was the only one to support newer cards. But that's
> no longer the case and xf86-video-ati is the preferred driver for all radeon
> chips.
> 
> Long story short : VIDEO_CARDS="radeon" is what you should be using.
> 
> Thanks
> 

Currently using radeonhd, radeon switches my two monitors (kde thinks that my smaller screen is the primary one). When I figure out how to renumber the screens (if it is possible) will switch to radeon.

Also, I have to upgrade to 2.6.31 kernel, right?
Comment 22 Rémi Cardona gentoo-dev 2009-10-28 09:09:48 UTC
@Tomàš, your turn to pipe in, you know ATI stuff better than me :)
Comment 23 Tomáš Chvátal (RETIRED) gentoo-dev 2009-10-28 11:05:40 UTC
http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
This is what i wrote for people interested in migration.
Well 3D will be around kernel-2.6.32. Mesa is prepared already :]
Comment 24 Gregor Kališnik 2009-10-28 12:15:47 UTC
(In reply to comment #23)
> http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
> This is what i wrote for people interested in migration.
> Well 3D will be around kernel-2.6.32. Mesa is prepared already :]
> 

Merged mesa-7.6 and x11-drm from git (using that wiki page). Got 3D hardware supported but kwin compositing still doesn't want to work :) . Which is odd, GLX_EXT_texture_from_pixmap is supported.

Also I get "IRQ's not enabled, falling back to busy waits: 2 0" warnings. I presume that I should also update some other thing to latest unstable :).
Comment 25 Gregor Kališnik 2009-10-28 12:20:48 UTC
Ok... I just kinda got the compositing working :). Kwin effects are working now :).