Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 287426 - emerge exim-4.69-r3 fails with >=sys-libs/db-4.7 due to ENV nameclash with USE=radius
Summary: emerge exim-4.69-r3 fails with >=sys-libs/db-4.7 due to ENV nameclash with US...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Fabian Groffen
URL:
Whiteboard:
Keywords:
: 287427 325645 343241 346069 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-02 21:24 UTC by Napoleon
Modified: 2011-02-01 12:57 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Napoleon 2009-10-02 21:24:34 UTC
I just did an emerge -u --deep --newuse world followed by an emerge --depclean followed by a revdep-rebuild which fails when compiling exim. The problem seems to be related to the radius USE flag. When that flag is removed, exim compiles without any problems.

Reproducible: Always

Steps to Reproduce:
1. emerge exim
2.
3.

Actual Results:  
In file included from call_radius.c:41:
/usr/include/radiusclient.h:343: error: conflicting types for 'ENV'
/usr/include/db.h:181: error: previous declaration of 'ENV' was here
make[2]: *** [call_radius.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/mail-mta/exim-4.69-r3/work/exim-4.69/build-exim-gentoo/auths'


Expected Results:  
Should have emerged fine.

latest db version: db-4.7.25_p4
db version removed by emerge --depclean: db-4.6.21_p4
radiusclient version: radiusclient-0.3.2
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-10-02 21:41:34 UTC
Hmm, maybe a slot dep is in order. Assigning to maintainer.
Comment 2 Fabian Groffen gentoo-dev 2009-10-03 11:13:48 UTC
My initial feeling actually is that it is radius-client that has the problem with db here, not exim, as it just compiles against it.
Comment 3 Fabian Groffen gentoo-dev 2009-10-03 11:38:45 UTC
Cc-ing net-dailup because they might see more bugs similar to this one
Cc-ing base-system because they are the herd for sys-libs/db and might have a good idea on how to solve this.

This /is/ an annoying error.  All packages that compile against radiusclient and use db > 4.6 seem affected because then the ENV declaration conflict occurs.  I'd say this is some nasty thing introduced in db-4.7, as it seems it used to be called DB_ENV instead.



x86_64-pc-linux-gnu-gcc -c -march=athlon64 -O2 -pipe -mno-tls-direct-seg-refs  call_radius.c
In file included from call_radius.c:41:
/usr/include/radiusclient.h:343: error: conflicting types for 'ENV'
/usr/include/db.h:181: error: previous declaration of 'ENV' was here
make[2]: *** [call_radius.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/mail-mta/exim-4.69-r3/work/exim-4.69/build-exim-gentoo/auths'
make[1]: *** No rule to make target `auths/auths.a', needed by `exim'.  Stop.
make[1]: Leaving directory `/var/tmp/portage/mail-mta/exim-4.69-r3/work/exim-4.69/build-exim-gentoo'
make: *** [go] Error 2
Comment 4 Napoleon 2009-10-03 16:48:43 UTC
proftpd also uses radiusclient and it emerges without any problems (at least for me).
Comment 5 Alin Năstac (RETIRED) gentoo-dev 2009-10-03 17:05:44 UTC
I could rename it as RC_ENV, but I have no idea if some dependent application use the old form.

The safest way to fix this is to patch >=db-4.7 and ask upstream to merge it into their source tree.
Comment 6 Christian Ruppert (idl0r) gentoo-dev 2009-10-03 21:25:37 UTC
*** Bug 287427 has been marked as a duplicate of this bug. ***
Comment 7 DEMAINE Benoît-Pierre, aka DoubleHP 2010-01-19 00:42:18 UTC
Also had this error with 4.69-r3 . This fixed it for me:
=mail-mta/exim-4.69-r3 -radius
Comment 8 Fabian Groffen gentoo-dev 2010-06-26 10:08:39 UTC
*** Bug 325645 has been marked as a duplicate of this bug. ***
Comment 9 DEMAINE Benoît-Pierre, aka DoubleHP 2010-06-26 11:35:12 UTC
I had forget it, but, yes, again,
=mail-mta/exim-4.72 -radius
fixed it for me.
Comment 10 Fabian Groffen gentoo-dev 2010-11-05 21:11:43 UTC
*** Bug 343241 has been marked as a duplicate of this bug. ***
Comment 11 Rafał Mużyło 2010-11-19 14:08:35 UTC
*** Bug 346069 has been marked as a duplicate of this bug. ***
Comment 12 DEMAINE Benoît-Pierre, aka DoubleHP 2011-01-05 00:13:16 UTC
still happens with mail-mta/exim-4.72-r1
Comment 13 Fabian Groffen gentoo-dev 2011-02-01 12:57:04 UTC
I worked around this in 4.74-r1