Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 287401 - media-libs/libkate-0.3.7 - test failure in "Checking Kate namespace"
Summary: media-libs/libkate-0.3.7 - test failure in "Checking Kate namespace"
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-02 19:17 UTC by Mounir Lamouri (volkmar) (RETIRED)
Modified: 2019-06-01 17:49 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,27.03 KB, text/plain)
2009-10-02 19:18 UTC, Mounir Lamouri (volkmar) (RETIRED)
Details
libkate-3.7 Build log (build.log,39.11 KB, text/plain)
2010-02-25 20:04 UTC, Mounir Lamouri (volkmar) (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-10-02 19:17:44 UTC
I got a failure while running test suite of libkate.

Portage 14420-svn (default/linux/powerpc/ppc32/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r4 ppc)
=================================================================
System uname: Linux-2.6.30-gentoo-r4-ppc-7447A,_altivec_supported-with-gentoo-1.12.11.1
Timestamp of tree: Fri, 02 Oct 2009 00:45:01 +0000
app-shells/bash:     4.0_p28
dev-lang/python:     2.6.2-r1
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="ppc"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -pipe -mcpu=7450 -mtune=7450 -maltivec -mabi=altivec -fno-strict-aliasing -frename-registers -fivopts -ftree-vectorize"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -mcpu=7450 -mtune=7450 -maltivec -mabi=altivec -fno-strict-aliasing -frename-registers -fivopts -ftree-vectorize"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ http://mirror.muntinternet.net/pub/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/usr/portage/tmp"
PORTDIR="/usr/portage/tree"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/x11 /usr/local/portage/layman/gnome /usr/local/portage/layman/mozilla /home/volkmar/projects/gentoo/voip /usr/local/portage/oldworld"
SYNC="rsync://oldworld.fr/gentoo-portage"
USE="X a52 aac acl alsa altivec avahi berkdb bluetooth branding bzip2 cairo cddb cdr cjk cli consolekit cracklib crypt curl dbus dri dvd emboss encode evo fam firefox flac fontconfig fortran gdbm gif gnutls gstreamer gtk hal iconv imagemagick imlib isdnlog jpeg latex libnotify mad matroska mikmod modules mp3 mp4 mpeg mudflap musepack ncurses nls nocd nodrm nptl nptlonly ogg openal opengl openmp pam pcre pdf perl png ppc ppds pppd python qt3support readline reflection ruby sdl session speex spell spl ssl startup-notification svg symlink sysfs tcpd tetex theora thunar tiff truetype unicode usb userlocales videos vim-syntax vorbis wifi x264 xcomposite xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nv nouveau" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-10-02 19:18:44 UTC
Created attachment 205866 [details]
Build log
Comment 2 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-10-02 22:44:34 UTC
Also failing in 0.3.6.
What's weird is it doesn't print any error as if it was failing when exiting.
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2010-02-24 19:35:52 UTC
(In reply to comment #2)
> Also failing in 0.3.6.
> What's weird is it doesn't print any error as if it was failing when exiting.
> 

All tests pass here with 0.3.7 (current stable). Please reopen if you can still reproduce, thanks!
Comment 4 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2010-02-25 20:03:16 UTC
Unfortunately, it is still failing with 0.3.7.
Comment 5 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2010-02-25 20:04:46 UTC
Created attachment 221189 [details]
libkate-3.7 Build log
Comment 6 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2010-02-25 20:06:08 UTC
New emerge --info. The previous one is 4 months old.

Portage 2.1.7.17 (default/linux/powerpc/ppc32/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 ppc)
=================================================================
System uname: Linux-2.6.31-gentoo-r6-ppc-7447A,_altivec_supported-with-gentoo-1.12.13
Timestamp of tree: Thu, 25 Feb 2010 01:45:01 +0000
app-shells/bash:     4.0_p35
dev-lang/python:     2.6.4, 3.1.1-r1
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="ppc"
ACCEPT_LICENSE="* -@EULA"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -pipe -mcpu=7450 -mtune=7450 -maltivec -mabi=altivec -fno-strict-aliasing -frename-registers -fivopts -ftree-vectorize"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -mcpu=7450 -mtune=7450 -maltivec -mabi=altivec -fno-strict-aliasing -frename-registers -fivopts -ftree-vectorize"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ http://mirror.muntinternet.net/pub/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/usr/portage/tmp"
PORTDIR="/usr/portage/tree"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/gnome /home/volkmar/projects/gentoo/voip /usr/local/portage/oldworld"
SYNC="rsync://oldworld.fr/gentoo-portage"
USE="X a52 aac acl alsa altivec avahi berkdb bluetooth branding bzip2 cairo cddb cdr cjk cli consolekit cracklib crypt curl cxx dbus dri dvd emboss encode evo fam firefox flac fontconfig fortran gdbm gif gnutls gstreamer gtk hal iconv imagemagick imlib jpeg latex libnotify mad matroska mikmod mng modules mp3 mp4 mpeg mudflap musepack ncurses nls nocd nodrm nptl nptlonly ogg openal opengl openmp pam pcre pdf perl png ppc ppds pppd python qt3support readline reflection ruby sdl session speex spell spl ssl startup-notification svg symlink sysfs tcpd tetex theora thunar tiff truetype unicode usb userlocales videos vim-syntax vorbis wifi x264 xcomposite xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nouveau" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2010-04-15 13:00:46 UTC
Comment on attachment 221189 [details]
libkate-3.7 Build log

Confirmed on both HPPA and x86.
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2010-04-15 13:12:18 UTC
jeroen@astrid /var/tmp/portage/media-libs/libkate-0.3.7/work/libkate-0.3.7/tests $ /usr/bin/i686-pc-linux-gnu-nm ../lib/.libs/*.{a,so} | grep "^[0-9a-z]\{8\} [A-MO-Z] [^\.]" | grep -v "^.\{11\}_" | grep -v "^.\{11\}kate_"
00000000 r default_bitmap.3824
000000a0 r default_region.3803
00000040 r default_style.3810
00000000 r mask
00000f10 t get_zero
0000efe0 r default_bitmap.3824
0000f080 r default_region.3803
0000f020 r default_style.3810
0000e9c0 t get_zero
0000f1c0 r mask
jeroen@astrid /var/tmp/portage/media-libs/libkate-0.3.7/work/libkate-0.3.7/tests $ echo $?                                                                                    0

According to tests/Makefile this test ought to fail (probably somewhere in that pipeline) but obviously it doesn't. I cannot reproduce this on a stable amd64 system, so that might be a clue.
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2010-04-15 13:15:00 UTC
On that amd64 system, the same command gives me no output:

# nm -B ../lib/.libs/*.{a,so} | grep "^[0-9a-z]\{8\} [A-MO-Z] [^\.]" | grep -v "^.\{11\}_" | grep -v "^.\{11\}kate_"
# 
Comment 10 Rick Farina (Zero_Chaos) gentoo-dev 2012-10-10 03:20:22 UTC
All versions in tree pass tests for me as of right now. Please verify if this still is an issue.
Comment 11 Jeroen Roovers (RETIRED) gentoo-dev 2012-10-10 15:03:46 UTC
In a 0.3.7 build log from February 2012 I didn't see this error on HPPA.
Comment 12 Jonas Stein gentoo-dev 2019-06-01 17:49:05 UTC
media-libs/libkate-0.3.7 is no longer in the tree. Please test and report with current version.