Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 286949 - dev-libs/glib-2.20.5 not detected by some other packages
Summary: dev-libs/glib-2.20.5 not detected by some other packages
Status: VERIFIED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-29 15:44 UTC by Karl Ernst Brunk
Modified: 2009-11-20 21:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Ernst Brunk 2009-09-29 15:44:11 UTC
Todays update made me compile gtk+-2.16.6 and qt-core. Both stoped while checking the installed glib.

gtk+-2.16.6 error :
>>
checking for GLIB - version >= 2.19.7... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
<<<<

qt-core-4.5.2
>>>
Glib auto-detection... ()
compiling glib.cpp
glib.cpp: In function »int main(int, char**)«:
glib.cpp:14: Warnung: »pollfd« is used uninitialized in this function
linking glib
/usr/lib64/libgthread-2.0.so: undefined reference to `clock_gettime'
collect2: ld gab 1 als Ende-Status zurück
make: *** [glib] Fehler 1
Glib disabled.
Glib support cannot be enabled due to functionality tests!
<<<<


Reproducible: Always

Steps to Reproduce:
1.emerge gtk+ or qt-core
2.
3.

Actual Results:  
compile stops when checking glib

Expected Results:  
comiling fine

I report this to qt-core also and did already comment #285586
Kalr
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-09-29 16:18:54 UTC
emerge --info, emerge -pv glib and full config.log of the failing package please.
Comment 2 Romain Perier (RETIRED) gentoo-dev 2009-09-29 17:08:20 UTC
and output of the following command : 
$ pkg-config glib-2.0 --modversion

to be sure, however, with glib-2.22.0 it's should works just fine.
Comment 3 Karl Ernst Brunk 2009-09-30 16:15:50 UTC
I will try to send the neede infos. But i will have to reverse my workaround :
did find a bug year 2007 about the same error messages delivered by some programs pointing at libgthread-2.0.so.
(/usr/lib64/libgthread-2.0.so: undefined reference to `clock_gettime')
This message also comes up when trying to start thunar. It wont start and give exactly that message.
The workaround two years ago does work also now :
Compile glib with LDFLAGS=-lrt and all is fine. All failing programs can finish there build.
So i will revert that and send over those messages. This will probably take two days.
Thanks so long
Karl
Comment 4 Karl Ernst Brunk 2009-10-11 15:20:44 UTC
Sorry for the time passed by but i had to do some further investigations before pointing at some nonexisting problems.
So at the end i had around 15 packages all stopping compiling at the same point when checking clock_gettime. The intermediate workarround LDFLAGS="-lrt worked till openoffice showed up. No chance.
So i had to look for another solution. After all i had to rebuild gcc and all openmp using or depending packages. That solved it.
So the conclusion for my system is not to use CFLAG -fopenmp and USE-Flag openmp.
I know that there are some warnings about those Flags but they never accompanied with any info : why not. And in the beginning it did seem to work.
So sorry for the hazzle.
Karl
BTW. where is 2.22.0 ? Overlay ? 
Comment 5 Romain Perier (RETIRED) gentoo-dev 2009-10-11 16:03:18 UTC
yep glib-2.22 is in the overlay
Comment 6 Bruno Santos 2009-11-20 21:12:43 UTC
The flag -fopenmp cause pixman (libpixman) not working and as a result, xfce works very bad...
Eclipse didn't work, with the following error: symbol lookup error: /usr/lib/libgthread-2.0.so.0: undefined symbol: clock_gettime 

Openoffice.org didn't compiled either...

Removing it from CFLAGS and recompilet glib did the trick.... Even unmasking glib-2.22.2 didn't work when using -fopenmp