Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 286260 - dev-db/postgresql-server-8.4.1 fails to compile: cannot find -lpgport
Summary: dev-db/postgresql-server-8.4.1 fails to compile: cannot find -lpgport
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: PgSQL Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 285475
  Show dependency tree
 
Reported: 2009-09-24 16:39 UTC by Carlos Konstanski
Modified: 2010-01-26 20:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.og (build.log,257.37 KB, text/plain)
2009-10-09 14:17 UTC, Carlos Konstanski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Konstanski 2009-09-24 16:39:29 UTC
dev-db/postgresql-server-8.4.1 [8.3.8] USE="nls perl python xml -doc (-selinux) -tcl -uuid" LINGUAS="de -af -cs -es -fa -fr -hr -hu -it -ko -nb -pl -pt_BR -ro -ru -sk -sl -sv -tr -zh_CN -zh_TW"

This happens on only one of my machines.  I even set make options to -j1, which often helps with problems having to do with undetected dependencies.  But not this time.

A snippet of the build:

make[4]: Entering directory `/var/tmp/portage/dev-db/postgresql-server-8.4.1/work/postgresql-8.4.1/src/port'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/var/tmp/portage/dev-db/postgresql-server-8.4.1/work/postgresql-8.4.1/src/port'
x86_64-pc-linux-gnu-gcc -march=k8 -O2 -msse3 -pipe -Wall -Wmissing-prototypes -Wpointer-arith -Wdeclaration-after-statement -Wendif-labels -fno-strict-aliasing -fwrapv -I../../../src/include -DFRONTEND -I../../../src/interfaces/libpq -I../../../src/include -D_GNU_SOURCE -I/usr/include/libxml2  -I/usr/include/postgresql-8.4/  -c -o initdb.o initdb.c -MMD -MP -MF .deps/initdb.Po
rm -f encnames.c && ln -s ../../../src/backend/utils/mb/encnames.c .
x86_64-pc-linux-gnu-gcc -march=k8 -O2 -msse3 -pipe -Wall -Wmissing-prototypes -Wpointer-arith -Wdeclaration-after-statement -Wendif-labels -fno-strict-aliasing -fwrapv -I../../../src/include -DFRONTEND -I../../../src/interfaces/libpq -I../../../src/include -D_GNU_SOURCE -I/usr/include/libxml2  -I/usr/include/postgresql-8.4/  -c -o encnames.o encnames.c -MMD -MP -MF .deps/encnames.Po
rm -f pqsignal.c && ln -s ../../../src/interfaces/libpq/pqsignal.c .
x86_64-pc-linux-gnu-gcc -march=k8 -O2 -msse3 -pipe -Wall -Wmissing-prototypes -Wpointer-arith -Wdeclaration-after-statement -Wendif-labels -fno-strict-aliasing -fwrapv -I../../../src/include -DFRONTEND -I../../../src/interfaces/libpq -I../../../src/include -D_GNU_SOURCE -I/usr/include/libxml2  -I/usr/include/postgresql-8.4/  -c -o pqsignal.o pqsignal.c -MMD -MP -MF .deps/pqsignal.Po
x86_64-pc-linux-gnu-gcc -march=k8 -O2 -msse3 -pipe -Wall -Wmissing-prototypes -Wpointer-arith -Wdeclaration-after-statement -Wendif-labels -fno-strict-aliasing -fwrapv -I../../../src/include initdb.o encnames.o pqsignal.o  -L../../../src/port -Wl,-O1  -Wl,--as-needed -Wl,-rpath,'/usr/lib64/postgresql-8.4/lib64' -lpgport -lxslt -lxml2 -lpam -lssl -lcrypto -lz -lreadline -lcrypt -ldl -lm  -o initdb
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lpgport

Reproducible: Always




Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30.3 x86_64)
=================================================================
System uname: Linux-2.6.30.3-x86_64-AMD_Phenom-tm-_9850_Quad-Core_Processor-with-gentoo-1.12.11.1
Timestamp of tree: Thu, 24 Sep 2009 12:00:02 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -msse3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -msse3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US"
LDFLAGS="-Wl,-O1"
LINGUAS="de en en_US"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/lisp /usr/portage/local/layman/java-overlay"
SYNC="rsync://sphinktoo.pippiandcarlos.com/gentoo-portage"
USE="3dnow 3dnowext 3dnowprefetch X a52 aac acl acpi alsa amd64 apache2 berkdb bitmap-fonts bluetooth branding browserplugin bzip2 cairo cdr cli consolekit cracklib crypt cups curl dbus dri dts dvd dvdr eds emacs emboss encode evo fam ffmpeg firefox flac fortran gd gdbm gif gnutls gpm gstreamer gtk gtkhtml guile hal hddtemp iconv imagemagick imap isdnlog jack java java6 jbig jpeg jpeg2k latex ldap libnotify libwww lm_sensors mad maildir mikmod mmx mmxext mng modules motif mozilla mp3 mp4 mpeg mudflap multilib ncurses networking nls nptl nptlonly nsplugin odbc ogg opengl openmp oss pam pcre pdf perl pic png postgres ppds pppd python qt3support qt4 quicktime readline reflection sasl sdl session source spell spl sse sse2 sse3 sse4a ssl startup-notification svg sysfs tcltk tcpd tetex threads thunar tiff truetype truetype-fonts type1-fonts unicode urandom usb v4l v4l2 vim vorbis webkit x264 xattr xft xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Wormo (RETIRED) gentoo-dev 2009-10-09 06:55:41 UTC
Please attach the full build log from a failed attempt. Also, how about posting 'emerge --info' for one of your machines where the same build does work, for comparison?
Comment 2 Carlos Konstanski 2009-10-09 14:17:23 UTC
Created attachment 206530 [details]
build.og
Comment 3 Carlos Konstanski 2009-10-09 14:19:36 UTC
emerge --info from a successful installation on another amd64 machine:

root@sphinktoo:~# emerge --info
Portage 2.1.6.13 (default/linux/amd64/10.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30.3 x86_64)
=================================================================
System uname: Linux-2.6.30.3-x86_64-AMD_Athlon-tm-_64_Processor_3000+-with-gentoo-1.12.11.1
Timestamp of tree: Fri, 09 Oct 2009 11:30:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=k8"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US"
LDFLAGS="-Wl,-O1"
LINGUAS="de en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/lisp /usr/portage/local/layman/java-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 apache2 berkdb bluetooth branding browserplugin bzip2 cairo cdr cli consolekit consolekiti cracklib crypt cups curl dbus dri dts dvd dvdr eds emacs emboss encode evo fam ffmpeg firefox firefox3 flac fortran gd gdbm gif gnutls gpm gstreamer gtk gtkhtml guile h323 hal iconv imagemagick imap ipv6 isdnlog jack java java6 jbig jpeg jpeg2k latex libnotify libwww lm_sensors mad maildir mikmod mmx mmxext mng mod modules motif mozilla mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin odbc ogg opengl openmp oss pam pcre pdf perl pic png pni postgres ppds pppd python qt3support qt4 quicktime readline reflection ruby samba sasl sdl session sip source spell spl sse sse2 sse3 ssl startup-notification svg sysfs tcltk tcpd tetex threads thunar tiff truetype unicode urandom usb v4l v4l2 vim vorbis wav webkit x264 xattr xft xinerama xml xmms xorg xulrunner xv xvid zlib" ALSA_CARDS="nvidia" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Roman Tataurov 2009-10-11 13:46:09 UTC
(In reply to comment #0)

I got absolutely the same trouble 
In my case it was resolved by running 2 commands

eselect postgresql set-all 8.4
eselect update

Hope this will help :)
Comment 5 Roman Tataurov 2009-10-11 13:47:16 UTC
> 
> eselect postgresql set-all 8.4
> eselect update
> 
Sorry - my mistype

eselect postgresql set-all 8.4
eselect postgresql update
Comment 6 Ole Langbehn 2009-10-12 08:36:25 UTC
Proposed fix works for me. Thanks.