Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 285436 - app-text/xpdf-3.02-r3 -reload crashes
Summary: app-text/xpdf-3.02-r3 -reload crashes
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Printing Team
Depends on:
Reported: 2009-09-18 12:36 UTC by Kevin Bryan
Modified: 2010-02-18 23:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Bryan 2009-09-18 12:36:05 UTC
xpdf -remote doc file.pdf &
xpdf -remote doc -reload

The second command causes: 
*** glibc detected *** xpdf: double free or corruption (out): 0x080b95a0 ***

valgrind reports it as:

==2504== Invalid read of size 4
==2504==    at 0x40D3DD6: BuiltinFontWidths::~BuiltinFontWidths() (
==2504==    by 0x40D3F95: freeBuiltinFontTables() (
==2504==    by 0x41204D9: GlobalParams::~GlobalParams() (
==2504==    by 0x8072C07: main (
==2504==  Address 0x4bd5560 is 0 bytes inside a block of size 8 free'd
==2504==    at 0x4024ACB: operator delete(void*) (in /usr/lib/valgrind/x86-linux/
==2504==    by 0x40D3F9D: freeBuiltinFontTables() (
==2504==    by 0x8055ABD: GlobalParamsGUI::~GlobalParamsGUI() (
==2504==    by 0x8072BE1: main (

It looks like both ~GlobalParamsGUI and ~GlobalParams are calling freeBuiltinFontTables, so the second call is failing.  I'm not sure about the rest of the code, so I don't know if it's necessary to have both objects in xpdf.  By the names of the classes, it seems like it should use one or the other, but not both.

Portage 2.2_rc40 (default/linux/x86/2008.0/desktop, gcc-4.4.1, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r4 i686)

CFLAGS="-O2 -march=native -mtune=native -pipe"
CXXFLAGS="-O2 -march=native -mtune=native -pipe"
app-text/xpdf: Installed versions:  3.02-r3(10:30:17 09/16/09)(-debug -nodrm)
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2010-02-16 21:39:42 UTC
Please try with poppler-0.12.3-r5 and xpdf-3.02-r4 and if it still doesn't work, reopen the bug
Comment 2 Kevin Bryan 2010-02-18 23:06:23 UTC
Yes, it works now; thanks.