Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 285094 - mount: block device /dev/hdc is write-protected, mounting read-onl
Summary: mount: block device /dev/hdc is write-protected, mounting read-onl
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: Sparc64 Linux
: High normal (vote)
Assignee: Daniel Gryniewicz (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-15 14:30 UTC by Sergey
Modified: 2009-09-17 11:40 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey 2009-09-15 14:30:23 UTC
mount: block device /dev/hdc is write-protected, mounting read-onl

dmesg|tail
[ 2285.713031] hdc: possibly failed opcode: 0xa0
[ 2285.714757] end_request: I/O error, dev hdc, sector 118352
[ 2285.714770] Buffer I/O error on device hdc, logical block 14794
[ 2285.914537] hdc: command error: status=0x51 { DriveReady SeekComplete Error }
[ 2285.914554] hdc: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
[ 2285.914565] hdc: possibly failed opcode: 0xa0
[ 2285.925439] end_request: I/O error, dev hdc, sector 118352
[ 2285.925452] Buffer I/O error on device hdc, logical block 14794
[ 2286.129332] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 2286.172026] ISO 9660 Extensions: RRIP_1991A



Reproducible: Always

Steps to Reproduce:
1. emerge HAL
2. emerge UDEV
3.
Comment 1 Rafał Mużyło 2009-09-15 16:16:47 UTC
And your problem is....?
Comment 2 Sergey 2009-09-16 06:00:10 UTC
cd-rom not mount.
Comment 3 Rafał Mużyło 2009-09-16 12:31:33 UTC
In you case, I'm making an exception: 'emerge --info' first,
then your versions of hal and udev.

But if you're in unstable, you've probably failed to rebuild
hal, after udev upgrade.
Comment 4 Sergey 2009-09-16 12:39:28 UTC
emerge --info
Portage 2.1.6.13 (default/linux/sparc/2008.0, gcc-4.3.4, glibc-2.9_p20081201-r3, 2.6.31-gentoo sparc64)
=================================================================
System uname: Linux-2.6.31-gentoo-sparc64-sun4u-with-gentoo-2.0.1
Timestamp of tree: Wed, 16 Sep 2009 06:00:01 +0000
app-shells/bash:     4.0_p33
dev-lang/python:     2.6.2-r1, 3.1.1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="sparc ~sparc"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=v9 -mtune=ultrasparc3 -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=v9 -mtune=ultrasparc3 -pipe"
DISTDIR="/opt/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo "
LANG="ru_RU.KOI8-R"
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/opt/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa berkdb bzip2 cli cracklib crypt cups dri fbdev fortran gcc64 gdbm gpm hal iconv isdnlog kde mozilla mudflap ncurses nls nptl nptlonly openmp pam pcre perl pop pppd python qt3 readline reflection samba session sparc spl ssl sysfs tcpd unicode xorg zlib" ALSA_CARDS="all" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

sys-fs/udev-145-r1
sys-apps/hal-0.5.13-r2 
Comment 5 Sergey 2009-09-16 13:28:32 UTC
emerge sys-fs/udev-145-r1
emerge  sys-apps/hal-0.5.13-r2

mount /dev/cdrom /mnt/cdrom freeze mount... and dmesg|tail
[86710.958935] hdc: possibly failed opcode: 0xa0
[86710.964969] end_request: I/O error, dev hdc, sector 118352
[86710.964982] Buffer I/O error on device hdc, logical block 29588
[86710.964995] Buffer I/O error on device hdc, logical block 29589
[86711.156124] hdc: command error: status=0x51 { DriveReady SeekComplete Error }
[86711.156140] hdc: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
[86711.156152] hdc: possibly failed opcode: 0xa0
[86711.165383] end_request: I/O error, dev hdc, sector 118352
[86711.165397] Buffer I/O error on device hdc, logical block 29588
[86711.165407] Buffer I/O error on device hdc, logical block 29589

Comment 6 Sergey 2009-09-16 13:30:11 UTC
emerge sys-fs/udev-111
emerge  sys-apps/hal-0.5.11-r9
Comment 7 Rafał Mużyło 2009-09-17 10:27:38 UTC
I missed, that you're on sparc.
I'm on x86, so I really can't tell what your problem can be
- those versions are quite old here, especially udev.
Comment 8 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-09-17 10:35:22 UTC
You say "cdrom doesn't mount" as your problem, but you've given a lot of text without reference to why.

Comments 5 and 6 give different hal and udev versions.

1. Does "mount /dev/hdc /mnt/cdrom" as root?
2. Does the CD work on another machine?
3. Is there some combination of udev+HAL where it DID work before and does not work after you upgrade?
4. Can you provide us with the TOC for the CD?
5. Does the CDROM drive work on another machine?

Please reopen when you give us more information on tracing where the problem is. Beyond that I strongly suspect hardware issues in your machine.
Comment 9 Gilles Dartiguelongue gentoo-dev 2009-09-17 11:40:00 UTC
kernel messages tends to make me think that your drive is dead or dying.