Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 284678 - net-analyzer/smokeping depends on recent version of dejavu and pango
Summary: net-analyzer/smokeping depends on recent version of dejavu and pango
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
: 282329 290753 327533 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-12 12:09 UTC by Dominik
Modified: 2010-08-27 13:31 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik 2009-09-12 12:09:20 UTC
After the last "emerge -uD world" there was also updates for net-analyzer/rrdtool and net-analyzer/smokeping installed.

After that the graphs which are generated by this tools didnt work anymore, because the description of the x-axis and y-axis was missing and showed only some strange [].

A friend of mine told me that this effects also munin and that i need to do "emerge pango dejavu". After that the graphs works fine again.

So I think that the dependencies for rrdtool/smokeping/munin etc. pp. should be fixed.

Thanks

Reproducible: Always
Comment 1 Justin Lecher (RETIRED) gentoo-dev 2009-09-14 19:54:32 UTC
Please state clearly which version of pango dejavu doesn't work with which versions of net-analyzer/rrdtool and net-analyzer/smokeping and munin.
Comment 2 Dominik 2009-09-14 21:39:07 UTC
net-analyzer/smokeping (Version 2.2.4) and other rrdtool (Version 1.3.8) based software doesnt work correctly without installing the actual version of pango and dejavu
Comment 3 Justin Lecher (RETIRED) gentoo-dev 2009-09-15 06:03:08 UTC
Thanks for this addition, but we need two separate bugs for each package. You can refer to this one.
I renamed this bug to only address rddtool and assign it to maintainer. If you can, please provide more information what actually happens if those packages aren't installed.
Comment 4 Peter Volkov (RETIRED) gentoo-dev 2009-10-26 13:22:41 UTC
rrdtool-2.24 does not exists in the tree.

I guess that you are talking about rddtool-3.x. This version really uses pango and requires some font to be installed on the system and that's what you've been told after installing rrdtool:

ewarn "Note: rrdtool-1.3.x doesn't have any default font bundled. Thus if you've"
ewarn "upgraded from rrdtool-1.2.x and don't have any font installed to make"
ewarn "lables visible, please, install some font, e.g. media-fonts/dejavu."

Just to clarify. I'm not going to add any font as a dependency since I don't see any difference to desktop applications here, which don't depend on any font although it's impossible to use them without some nice fonts installed.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2009-10-26 13:54:33 UTC
(In reply to comment #2)
> net-analyzer/smokeping (Version 2.2.4) and other rrdtool (Version 1.3.8) based
> [...]
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-02-01 00:38:29 UTC
*** Bug 282329 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-02-01 00:43:08 UTC
Jeroen, No reason to re-open. Closing, again per comment #4. There is an elog message telling you to install some fonts.

There are a number of fonts that will work. corefonts, dejavu, liberation-fonts, the list continues...
Comment 8 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-02-01 00:46:28 UTC
*** Bug 290753 has been marked as a duplicate of this bug. ***
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2010-02-01 01:12:33 UTC
(In reply to comment #7)
> Jeroen, No reason to re-open. Closing, again per comment #4. There is an elog
> message telling you to install some fonts.

I reopened it because the first remark in comment #4 is plain wrong.
Comment 10 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-02-01 03:23:13 UTC
(In reply to comment #9)
> (In reply to comment #7)
> > Jeroen, No reason to re-open. Closing, again per comment #4. There is an elog
> > message telling you to install some fonts.
> 
> I reopened it because the first remark in comment #4 is plain wrong.
> 

Ok, well..read the elog message then and install some fonts.
Comment 11 Dominik 2010-02-01 07:20:51 UTC
I changed the summary to net-analyzer/smokeping instead of rrdtool.
smokeping doesnt work without a font, so there should one default.
Comment 12 Peter Volkov (RETIRED) gentoo-dev 2010-02-01 07:42:25 UTC
Dominik don't reopen this bug report. You are supposed to read elog messages and if you don't you are on your own.
Comment 13 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-07-08 20:42:33 UTC
*** Bug 327533 has been marked as a duplicate of this bug. ***
Comment 14 Gabor Garami 2010-08-27 13:31:11 UTC
I think #4 is not enough to not to add dejavu as RDEPEND, because desktop applications depends on some other packages which depends on some fonts, so this is totally wrong argument. If you install desktop application, you implicite have some desktop environment, what is depends on some fonts. But, rrdtool is not a desktop application, so you may not have installed desktop environment (e.g. on servers). And because nor cairo/pango, nor rrdtool doesn't depends on fonts, the rrdtool willn't working correctly after installation.