Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 284509 - app-office/openoffice-3.1.1 ugly unusable interface colors when using dark KDE4 theme
Summary: app-office/openoffice-3.1.1 ugly unusable interface colors when using dark KD...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Office Team
Depends on:
Reported: 2009-09-10 16:28 UTC by DrSlony
Modified: 2009-09-22 11:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

The problem. (20090910_kde431_go-oo311_dark_theme.png,143.67 KB, image/png)
2009-09-10 16:29 UTC, DrSlony
How things should look, except for the light theme of course. (20090910_kde431_go-oo311_light_theme.png,191.01 KB, image/png)
2009-09-10 16:30 UTC, DrSlony
My dark KDE4 color scheme. This problem persists in all other dark themes I tried too. (DrSlonyColdAsh.colors,2.27 KB, text/plain)
2009-09-10 16:31 UTC, DrSlony

Note You need to log in before you can comment on or make changes to this bug.
Description DrSlony 2009-09-10 16:28:23 UTC
app-office/openoffice-3.1.1 handles my KDE4 dark theme very poorly. The menu font color is black, the menu background is very dark grey, which makes things unreadable. Notes in oowriter are also black font/very dark grey background. Unreadable. Can't change this in tools > options > ooo > appearance.
The icons are all very ugly and high contrast too.
Tools > options > ooo > accessibility has "automatically detect high contrast mode of operating system" turned off. It used to be on, I was told to try turning it off, I did, nothing helped.
Tools > options > ooo > view - changing the icon style makes no difference. I see Galaxy (default), High Contrasty, Industrial, Crystal, Tango, Classic and Oxygen in the list, but it makes no difference which one I try. 
I'm fairly certain I did not have these problems with 3.1.0-r1.

Link to my KDE4 color scheme:

Reproducible: Always

Steps to Reproduce:
1. emerge app-office/openoffice-3.1.1
2. use a dark KDE4 color scheme. Try mine. 
3. fire up oowriter or oocalc (havent tried others)

Actual Results:
Ugly high contrast icons, unreadable notes, unreadable menus, some other things like note pointers are missing.

Expected Results:  
Here is what it looks like when I use a light theme:
Notice the completely different icons and other changes.

Portage 2.2_rc40 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.10.1-r0, 2.6.30-gentoo-r4 x86_64)
System uname: Linux-2.6.30-gentoo-r4-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-
Timestamp of tree: Thu, 10 Sep 2009 10:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r2
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
CFLAGS="-march=nocona -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
FEATURES="assume-digests ccache collision-protect distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/berkano /usr/local/portage/layman/voyageur /usr/local/portage/layman/roslin /usr/local/portage/layman/sunrise /usr/local/portage"
USE="X a52 aac aalib acl acpi additions alsa amd64 apache2 apm archive avi bash-completion berkdb bitmap-fonts bluetooth branding bzip2 cairo cddb cdr cli cracklib crypt cups dbus devil dhcp divx djvu dlloader dns dri dts dv dvd dvdr dvdread embedded emboss enblend enca encode esd evo exif fam ffmpeg fftw firefox flac fortran gadu gdbm gif gimp glitz gmedia gnutls gphoto2 gpm gstreamer gtk gtk2 gtkhtml h323 hal hdri iconv imagemagick ipv6 isdnlog java jpeg jpeg2k kde kdeenablefinal lcms ldap libg++ libnotify libsamplerate mad melt mikmod mmx mng modplug mp2 mp3 mp4 mpeg mplayer mudflap multilib musepack mysql ncurses nls npp nptl nptlonly nsplugin nvidia ogg openexr opengl openmp oss pam pcre pdf pdflib perl pipechan png portaudio ppds pppd python qt3 qt3support qt4 quicktime raw rdp readline realmedia reflection scanner sdl session sid sift sip smp sound speex spell spl sql sqlite srt sse sse2 ssl ssse3 startup-notification svg symlink sysfs tcpd theora threads thunar tiff truetype truetype-fonts type1-fonts udev unicode usb v4l v4l2 video vnc vorbis wav webkit wmp x264 xcb xcomposite xml xorg xulrunner xv xvid xvmc zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia"

drslony@budgie ~ $ cat /etc/portage/package.keywords | grep -i openoffice
app-office/openoffice ~amd64
app-office/openoffice ~amd64
drslony@budgie ~ $ cat /etc/portage/package.use | grep -i openoffice
app-office/openoffice -gtk
Comment 1 DrSlony 2009-09-10 16:29:25 UTC
Created attachment 203685 [details]
The problem.
Comment 2 DrSlony 2009-09-10 16:30:10 UTC
Created attachment 203686 [details]
How things should look, except for the light theme of course.
Comment 3 DrSlony 2009-09-10 16:31:38 UTC
Created attachment 203687 [details]
My dark KDE4 color scheme. This problem persists in all other dark themes I tried too.
Comment 4 Andreas Proschofsky (RETIRED) gentoo-dev 2009-09-22 09:08:23 UTC
This is really something for upstream, nothing we as a distro can do here. Please file this at:
Comment 5 DrSlony 2009-09-22 11:21:36 UTC
hmm, but this is about GO-OO, not OOo, so where do I file that?

app-office/openoffice-bin -
app-office/openoffice -
Comment 6 Andreas Proschofsky (RETIRED) gentoo-dev 2009-09-22 11:25:50 UTC
(In reply to comment #5)
> hmm, but this is about GO-OO, not OOo, so where do I file that?
> app-office/openoffice-bin -
> app-office/openoffice -

Go-OO is based on OOo and in this case the patches are handled upstream, so they should take it (see the link I provided). If not then the next stop is , which handles go-oo-bugs. Yeah. Complicated :-(