Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 283955 - Please stabilize =media-libs/glfw-2.6
Summary: Please stabilize =media-libs/glfw-2.6
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2009-09-07 08:14 UTC by Pierre
Modified: 2010-02-26 13:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre 2009-09-07 08:14:09 UTC
There is no open bugs
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2009-09-07 22:13:13 UTC
Version to stabilize?
Reopen at your convenience.
Comment 2 Pierre 2009-09-08 17:19:22 UTC
2.6
Comment 3 Samuli Suominen gentoo-dev 2009-09-12 10:31:20 UTC
@games: If you agree, CC amd64 and x86.
Comment 4 Christian Faulhammer (RETIRED) gentoo-dev 2009-11-19 10:06:32 UTC
gcc -c -I. -I..  -Dlinux  -D_GLFW_HAS_XF86VIDMODE -pthread -D_GLFW_HAS_PTHREAD -D_GLFW_HAS_SCHED_YIELD -D_GLFW_HAS_GLXGETPROCADDRESS -D_GLFW_HAS_GLXGETPROCADDRESSARB -D_GLFW_HAS_DLOPEN -D_GLFW_HAS_SYSCONF -Os -Wall -o x11_fullscreen.o x11_fullscreen.c
x11_fullscreen.c: In function ‘_glfwGetClosestVideoMode’:
x11_fullscreen.c:169: error: ‘h’ undeclared (first use in this function)
x11_fullscreen.c:169: error: (Each undeclared identifier is reported only once
x11_fullscreen.c:169: error: for each function it appears in.)
make[1]: *** [x11_fullscreen.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/media-libs/glfw-2.6/work/glfw/lib/x11'
make: *** [x11] Error 2
Comment 5 Myckel Habets (work) 2010-01-02 10:09:51 UTC
Build successfully on x86 (stable x86 with FEATURES="test collision-protect"). Ran a few demo programs from the package, no problems encountered.

Unable to reproduce the build failure in Comment #4 (caused by XF86VIDMODE/XRANDR flag?):
gcc -c -I. -I..  -Dlinux  -D_GLFW_HAS_XRANDR -pthread -D_GLFW_HAS_PTHREAD -D_GLFW_HAS_SCHED_YIELD -D_GLFW_HAS_GLXGETPROCADDRESS -D_GLFW_HAS_GLXGETPROCADDRESSARB -D_GLFW_HAS_DLOPEN -D_GLFW_HAS_SYSCONF -Os -Wall -o x11_fullscreen.o x11_fullscreen.c
Comment 6 Christian Faulhammer (RETIRED) gentoo-dev 2010-01-03 21:36:08 UTC
x86 stable, thanks Thomas
Comment 7 Markos Chandras (RETIRED) gentoo-dev 2010-01-05 13:34:56 UTC
Stable on amd64

All arches done