Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 283348 - gpe-utils/gpe-ownerinfo-0.28 fails due to missing -lGL LDFLAGS
Summary: gpe-utils/gpe-ownerinfo-0.28 fails due to missing -lGL LDFLAGS
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: GPE Desktop Herd
URL:
Whiteboard:
Keywords:
Depends on: 283339
Blocks:
  Show dependency tree
 
Reported: 2009-08-31 17:44 UTC by Christopher Friedt
Modified: 2009-09-22 21:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,11.71 KB, text/plain)
2009-08-31 17:44 UTC, Christopher Friedt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Friedt 2009-08-31 17:44:05 UTC
This is exactly the same thing that happened while building libgpewidgets-0.117-r1, in bug #283339. 

Check out the attached build.log, and see bug #283339 for some suggestions.

Reproducible: Always

Steps to Reproduce:
1.cross-compile gpe-utils/gpe-ownerinfo-0.28
2.
3.
Comment 1 Christopher Friedt 2009-08-31 17:44:38 UTC
Created attachment 202813 [details]
build.log
Comment 2 solar (RETIRED) gentoo-dev 2009-09-04 14:58:13 UTC
This package does not need to link with opengl directly. 
Comment 3 Christopher Friedt 2009-09-04 15:09:43 UTC
(In reply to comment #2)
> This package does not need to link with opengl directly. 
> 

That's what makes it a bit tricky...

I don't see any other 'smooth' way around it aside from inserting -lGL into cairo.pc from the cairo ebuild. So it could be considered a bug in cairo. 

An alternative is to add a test to some aspect of the configure process to see if the -lGL flag is necessary to build a cairo-linked binary, and insert that into the resulting Makefile, as appropriate, but that might be a lot of work for each of the gpe-* apps that doesn't build. 
Comment 4 solar (RETIRED) gentoo-dev 2009-09-04 15:24:11 UTC
try with the linker flag -Wl,--as-needed on all of the pkgs in question.
Comment 5 Christopher Friedt 2009-09-04 15:49:42 UTC
(In reply to comment #4)
> try with the linker flag -Wl,--as-needed on all of the pkgs in question.
> 

still no dice
Comment 6 Angelo Arrifano (RETIRED) gentoo-dev 2009-09-04 15:56:39 UTC
Can you do 

armv5tel-softfloat-linux-gnueabi-scanelf -n /usr/armv5tel-softfloat-linux-gnueabi/usr/lib/{libglitz,libglitz-glx,libgtk-x11,libcairo}.so ?

Thanks,
Comment 7 Christopher Friedt 2009-09-04 16:31:37 UTC
I've actually tried compiling the program natively, so cross-compiling is not an issue. On the hose machine, I've got

ET_DYN libm.so.6,libgcc_s.so.1,libc.so.6 /usr/lib/libglitz.so 
ET_DYN libglitz.so.1,libX11.so.6,libGL.so.1,libpthread.so.0,libc.so.6 /usr/lib/libglitz-glx.so 
ET_DYN libpixman-1.so.0,libfreetype.so.6,libfontconfig.so.1,libglitz-glx.so.1,libGL.so.1,libpthread.so.0,libglitz.so.1,libpng12.so.0,libxcb-render-util.so.0,libxcb-render.so.0,libxcb.so.1,libXrender.so.1,libX11.so.6,libz.so.1,libm.so.6,libgcc_s.so.1,libc.so.6 /usr/lib/libcairo.so

/usr/lib/libgtk-x11.so does not exist (I guess it would be a symlink?) but rather 

/usr/lib/libgtk-x11-2.0.so -> libgtk-x11-2.0.so.0.1600.5
/usr/lib/libgtk-x11-2.0.so.0 -> libgtk-x11-2.0.so.0.1600.5
/usr/lib/libgtk-x11-2.0.so.0.1600.5

for that so, scanelf gives

ET_DYN libgdk-x11-2.0.so.0,libXrandr.so.2,libXcursor.so.1,libgdk_pixbuf-2.0.so.0,libpangocairo-1.0.so.0,libuuid.so.1,libxcb-xlib.so.0,libXcomposite.so.1,libXdamage.so.1,libXfixes.so.3,libatk-1.0.so.0,libcairo.so.2,libpixman-1.so.0,libglitz-glx.so.1,libGL.so.1,libSM.so.6,libICE.so.6,libXmu.so.6,libXt.so.6,libXext.so.6,libXi.so.6,libpthread.so.0,libglitz.so.1,libpng12.so.0,libxcb-render-util.so.0,libxcb-render.so.0,libxcb.so.1,libXrender.so.1,libX11.so.6,libXau.so.6,libXdmcp.so.6,libgio-2.0.so.0,libpangoft2-1.0.so.0,libpango-1.0.so.0,libfontconfig.so.1,libfreetype.so.6,libz.so.1,libexpat.so.1,libgobject-2.0.so.0,libgmodule-2.0.so.0,libdl.so.2,libglib-2.0.so.0,libm.so.6,libc.so.6 /usr/lib/libgtk-x11-2.0.so.0.1600.5
Comment 8 Angelo Arrifano (RETIRED) gentoo-dev 2009-09-22 21:17:13 UTC
Sorry, I can't reproduce it. Since the problem isn't on gpe-ownerinfo, I'm going to close as cantfix.