Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 283331 - x11-drivers/nvidia-drivers-{180.60,190.18}: if BackingStore is enabled, KDE 4 crashes when opening (context) menus
Summary: x11-drivers/nvidia-drivers-{180.60,190.18}: if BackingStore is enabled, KDE 4...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Doug Goldstein (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-31 13:32 UTC by Frank Steinmetzger
Modified: 2010-11-12 22:38 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Some system infos (info,4.62 KB, text/plain)
2009-08-31 13:40 UTC, Frank Steinmetzger
Details
xsession-errors (xsession-errors,4.85 KB, text/plain)
2009-08-31 13:41 UTC, Frank Steinmetzger
Details
Xorg backtrace (backtrace,1.03 KB, text/plain)
2009-08-31 14:04 UTC, Frank Steinmetzger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Steinmetzger 2009-08-31 13:32:23 UTC
Until now I tried several version of KDE4, 4.2 from portage in the past, 4.4 from kde-testing recently, and now 4.3 from portage (which is why I post here). All of them had the hereby described issue on my laptop:

As soon as I open Konsole, opening any kind of menu (main or popup) is a gamble at best. The same goes for popups like those hints when the mouse stays over a panel plasmoid. X instantly crashes, restarts and gets me back to kdm. I have a suspicion that something with font rendering is borked. Sometimes it works, but mostly it doesn't. At perhaps 30% of sessions, I don't even have to open Konsole: I log in and as first thing want to quit kpowersave (the KDE3 app). So I right-click its tray icon to get the menu -> crash.

Opening programs is no problem, all their controls render normally. It's only the menus and popups that have this issue. Perhaps because they use the same method to get displayed? I also had it _once_ that when launching Konsole, its window background stayed visible, but the usual (for me) black text area did not show up. I see this as another hint that something in Konsole is not right.

I tried disabling desktop effects, but at one time that actually worsened the problem. I couldn't even open Qt3 menus anymore, the only solution I could think of was to delete ~/.kde4.

I had nvidia-drivers-180.60 (newest stable) running, but then tried 190.18 in hope of improvements from NVidia, but to no avail. I did _not_ encounter this problem with XOrg's nv driver. I am not sure where to start with debugging; I compiled all kde-base:4 packages with splitdebug, so I can give you debug information if you tell me where to start.

Reproducible: Sometimes

Steps to Reproduce:
1. Log into kde4 with xserver running on nvidia-drivers
2. Open konsole
3. Open any menu
4. 90% of cases, xserver crashes. If not, then after some more tries.
Actual Results:  
Xorg crashes in almost all attempts to open a menu after Konsole was opened. There are no apparent messages in ~/.xsession-errors or Xorg.*.log

Expected Results:  
Menus and other popping up items should appear without crashing Xorg :-)
Comment 1 Frank Steinmetzger 2009-08-31 13:40:00 UTC
Created attachment 202798 [details]
Some system infos
Comment 2 Frank Steinmetzger 2009-08-31 13:41:05 UTC
Created attachment 202799 [details]
xsession-errors

tail of ~/.xsession-errors for a test session:
login, right-click on KPowersave and close it (did not crash).
Then open Konsole, open one of its main menus -> crash.
Comment 3 Frank Steinmetzger 2009-08-31 14:04:47 UTC
Created attachment 202801 [details]
Xorg backtrace

Just remerged xorg-server with splitdebug, because I saw a lonely backtrace message in Xorg.0.log.old last line. Now I get this backtrace from a crash.
Comment 4 Penetsdorfer Martin 2009-08-31 18:44:16 UTC
I'm a newbie in gentoo, but you can try #revdep-rebuild.
You can also test an another Desktop (fluxbox) to exclude that nvidia-driver and xorg have an error.
Comment 5 Frank Steinmetzger 2009-09-10 08:37:13 UTC
(In reply to comment #4)
> I'm a newbie in gentoo, but you can try #revdep-rebuild.

That was one of the first things I did, of course.

> You can also test an another Desktop (fluxbox) to exclude that nvidia-driver
> and xorg have an error.

I've never had any issues in my years with KDE 3.
Today I got a reply on gentoo.user ML, he said to disable BackingStore in xorg.conf. Now the crashes seem to have gone fortunately. However, with that I wouldn't call the bug fixed, but merely circumvented.
Comment 6 Tomáš Chvátal (RETIRED) gentoo-dev 2009-09-10 09:03:51 UTC
And you expect kde team to fix nvidia driver issues?

@wranglers, plz add nvidia maintainers
Comment 7 Frank Steinmetzger 2009-09-10 09:24:01 UTC
Sorry for my suggestive tone, of course not. But since it really only happened with KDE4, I thought maybe they did something wrong. ;-) I've stumbled upon nvnews.net, where this solution was already mentioned, so I figure NV people know about this already.
Comment 8 Tomáš Chvátal (RETIRED) gentoo-dev 2009-09-10 09:27:05 UTC
(In reply to comment #7)
> Sorry for my suggestive tone, of course not. But since it really only happened
> with KDE4, I thought maybe they did something wrong. ;-)
Think about it the other way around. Nvidia is the only one having issues.
Comment 9 Peter Alfredsen (RETIRED) gentoo-dev 2009-09-10 20:20:35 UTC
Read somewhere that setting:
Option "BackingStore" "False"
Under the Device section in xorg.conf
Comment 10 Peter Alfredsen (RETIRED) gentoo-dev 2009-09-11 08:35:52 UTC
(In reply to comment #9)
> Read somewhere that setting:
> Option "BackingStore" "False"
> Under the Device section in xorg.conf
> 

I wonder what I meant. Too much coffee and over-clickity fingers, probably.
Anyway, nvidia bug. Assigning.
Comment 11 Robert Piasek (RETIRED) gentoo-dev 2009-09-12 21:37:34 UTC
BackingStore doesn't work with nvidia closed drivers for ages now. Enabling this option will cause crashes. It's know nvidia problem and they recommend disabling BackingStore. That should solve the problem (assuming you've got it enabled).

I'm not sure there's anything nvidia maintainers can do about it.
Comment 12 Maciej Mrozowski gentoo-dev 2009-09-13 09:57:40 UTC
Hmm, how about placing in pkg_postinst some detection code that greps for Xorg backing store driver option and warning about it? Or just plain postinst ewarn/elong with no detection.
Comment 13 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-09-13 12:19:46 UTC
(In reply to comment #12)
> Hmm, how about placing in pkg_postinst some detection code that greps for Xorg
> backing store driver option and warning about it? Or just plain postinst
> ewarn/elong with no detection.

Maciej,

detection for user configured files doesn't seem the best option to me.
An ewarn/elog should be enough, imho.
Comment 14 Andreas K. Hüttel archtester gentoo-dev 2010-04-13 22:02:51 UTC
huettel@pinacolada /usr/portage/x11-drivers/nvidia-drivers $ grep -i backing *
huettel@pinacolada /usr/portage/x11-drivers/nvidia-drivers $ 

Hmm any news on this one?

Maybe we could just add the ewarn and be done with it?
On the other hand, I'm running nvidia-drivers without this option right now, and I dont see a flood of duplicate bugs...
Comment 15 Andreas K. Hüttel archtester gentoo-dev 2010-11-12 22:38:05 UTC
All mentioned nvidia-drivers versions are not in the tree anymore. No message for more than a year. Resolving NEEDINFO for the kde team. Anyone who disagrees- please reopen...