Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 283199 - Remove dev-python/uuid
Summary: Remove dev-python/uuid
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Caleb Tennis (RETIRED)
Depends on:
Blocks: 281571
  Show dependency tree
Reported: 2009-08-30 02:46 UTC by Arfrever Frehtes Taifersar Arahesis (RETIRED)
Modified: 2009-08-30 19:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

dev-python/stomper/files/stomper-0.2.2-dont_require_separate_uuid_package.patch (stomper-0.2.2-dont_require_separate_uuid_package.patch,344 bytes, patch)
2009-08-30 02:47 UTC, Arfrever Frehtes Taifersar Arahesis (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-08-30 02:46:47 UTC
dev-python/uuid installs uuid module to site-packages directory. uuid module has been included in Python standard library (in dev-lang/python) since 2.5. suggests that uuid is no longer maintained outside Python standard library. uuid module installed by dev-python/uuid is out-of-date and, in Python >=2.5, it is even *never* used.

$ python -c 'import sys; print(sys.path)'
['', '/usr/lib64/', '/usr/lib64/python2.6', '/usr/lib64/python2.6/plat-linux2', '/usr/lib64/python2.6/lib-tk', '/usr/lib64/python2.6/lib-old', '/usr/lib64/python2.6/lib-dynload', '/usr/lib64/python2.6/site-packages', '/usr/lib64/python2.6/site-packages/FontTools', '/usr/lib64/python2.6/site-packages/Numeric', '/usr/lib64/python2.6/site-packages/PIL', '/usr/lib64/python2.6/site-packages/gtk-2.0', '/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode', '/usr/lib64/portage/pym']

As you can see /usr/lib64/python2.6 is before /usr/lib64/python2.6/site-packages, so /usr/lib64/python2.6/ is always used instead of /usr/lib64/python2.6/site-packages/ isn't available in Python 2.4, but this slot is deprecated and you don't need to support installation of your packages for Python 2.4. Please update dependencies to require Python >=2.5. You can set NEED_PYTHON="2.5" before 'inherit ...' line.

You probably included dependency on dev-python/uuid in net-misc/orbited-0.7.9 only because dev-python/stomper requires separate uuid package. This useless dependency can be easily removed by the attached patch.
Comment 1 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-08-30 02:47:52 UTC
Created attachment 202683 [details, diff]
Comment 2 Caleb Tennis (RETIRED) gentoo-dev 2009-08-30 11:59:44 UTC
bumped and fixed, thanks.
Comment 3 Caleb Tennis (RETIRED) gentoo-dev 2009-08-30 12:02:23 UTC
also, please feel free to remove the uuid package when you are happy.
Comment 4 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-08-30 19:14:28 UTC
(In reply to comment #3)

OK. I have masked dev-python/uuid.